Windows says 1 notification for me ... but there are none

Page 3 of 4 FirstFirst 1234 LastLast

  1. Posts : 78
    Windows 10
       #21

    margrave55 said: View Post
    I finally found my fix.
    From the command line I can run sc query state= all
    If I search the results for these two strings: WpnService and WpnUserService_.
    ... I get two names: WpnService and WpnUserService_7e8d2
    The name of the latter one will vary from time to time. In this case the suffix is 7e8d2. Next time it might be different.

    Anyway ... if I run these four commands, all is well again.
    net stop WpnService
    net start WpnService
    net stop WpnUserService_7e8d2
    net start WpnUserService_7e8d2

    Since I run Cygwin (a Linux emulator), I wrapped up all of that into a script:
    Code:
    for item in WpnService WpnUserService_
    do
      service_name=$(sc query state= all | d2u | grep "$item" | grep "^SERVICE" | sed -e "s/.*: //")
      echo "$service_name"
      echo "y" | net stop  "$service_name"
      echo "y" | net start "$service_name"
    done
    exit 0

    I've been chasing this issue for months. Your narrowing it down to these services is the 1st solution that worked for me margrave55. Specifically it's the WpnUserService_xxxxx service that keeps stopping on me. Running the command you posted to start it got notifications working again, at least for the moment. After 4 to 6 hours of the system running, it stopped again.

    I opened services.msc and found the WpnUserService_xxxxx / 'Windows Push Notifications User Service_xxxxx' startup type set to 'Manual' and the service was stopped. I see for my Home version 1803 it should be set to Automatic. So I set startup set to 'Automatic', started it, and waited. After a number of hours I found the service had stopped again. The Action Center icon had gone white in that time, indicating new notifications. But again, it didn't list any notifications when opened.

    Have you found the issue was permanently fixed for you margrave55? Any suggestions on how I could resolve the issue permanently?
    Last edited by ohante; 28 Nov 2018 at 13:14.
      My ComputerSystem Spec


  2. Posts : 805
    X
    Thread Starter
       #22

    In the week since I discovered this fix the notification problem only recurred once. So this fix is not permanent. I just ran that script to fix things and I'm good (for now).

    The good: I can run a script to restore proper operation, rather than logout/login or reboot.
    The bad: The fix is not permanent. And I don't have a permanent solution.

    Maybe this will be fixed in the next update? Or maybe not. (Maybe the update will simply break more things! )
      My ComputerSystem Spec


  3. Posts : 78
    Windows 10
       #23

    I've just been leaving the services.msc settings menu open, and when notifications don't appear I open 'Windows Push Notifications User Service_xxxxx' settings and start the service again. I see people who've gotten the 1809 update are having the same problem. So if it's something MS can fix, they'll likely have to issue a newer build.

    Notifications stop for me at least once a day. My system is on 24/7. The 1st indication of problems is when I see the thumbnail for MS News on the Start Menu stop cycling animated images. Rebooting fixes both. But restarting the service only fixes notifications.

    Is there somewhere we can report this issue to MS?
    Last edited by ohante; 30 Nov 2018 at 04:41.
      My ComputerSystem Spec


  4. Posts : 805
    X
    Thread Starter
       #24

    It happened again yesterday. I fixed it yet again by running that script.
    Fortunately this problem only appears once every week or so.
      My ComputerSystem Spec


  5. Posts : 78
    Windows 10
       #25

    margrave55 said: View Post
    It happened again yesterday. I fixed it yet again by running that script.
    Fortunately this problem only appears once every week or so.

    Win10 just updated to v1809 build 17763.194 tonight. Previous to this I might go a day without having to restart the service, or have to restart it a couple times a day. I don't see any reference to a build number in this other thread about problems with 1809. Maybe someone can tell me if it was not the build17763.194 I got tonight that people were having problems with.

    The 1st thing I'll notice if it hasn't fixed my problems will be seeing the animated News app icon on the start menu not revolving.
    Last edited by ohante; 12 Dec 2018 at 07:54.
      My ComputerSystem Spec


  6. Posts : 6
    Windows 10
       #26

    margrave55 said: View Post
    Windows says I have one notification:
    Attachment 205785
    But when I open the action center I have none:

    Attachment 205786

    When I reboot this disappears.

    What's up with that, Holmes?
    I have had exactly that behaviour for a couple of weeks, A reboot clears the notification, But it come back even though the action center says i have none.

    I just had an update last night so i dont know if it has been fix, Yet.

    John.
      My ComputerSystem Spec



  7. Posts : 78
    Windows 10
       #27

    PoorUserName said: View Post
    I just had an update last night so i dont know if it has been fix, Yet.

    John.

    When you search Cortana for Winver what does it tell you your version and build are now John?
      My ComputerSystem Spec


  8. Posts : 6
    Windows 10
       #28

    ohante said: View Post
    When you search Cortana for Winver what does it tell you your version and build are now John?
    Now : Version 1803 Build 17134.407

    I have not seen the false notification show again since the update, But it`s too early to celebrate.

    John.
      My ComputerSystem Spec

  9. Stitch194's Avatar
    Posts : 430
    Windows 10 Pro
       #29

    I had exactly the same with the .134 CU on one PC only. After much searching, trial and error in settings, I found that "Messaging" in background apps was turned "OFF" Turned messaging "ON" and the problem (no notification text) disappeared.

    Windows says 1 notification for me ... but there are none-capture.png
      My ComputerSystem Spec


  10. Posts : 6
    Windows 10
       #30

    The false notification is back, And i have notifications enabled in background apps as mentioned in the post above.

    If i hove the mouse pointer over the notification it says "notifications not enabled", If i right-click the notification and select turn on notifications, Notifications still show as "not enabled"

    John.
      My ComputerSystem Spec


 
Page 3 of 4 FirstFirst 1234 LastLast

Related Threads
Is there any way to disable the Windows 10 All Apps New Notification on the Start menu, I noticed it's constantly telling me I have a new app installed even though I don't. Scrolling through the applications removes the notification but after some...
Windows Updates Notification in Windows Updates and Activation
Anyone receive notifications like this? This is the first I have seen it, so I am bit surprised. I am not complaining, but I have action center and notifications disabled, so it is strange. I have Windows Update set to notifications, so I like...
Solved Windows 10 Notification Process in Installation and Upgrade
My computer runs 8.1 and I signed up for WIN10 some time ago. I did click on the "Notify Me" button and am still waiting ... What form does the notice that WIN10 is ready for download take ? Do I hear Angelic Voices or Trumpets blaring or is...
Windows 7 to 10 missing notification in Installation and Upgrade
Hello, I want to reserve windows 10 but no notification as you can see in the picture I screen shot. 20501 I have SP1 installed, I have no important updates but some optional. I have ultimate edition and genuine windows, (legit version), allowed...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:06.
Find Us