Dual boot w7/w10 , win10 partition raw in win7  


  1. Posts : 6
    win10 win7 ubuntu xp dos w2k w2k8
       #1

    Dual boot w7/w10 , win10 partition raw in win7


    hello,

    I have dual boot systems win7 and win10.

    Win 10 is primary system on SSD Disk0 with 2 partitions, boot/system and recovery. Bios MBR. (not uefi)
    Win 7 is on Disk3 part1 , all is working fine , both systems boot via win10 startup menu.
    Disks 1 and 2 are GPT raid0, data only. (disk1 3tb , disk2 1tb)

    disk0 1. win10/boot/sytem 2.recovery (mbr/ssd)
    disk1 1. raida500gb 2. simple (gpt)
    disk2 1.raidb500gb 2. simple 3.simple (gpt)
    disk3 1.win7sys 2. primary 3. primary

    Recently (since some sep. win7 kb update, but may not be the reason), my win10 partition become inaccessible in win7 system and is seen as RAW in disk manager and diskpart., BUT!, it is seen normal ntfs in Minitool part manager and other partition software.??

    I've tried full shutdown/restart if it were fast-startup the reason in win10 , but to no avail.

    Repeat, both systems function normally (it seems), BCD is valid in win10 , but of course it doesn't work in win7 anymore because db is not accessible.

    What can be the reason, any ideas?

    Thanks
      My Computer


  2. Posts : 5,478
    2004
       #2

    You got hibernation turned off on both? (powercfg -h off)
      My Computer


  3. Posts : 6
    win10 win7 ubuntu xp dos w2k w2k8
    Thread Starter
       #3

    No I haven't got, it worked with hib. active on both before,
    I didn't think that the problem is with hibernation file(s) anyway.
    I know it is linked in win10 with fast startup feature, but it should respect full shutdown via win+X poweroff. (as whitepapers say...)

    Anyway, .. I've disabled it on both, still the same.
    Even 'partition guru(disk genius)' can access disk and see and browse ntfs along with 'partition wizard' , but no win7.
    Are those partition software using some different disk access type then "ordinary" (direct-access?)
      My Computer


  4. Posts : 6
    win10 win7 ubuntu xp dos w2k w2k8
    Thread Starter
       #4

    Dual boot w7/w10 , win10 partition raw in win7-clipboard-1.jpg

    As you can see, Aomei backup picture says something is very wrong here, same stuff seeing if program ran from win7.
    Disk1 and Disk2 are missing all along and/or are connected to disk0 somehow... crap .. ..problem.

    Already emptied raid , now will backup disk0 system ssd, then try to figure is it repairable or will have to recreate partitions.
    Still, not quite sure is it just Aomei, somewhat broken representation of Dynamic disks, or is the true state. Will do later, after I can see what Paragon have to say and some other programs from offline usb stick.

    Wish me luck
      My Computer


  5. Posts : 6
    win10 win7 ubuntu xp dos w2k w2k8
    Thread Starter
       #5

    Good news, picture above is really a bug in AOMEI Backupper, there is an error when, at least displaying Dynamic volumes/disks, don't know how "well" it behaves with backup/restore. (I'm afraid to even try on my system to be honest :) )
    Well wait for update...s.

    For OP , I still haven't found the solution, but I've tested booting Win7PE from usb and of course , win10 partition (whole disk including recovery hidden partition) is still RAW and unusable in that state.

    If you boot offline partitioning software off win10pe image , everything is peachy, fine.

    My, humble, opinion is they've (Microsoft) updated something near first 2 weeks in september for Win10 and ... **ed up.

    Still have yet to see what linux see's with gparted or pmagic... probably same RAW , so.. why bother.

    Please Mike, fix that, preferably this year.. Thanks.

    It must be
      My Computer


  6. Posts : 6
    win10 win7 ubuntu xp dos w2k w2k8
    Thread Starter
       #6

    SOlved!!!
    First, SINCERE apologies to Microsoft and AOMEI, it is not their fault as described at all.

    To cut long story short, the darn problem was Gigabyte HDD(Hpa) bios backup! .. good known "troublemaker" among raid population.
    After updating the motherboard bios , that, may I say STUPID option is selected by default and it kicks in the moment you restart/poweron computer first time after bios update. Let me repeat so GIgabyte can hear clearly...
    REMOVE THAT SHIT AS DEFAULT , you are corrupting people's partitions and disks.. that's just DUMB , in absence of kinder words.
    Even that motherboard have dual-chip bios , recovery bios writes itself onto HPA area on the end of the disk , reducing, not a problem, just about 1MB , but, again, is more of problem then any benefit.

    The thing worse is that is a SSD so it can't have HPA in standard way , so it corrupted Recovery partition at the end of disk "freeing" up 1.03MB :) from partition, illegally , seen by system,.. in a way which, somewhat NOT encouraging , even checkdisk or any volume/disk check/fix software haven't recognized and/or fixed ... just great.

    Luckily it was just 450MB recovery partition on system disk affected so it was kind of easy fix, but having it figured out was not so easy ... lol

    I won't describe fix as it is pretty easy , involves recreating Recovery partition for win10 , so it is on Technet already.
    Now is all clear, you can mark this as solved , by me ... here's AOMEI pic now, after fix.
    Dual boot w7/w10 , win10 partition raw in win7-clip2.jpg

    Cheers!
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:11.
Find Us




Windows 10 Forums