has something changed with mouse behavior?  

  1. Posts : 67
    Windows 10 Pro x64

    has something changed with mouse behavior?

    For the past few months, I've had a major issue with single mouse clicks maximizing windows. It is driving me nuts, and it has happened on all the PCs I use. I cannot figure out what has changed. It's truly to the point it's making me hate Windows. Did MS change something in mouse behavior? Did Chrome?? Where it really happens pretty much constantly is in browsers. It's nearly impossible to click in the tabs area without ending up full-screen.
      My Computer

  2. Posts : 13,346
    Win10 Version 22H2 Pro and Home, Win11 Pro and Home

    Nothing changed as far as I've seen. I use Wired mice on my Desktops, USB Wireless on some Notebooks and Bluetooth mice on those Notebooks that have it. On some things the accuracy of the pointer location can be problematic.
      My Computers

  3. Posts : 4,555
    Windows 11 Pro 64 Bit 22H2

    This is an indication of a Stuck key on the Keyboard. If this is an external keyboard for a desktop, as outlined in your profile, turn it upside down and blow out the keys with a can of compressed air. Is your keyboard Wireless? or Wired USB?
    Try a different keyboard.
      My Computer

  4. Posts : 67
    Windows 10 Pro x64
    Thread Starter

    I just wanted to follow up on this post since I found the solution.

    My issue was occurring on three different PCs, all with the Logitech M510 mouse. I'd tried everything I can think of with the Logitech Options software, removing the MS Mouse & Keyboard Center (I use the MS Ergonomic 4000 keyboard), etc. It wasn't just the resizing -- dragging had started failing, clicks, everything mouse-related was failing and getting worse. Nothing worked. It had gotten to the point that some things that should take a single-click would take 3 or 4 one time, once on another. It was driving me nuts, and I thought Logitech was simply engineering their mice to fail after a couple of years.

    I was ready to go back to my old standby & buy three new MS mice. The solution is kinda weird, but it's straight from Logitech tech support, and it worked on all three: remove the batteries, then rapidly press both buttons repeatedly for a full minute. Put the batteries back in, & voila! Good as new.

    Amazingly simple, and I don't understand why Logitech doesn't put these instructions in the Options software.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:39.
Find Us

Windows 10 Forums