Windows 10: After new update, search don't work (system restore, update) Solved

Page 5 of 6 FirstFirst ... 3456 LastLast
  1.    26 Jun 2018 #41

    Hey rivre,
    For what it's worth ... I use OOShutp10 to disable cortana and search finds all the update settings when I search on ... windows update ... both in Cortana and Settings.

    Click image for larger version. 

Name:	shutup10-cortana.png 
Views:	1 
Size:	22.8 KB 
ID:	193610

    BTW ... Looking at your Shutup10 screen shot, you might want to update it. Latest Version 1.6.1396 - released May 2, 2018
      My ComputersSystem Spec


  2. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       26 Jun 2018 #42

    Thanks for that info, Eagle51. You've got all the Cortana stuff blocked and indexing still works correctly for you, so shutup10 must not be the cause of my issues I'm guessing. I'll update it though since it's out of date.
      My ComputerSystem Spec


  3. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       26 Jun 2018 #43

    dalchina said: View Post
    Try new user to confirm it is user profile related.

    In your original user:
    a. Confirm indexing is complete.

    b. Confirm
    %LocalAppData%\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState
    is included in Indexing Options.

    If still no luck with current user, re-register Settings using instructions at the head of the section containing the Powershell command for Settings:
    Reinstall and Re-register Apps in Windows 10 | Windows 10 Tutorials
    The problem is if I do create a new user account, how do I know localstate is in indexing? By default, is it? It lists "users' by default but excludes appdata, and localstate is in appdata, unless it has localstate enabled as an exception. Like I said, right now, it's checked, even though it lists appdata in the exclusions.

    It worked until yesterday without ever thinking about it, that's all I know.

    What will re-registering all settings do? I dread having 50 different custom settings reset and then it not even solving my problem.
    Last edited by rivre; 27 Jun 2018 at 15:09.
      My ComputerSystem Spec

  4.    27 Jun 2018 #44

    Please try what I've suggested.
    I would hope re-registering Settings shouldn't change settings. It's the app you're re-registering, not the registry settings it controls.

    Creating and deleting a new user would take less time than all the typing....

    I suspect your problems are essentially self-inflicted- by using certain 3rd party things or changing things in ways not intended.

    ** Remember you said 'it worked until yesterday' - have I ever asked if you had a system restore point you could use?

    but some of the Windows apps are being skipped oddly, like Windows update.
    That's not an app as such. Please distinguish between the universal apps like Mail, Alarms & Clock, Groove ... which do not use exe's or dlls but a different programming paradigm, and programs which do.
    Last edited by dalchina; 27 Jun 2018 at 01:32.
      My ComputerSystem Spec


  5. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       27 Jun 2018 #45

    Whether they're called apps or not, some built-in Windows functions are no longer accessible through search, and they were until yesterday. Even if ccleaner or a Windows update deleted something, Windows should be able to rebuild. It's ridiculous that this can't be resolved.

    As far as doing stuff I'm not supposed to, I've had Spybot anti-beacon and Shutup10 installed since I installed Windows 10 2 years ago, and I haven't had this issue until yesterday. I've use ccleaner regularly for years with no ill effects. My girlffriend's place of employment has her using it on her work PC as a regular part of maintenance. The only thing I did differently is use a more extensive cleaning list, which may have deleted something related to search. I still don't understand why Windows can't just regenerate what it needs. That's the whole point of "rebuild".

    I'll give the other things a try this afternoon. At this point I'm not hopeful. I can't be the only person that has run into this. I'm still not convinced it wasn't the update that did this. Search worked before the update, but not after. Immediately after the update, search looked different, ran search on the internet when it didn't before this update, and developed this issue.
      My ComputerSystem Spec

  6.    27 Jun 2018 #46

    Even if ccleaner or a Windows update deleted something, Windows should be able to rebuild. It's ridiculous that this can't be resolved.
    If you have something hack the OS, you can't expect Windows to repair all arbitrary conditions itself.

    System Restore is a means to go back- addressing some areas.

    An in-place upgrade repair install can help with many problems but not those related to a specific user profile.

    If someone attacks the engine of your car, would you expect it to fix itself, or would you need a mechanic?
      My ComputerSystem Spec


  7. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       27 Jun 2018 #47

    I see no reason to point fingers. All I'm trying to do is figure out what happened.

    Anyways, I did the following:

    - re-registered all apps for all users according to instructions. This didn't improve things. It went through, mostly, but like before, I got the red text saying Cortana is in use, so I don't think that Cortana re-registered. How do I re-register Cortana if it's always in use?

    - created a new user account and logged in. After Windows set things up, the new user account came up, with the default desktop. Immediately went to search, and it finds "windows update", "screensaver" and "system restore" just fine.

    So search works fine for a new user account but not for my account. What would cause search to not work in my account but work in a new account, and how can I fix this?

    Are there settings or folders I can compare to see what might be different between the two accounts that could cause this issue? Obviously some programs are running in my main account that aren't in the newly-created account.

    Is there a way to backup and copy the search files from one account to another?
    Last edited by rivre; 27 Jun 2018 at 16:23.
      My ComputerSystem Spec


  8. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       27 Jun 2018 #48

    As an update, I took a look at a few things in the new user account (where search works correctly). Firstly, I copied over the full localstate folder to another drive for backup purposes, to compare to my main profile's folder. I then went into the Search and Privacy settings in the settings window, and made note of all the default settings. I also looked at the indexing options, to see what folders were being indexed. The only folders listed were the 2 default ones - Start Menu and Users, with appdata;appdata as exceptions. I looked into the modify window to see exactly what folders were being indexed, and localstate was not even checked off by default. So it seems to me localstate is unnecessary to index for search to bring up windows functions like windows update, screensaver settings, etc., since search is working fine in the new account without localstate being indexed. Also, the localstate folder is empty in the new user account. Yet search works fine.

    I then logged back into my main administrator account. I matched all my search and privacy settings to what was in the other user account. I opened spybot anti-beacon and clicked "undo" to reverse all telemetry blocking, since that isn't running in the new user account. I also ran shutup10 and disabled all changes (set everything back to unblocked) as that also isn't running in the new user account. I then rebooted and then ran the Reset_and_Rebuild_Search_Index.bat file again, which then rebuilt the index again.

    After all that, the search still isn't working correctly. Still can't find "windows update" and can't find screensaver settings. I'm sure it can't find a lot of other functions like this too. These are just common ones I tried that it can't find.

    So I have no idea what's up but it's not something that I'm blocking in my search or privacy settings, and it's not something I'm blocking with spybot anti-beacon or shutup10. And it seems the localstate folder doesn't even need to be indexed for search to pull this stuff up, as that folder is currently empty in the other user account, and isn't indexed. So even if ccleaner did delete a search-related index file or something, I see no reason why Windows shouldn't be able to correct this issue. Again, SearchDiagnostic.diagcab also could not find any issues. So as usual, Windows fails miserably at detecting and fixing what should be an easy issue.

    So what now? I have a lot of software installed and configured just right in my current user account. Most of it is not installed for "all users", so if I have to use a new user account, it will be almost as much work as just reinstalling from scratch, which isn't even an option right now. I have too many projects and things going on. I don't have the time and all my software is configured the way I want it. I can't believe it's this much of an issue to fix what appears to be a small issue.

    Is there some other search-related file(s) I can copy/transfer over from the new account to my user account to fix search? Or is it really broken now?
      My ComputerSystem Spec


  9. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       27 Jun 2018 #49

    Regarding the system restore you asked about earlier, that won't work for me in this situation.

    Windows apparently deleted my restore point during the update. From what I understand, Windows deletes restore points when they aren't relevant, like the big fall or spring updates, since it's not possible to do a system restore after a large update like that.
      My ComputerSystem Spec


  10. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       27 Jun 2018 #50

    Whaa?!?

    I just checked for updates again, and it said a new cumulative update was available:

    2018-06 Cumulative Update for Windows 10 Version 1803 for x64-based Systems (KB4284848).

    I took the update and it installed and rebooted. Windows update history shows it installed successfully. I immediately checked search, and now it immediately finds and pulls up windows update, screensaver settings, and system restore! It now seems to be working just fine, just like before.

    It looks to me like the big update broke search for me, but somehow this cumulative update fixed it. Really weird. All that stressing for 2 days with no luck fixing it and then this update comes along and instantly fixes it. I have a strong feeling that the big update broke search for me and whatever was in this new update fixed it.

    Anyways, I think I'm back on track now.

    A big thanks for trying to help me out. I know you put a lot of time and posts into this.
      My ComputerSystem Spec


 
Page 5 of 6 FirstFirst ... 3456 LastLast

Related Threads
I have often seen that whenever there is an automatic Windows update, the restore points created are no longer available. I agree that going back to an earlier point in time negates the advantages of an update. I have seen applications to break...
After the Anniversary update (version 1607 via Windows Update), Search doesn't work properly - i no longer have a search icon in my taskbar. i do have a cortana icon. is this by design? - when i try to key something into where it says "ask me...
My Windows 10 Update System Does Not Work in Windows Updates and Activation
For about two days now my Windows 10 update setting does not work. I have never had problems ever before with getting updates but now when I go into settings and click on UPDATES and click on CHECK FOR UPDATES, nothing happens. Oh yeah the time...
I cannot create a System Restore File/point. I have read instructions on setting the restore point but none are correct for 10. Screenshots 67305 Thank you for any help you could send my way-
I upgraded from Win 7 to Win 10 this past week. All is well except for one thing. I received an update from Microsoft yesterday (Cumulative Update for Win 10 - KB3081424) and noted during the installation that no restore point was created. System...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 07:41.
Find Us