Windows 10: After new update, search don't work (system restore, update) Solved

Page 2 of 6 FirstFirst 1234 ... LastLast

  1. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       26 Jun 2018 #11

    dalchina said: View Post
    Recommend you enable Windows search indexing.
    Okay, I'll give that a try. How do I enable that now?

    Obviously something broke with the update though, because I haven't changed any indexing options and I've had no issues until this update today. Just earlier today I typed system restore into that search box and it came up just fine. So the update broke something.
      My ComputerSystem Spec


  2. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       26 Jun 2018 #12

    Just went into services, and checked Windows Search there, and it says it's running, and set to delayed start. So it's already running.

    Under Indexing Options, it only lists the items I previously listed (Internet Explorer History, Start Menu, and Users.) If I select modify, it allows me to select any of my drives. I'd rather not select my entire C drive. That's why I used to have it disabled. Which folder(s) should I enable indexing for it to find my software and Windows commands (Windows/program files)?
      My ComputerSystem Spec

  3.    26 Jun 2018 #13

    You could try option 3 here:
    Rebuild Search Index in Windows 10 | Windows 10 Tutorials

    However, if after that, and rebuilding your search index, searching e.g. Settings still doesn't work, need to look in another direction.

    Note: you can Edit posts to add info so there's not a string of posts.. easier to read- thanks

    Settings:
    https://www.winhelponline.com/blog/w...lts-found-fix/
    How to fix Windows 10 Settings search not displaying results | Windows Central
      My ComputerSystem Spec


  4. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       26 Jun 2018 #14

    I already tried rebuilding the index about a half-hour ago. Still no improvement.
      My ComputerSystem Spec

  5.    26 Jun 2018 #15

    Did you also reset to default as per my previous?

    Now see my previous on how to deal with no finds in Settings.

    Then try this for Cortana:
    In Powershell as admin:

    Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    and see
    https://www.winhelponline.com/blog/i...ound-apps-off/
      My ComputerSystem Spec


  6. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       26 Jun 2018 #16

    - Reset and rebuilt indexing according to instructions in your link (modified SetupCompletedSuccessfully = 0, stopped and restarted indexing in services). No improvement.

    - Added Localstate folder to indexing according to instructions in your link. No improvement.

    - Ran troubleshooter for indexing - no problems found.

    - Checked "Allow background apps" in privacy settings - the master switch was already enabled.

    - Tried re-installing Cortana using Powershell but i get this in red:

    Deployment failed with HRESULT: The package could not be installed because the resources it modifies is currently in use.
      My ComputerSystem Spec

  7.    26 Jun 2018 #17

    Reinstall and Re-register Apps in Windows 10 | Windows 10 Tutorials
    - follow instructions for Cortana carefully, including those at the top.

    Try creating a new user for test purposes and see if you see the same then.

    If so, sorry, no more ideas bar an in-place upgrade repair install.
      My ComputerSystem Spec


  8. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       26 Jun 2018 #18

    I ran the following reg file to disable the annoying web search:

    Windows Registry Editor Version 5.00
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Search]
    "BingSearchEnabled"=dword:00000000
    "AllowSearchToUseLocation"=dword:00000000
    "CortanaConsent"=dword:00000000


    Now the search box looks like my old one before the update (compare this to the screenshots I posted on the previous page). And it seems to have disabled web search completely. But, it still doesn't find basic stuff like Windows Update or System Restore. And it worked fine just hours ago, before I installed the spring update.



    Do you have the latest spring update installed yourself? I'm wondering if it just breaks search currently. I know it breaks the ability to disable web search, thus the reg file I ran.

    Where are system apps like system restore, windows update, etc. located? Maybe that folder just isn't indexed currently for whatever reason since the update. I thought adding the localstate folder would add all that but even just looking in the localstate folder I see several hundred files but nothing that says update or system restore, so maybe those locations aren't indexed due to them being in a different location. Remember, I don't have my whole C drive indexed.
      My ComputerSystem Spec

  9.    26 Jun 2018 #19

    It would have been better to try fixing the basic problem before making mods.

    See my post #17. Did you use Powershell in admin mode?
    My build- see my specs. I'm not personally aware of 1803 breaking search like that in general.

    You don't need all C: indexed. What is important is to have at least the defaults configured- hence my previous on resetting indexed locations to default - ref. searching settings.

    I know it breaks the ability to disable web search
    - that started several builds back.

    System Restore- well, that's rstrui.exe, but you shouldn't index that explicitly- and if you did it wouldn't be found as 'restore'
      My ComputerSystem Spec


  10. Posts : 332
    Windows 10 64-bit home
    Thread Starter
       26 Jun 2018 #20

    Well I'm off to get some sleep. Big thanks for trying so hard to help me out. It's really appreciated. I'll try the Powershell thing in the morning but I don't have high hopes at this point. Nothing else has worked and I have no idea what happened.

    I see rstrui.exe actually runs system restore, but it doesn't open the "system protection" (SystemPropertiesProtection.exe) window that opens from Control panel, or that used to open up until today from the search box when typing "system restore", which actually lets me create restore points. That seems to be located in the system32 folder. If I index my system32 folder, would that possibly index some of these missing functions? I guess it wouldn't hurt to try.
      My ComputerSystem Spec


 
Page 2 of 6 FirstFirst 1234 ... LastLast

Related Threads
I have often seen that whenever there is an automatic Windows update, the restore points created are no longer available. I agree that going back to an earlier point in time negates the advantages of an update. I have seen applications to break...
After the Anniversary update (version 1607 via Windows Update), Search doesn't work properly - i no longer have a search icon in my taskbar. i do have a cortana icon. is this by design? - when i try to key something into where it says "ask me...
My Windows 10 Update System Does Not Work in Windows Updates and Activation
For about two days now my Windows 10 update setting does not work. I have never had problems ever before with getting updates but now when I go into settings and click on UPDATES and click on CHECK FOR UPDATES, nothing happens. Oh yeah the time...
I cannot create a System Restore File/point. I have read instructions on setting the restore point but none are correct for 10. Screenshots 67305 Thank you for any help you could send my way-
I upgraded from Win 7 to Win 10 this past week. All is well except for one thing. I received an update from Microsoft yesterday (Cumulative Update for Win 10 - KB3081424) and noted during the installation that no restore point was created. System...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 00:46.
Find Us