Windows 10: Registry tweaks from Win7 that no longer work in 10 Solved

  1.    10 Jun 2018 #1

    Registry tweaks from Win7 that no longer work in 10


    I have somewhat automated installation process of Windows 7 that works really well, but parts of it don't work in Windows 10. I could use some help.
    Problem1:
    At some point during messing around with mounted installation image, I apply various reg tweaks, specifically new entries in the context menu of My Computer (This PC in Win10??).
    Well, that doesn't work at all in the new version. I can't even import that reg file, cmd yells out some error.
    Would anyone know what the correct registry hive and keys are?

    This is how I have it for Win7:
    Code:
    ;My Computer context menu
    ;Add Services
    [HKEY_LOCAL_MACHINE\WIM_Software\Classes\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Services]
    "Icon"="filemgmt.dll,-236"
    "Position"="Top"
    [HKEY_LOCAL_MACHINE\WIM_Software\Classes\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Services\command]
    @="mmc.exe /s services.msc"
    
    ;Add Registry Editor
    [HKEY_LOCAL_MACHINE\WIM_Software\Classes\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Registry Editor]
    "Icon"="regedit.exe"
    "Position"="Top"
    [HKEY_LOCAL_MACHINE\WIM_Software\Classes\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Registry Editor\command]
    @="regedit.exe"
    
    ;Add Event viewer
    [HKEY_LOCAL_MACHINE\WIM_Software\Classes\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Event Viewer]
    "Icon"="eventvwr.exe"
    "Position"="Top"
    [HKEY_LOCAL_MACHINE\WIM_Software\Classes\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Event viewer\command]
    @="eventvwr.exe"
    
    ;Adds Device Manager
    [HKEY_LOCAL_MACHINE\WIM_Software\Classes\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Device Manager]
    "Icon"="shell32.dll,-13"
    "Position"="Top"
    [HKEY_LOCAL_MACHINE\WIM_Software\Classes\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Device Manager\command]
    @="mmc.exe /s devmgmt.msc"
    
    ;Adds Add/Remove to right click of MY Computer
    [HKEY_LOCAL_MACHINE\WIM_Software\Classes\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Add/Remove Programs]
    "Icon"="imageres.dll,-161"
    "Position"="Top"
    [HKEY_LOCAL_MACHINE\WIM_Software\Classes\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Add/Remove Programs\command]
    @="control.exe appwiz.cpl"
      My ComputerSystem Spec

  2.    10 Jun 2018 #2

    Took me almost three hours, but I managed to figure it out.
    This particular part of imported registry don't have the same permissions as that from Windows 7 image, which is why I couldn't apply the tweaks. I had to change the owner from TrustedInstaller to Administrators.
    Also, SetACL be praised. Such an old and yet so awesome program.


    I would still like to know whether there isn't "more proper" way of doing this though (I don't know, the commands I am using and so on).
      My ComputerSystem Spec

  3.    10 Jun 2018 #3

    Taking ownership of registry keys


    I am having a problem with SetACL. I figured out how to take ownership and change permissions of a key, BUT I have just noticed it doesn't change the owner of any subkeys that might be there.
    This is what I'm doing
    setacl -on "HKLM\WIM_Software\Classes\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}" -ot reg -actn setowner -ownr "n:administrators"
    setacl -on "HKLM\WIM_Software\Classes\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}" -ot reg -actn ace -ace "n:administrators;p:full"

    Would anyone know how to do it for the entire tree?
      My ComputerSystem Spec


 

Related Threads
Windows 10 Home auto-rebooted my system after installing updates while it was unattended and running scheduled tasks. This is annoying and has happened several times. So I tracked down these registry tweaks I found on Google and forum searches,...
I recently purchased a laptop with the Win 10 o.s. Will the Erunt program run with Windows 10? I ve used it on XP and 7, but haven't tried it on 10. I d like to find out if it does indeed work before I try installing it. Thank you.
We (me and a fellow worker) have just started using remote desktop to work. I have been using NetSupport Manager for almost 10 years but just switched to Windows 10 on virtual PC at work and discovered that remote desktop performance with UDP is...
I'm an IT Pro and been using Windows 10 for a while now but I just had to join this forum to ask at least this perhaps dumb question: In Windows 7 I used to be able to type into the start menu search field the word "close" and the first result...
While trying to tweak Quick Access, I somehow broke it and no matter what I do, it is stuck as shown in the screenshot. It doesn't get removed or restored with the registry keys but I am also unable to add or pin anything to it and recent...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:11.
Find Us