Windows 10: UNMOUNTABLE BOOT DRIVE after Windows Update rebooted PC

  1.    31 May 2018 #1

    UNMOUNTABLE BOOT DRIVE after Windows Update rebooted PC


    Hello,

    I am a Linux software developer which is not to say I'm wholly unknowledgeable about Windows but I haven't done much "desktop support" since Windows XP. Someone in my household has a Windows 10 PC which they left on Tuesday night and Wednesday morning it had the following blue screen message: "Automatic repair couldn't repair your PC". I'm fairly confident that Windows Update restarted the PC over night. If I click the "Exit and continue to Windows 10" button, I will get a blue screen with the error "UNMOUNTABLE BOOT DRIVE" before it automatically reboots and tries the automatic startup repair.

    I've booted the PC with a live Ubuntu disc and Linux has no problem mounting the partitions. I've examined the drive contents and while I don't really know what to look for, there seem to be all the normal folders (Windows, Program Files, etc) and even has the registry files in WINDOWS/System32/config and a backup under RegBack. So I can conclude that the error message "UNMOUNTABLE BOOT DRIVE" is not accurate.

    I have also used the command prompt you can get to after the automatic startup repair fails and done all of the things that are often suggested including:
    chkdsk /f d:
    bootrec.exe /fixboot
    bootrec.exe /fixmbr
    bootrec.exe /rebuildbcd
    sfc /SCANNOW

    The chkdsk passes without a single issue reported. The bootrec commands are kind of a ludicrous suggestion since the PC is booting to the recovery menu which means the MBR and boot loader are functioning (and the PC is indeed MBR, not UEFI). The system file checker is the most interesting one as it does 100% of the Verification phase and then immediately fails with the error "Windows Resource Protection could not perform the requested operation".

    I made an image of the PC and have reproduced all these issues in a virtual machine so I know there are no hardware issues preventing me from fixing the issue. It's not a big deal for me to reinstall Windows on the PC but I have become obsessed with figuring out this problem of a totally mountable UNMOUNTABLE BOOT DRIVE.

    If anyone has further suggestions or knows where there are logs I can look at for more clues to the problem, please respond!

    Thank you for your time,
    Chris Showers
      My ComputerSystem Spec

  2.    01 Jun 2018 #2

    The recovery menu resides on a different partition and activated, if and when Windows 10 cannot start up. It can also be started manually.

    Mounting the partition with Linux is good, the partion table is just fine, but it will not show if the the Windows 10 boot record is correct.

    You could try the "bootsect" at selecting the command line in the recovery menu:

    Code:
    C:
    cd boot
    bootsect /nt60 SYS
    
    
    or...
    
    bootsect /nt60 ALL
    mbrbootrec /rebuildbcd

    You could also force rebuilding the MBR, but it's probably not necessary:

    Code:
    bootsect /nt60 c: /force /mbr

    The link below has more explanation for the above commands...

    http://www.thewindowsclub.com/repair...rd-mbr-windows
      My ComputerSystem Spec

  3.    04 Jun 2018 #3

    Thanks for the reply, Cr00zng! I had not heard of the bootsect command before which reinstalls Bootmgr (or reinstalls NTLDR with the /nt52 switch). Unfortunately, this does not seem to have fixed my problem.

    I did notice some other interesting things. When I run the command "bootrec /fixboot" from the command prompt I get to when automatic repair fails, I get the error "Access Denied". However, if I run it from the command prompt I get after booting from a Win10 install disc and clicking "repair", it appears to succeed. My Windows 10 install disc is for version 1607. Also, when running the command "bootrec /rebuildbcd" it was failing to find a Windows install. I don't seem to remember that happening the first time I ran it (which was before I made the image which I'm now using to do all these repair attempts) but I might just not have noticed. I followed a guide which basically said to delete the file c:\boot\bcd and then rerun "bootrec /rebuildbcd" and that made it identify my one Windows install as "D:\WINDOWS".

    Interestingly, after doing all of those steps plus a chkdsk and plus the steps you provided, the "Reset my PC" option actually attempts to run (which it wasn't before and I don't think I mentioned that specifically). And what's even more interesting is if I select "Keep My Files", after the reset, I still get the UNMOUNTABLE_BOOT_VOLUME blue screen! If I pick the option to fully reinstall, it does work, and I have a clean install of Windows.

    Another surprising thing I found was that if I attempt to restore the registry from backup, I will get a different blue screen of death error. The error is "The operating system couldn't be loaded because the system registry file is missing or contains errors. File: \Windows\system32\config\system Error code: 0xc0000225" which I find very interesting because it couldn't read that file if the drive was unmountable! The way I restored the registry was to copy the following files from the recovery command prompt:
    d:
    cd WINDWS\System32\config\RegBack
    copy /y software ..
    copy /y System ..
    copy /y Sam ..

    Thanks again for your time!
    Chris Showers
      My ComputerSystem Spec

  4.    06 Jun 2018 #4

    I have found something else very interesting. I found a third way to get to a command prompt which behaves differently. The two ways I've used to get to a command prompt are using a Win10 install disc (selecting Repair, etc) and after Automatic Repair fails (clicking Advanced options > Troubleshoot > Advanced options > Command Prompt). My third method is to let Automatic Repair fail and then instead of picking "Command Prompt", select "Startup Settings". After waiting for that reboot, I press F10 for more options and then I only get offered one option which is "1) Launch recovery environment". This seems to start the same recovery environment as the other two methods. However, here when I pick Command Prompt (or Reset this PC or System Restore), I get asked to pick from a list of users and then enter their password (and I only have one user and they are an Admin account). I am not prompted to sign in with a user account in the other recovery environments.

    From this command prompt, sfc works! More specifically, the command "sfc /SCANNOW /OFFBOOTDIR=d:\ /OFFWINDIR=d:\windows /OFFLOGFILE=d:\sfc.log" produces the message "Windows Resource Protection found corrupt files but was unable to fix some of them". Looking at the log file that is generated, there are 784 occurrences of "Error: Overlap: Duplicate ownership for directory" type errors and then the log file ends with one error STATUS_CANNOT_DELETE and one error STATUS_DIRECTORY_NOT_EMPTY. The full text of all these errors is shown below. Are any of these errors meaningful and how can I address them? Thanks for any help you can provide!

    00012189 Error: Overlap: Duplicate ownership for directory \??\C:\WINDOWS\Servicing\Packages in component Microsoft-Windows-ServicingStack, version 10.0.17134.1, arch x86, nonSxS, pkt {l:8 b:31bf3856ad364e35}

    00000003 Servicing stack shim unable to mark handle 1a8 ('\Device\Ramdisk{d9b257fc-684e-4dcb-ab79-03cfa2f6b750}\Windows\temp\SSS_66a053523efdd3010100000020052405\msdelta.dll') for delete-on-close, error STATUS_CANNOT_DELETE
    00000004 Servicing stack shim unable to mark handle 17c ('\Device\Ramdisk{d9b257fc-684e-4dcb-ab79-03cfa2f6b750}\Windows\temp\SSS_66a053523efdd3010100000020052405') for delete-on-close, error STATUS_DIRECTORY_NOT_EMPTY
      My ComputerSystem Spec


 

Related Threads
Solved BSOD Unmountable Boot Volume in BSOD Crashes and Debugging
Hello, I got this BSOD after running the scanner from Microsoft then leaving it overnight then when I woke up it shows a BSOD Unmountable Boot Volume. The machine can't go to Automatic Repair/System Restore because after loading it just shows...
Hello everyone I have a Samsung laptop using Windows 10 and a couple of days ago a blue screen with an unmountable boot volume error showed up after booting, saying the computer would be restarted.After restart a loading recovery option message...
Unmountable boot error loop in Performance & Maintenance
Hey everyone. I am running Windows 10 on a Lenovo T520 computer. My problems began when I was having issues with my computer being slow after the most recent Windows update. I decided to rollback my build. I did so, and then upon logging in,...
Unmountable boot volume in BSOD Crashes and Debugging
Hello all, Currently at my wits end with my Acer Aspire E1-570 so I'm turning to you for help! The problem begin with a plain black screen and only a cursor visible. My girlfriend was using the laptop at the time so I am unsure as to how we got...
I have Windows 8 OEM pre-installled on SSD (hybrid drives: SSD and HDD = 750GB) which comes with the Vaio machine. Few days ago I reset the machine to its factory default setting from 8.1 to 8 (downgrading) due to the corrupted/error files on my HDD...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:37.
Find Us