Right-click has stopped working Solved

  1.    15 May 2018 #1

    Right-click has stopped working


    I recently had to open Disk Management and tried to do this using right-click on the Windows symbol and selecting that option. Nothing happened.


    I found another way to do it, but have now noticed that other right-click issues are happening, eg I recently tried to run several programs as Admin by right-clicking but nothing happens.


    I am the only user and I'm setup as an Administrator, so this should not be happening.



    Tried to run sfc.exe /scannow in a CMD window to check for integrity violations but it refuses and tells me I need to be an Admnistrator.


    So, I tried to open a CMD window as Administrator by right-clicking the Command Prompt and clicking Run as Administrator option - nothing happens.


    So I'm now going round in a vicious Win10 circle. WTF?


    Nothing major has happened to my PC except Win10 upgrades so I suspect that's the culprit, but does anyone know what I can do about this?


    Thanks.
      My ComputerSystem Spec

  2. Bree's Avatar
    Posts : 9,171
    10 Home x64 (1809) (10 Pro on 2nd pc)
       15 May 2018 #2

    OK, so you can right-click on most things, just not on Start. Does WinKey+X also fail? (it's supposed to bring up the same menu)

    This has happened before, and one possible cause was identified as being...
    .one or more desktop applications that install [...incompatible] shell extensions into the Windows right-click context menu.
    See post #13 by Dalchina in this thread and follow the link provided...
    Right click start button - some links do not work
      My ComputersSystem Spec

  3.    16 May 2018 #3

    That worked brilliantly! many thanks!

    yes, Win + X brought up the menu, but clicking items was the issue - they just would not run. You were right about incompatible shell extensions and I followed the link you provided above which then led me to:
    Winkey + X menu shortcuts not working in Win 8.1 (Winkey + X menu shortcuts not working in Win 8.1)
    (Ignore the fact it's about Win 8.1)

    I didn't much fancy the laborious task of using ShellExView (http://www.nirsoft.net/utils/shexview.html) to test each extention and re-boot EVERY time, so I read the whole thread and found that the same suspect progs cropped up a few times:
    - AirDroid (which I had already uninstalled some months ago, but it gave me no issues)
    - NCH Zip Express - which I had recently installed (along with all the other crap it adds...)

    Hunted down all the NCH progs and uninstalled them and my right-click is now working perfectly! - didn't even have to re-boot.

    Many thanks again!
      My ComputerSystem Spec

  4.    16 May 2018 #4

    Good detective work, @tallonius. That shows ingenuity and adaptability in learning from the experiences of others.
    Nice job! And there's NCH Zip Express, off my Christmas list forever (already a happy user of 7-Zip so unlikely to have tried it anyway...).
    --Ed--
      My ComputersSystem Spec

  5. Bree's Avatar
    Posts : 9,171
    10 Home x64 (1809) (10 Pro on 2nd pc)
       16 May 2018 #5

    Good work! Glad I could point you in the right direction.
      My ComputersSystem Spec


 

Related Threads
Hi, I am using Windows 10 with all the latest updates. Copy and Paste has stopped working. I am not able to copy and paste from anywhere e.g. In Notepad highlight a line and copy it and paste it. It will not paste anymore. In PyCharm as well,...
HD stopped working in Drivers and Hardware
Well this is strange i just rebooted and instantly got a BSOD i rebooted and this time i got the msgbox press enter to continue i did and after waiting a couple minutes i finally saw the Desktop but disaster my Games Hard Drive was not showing i...
alt+tab stopped working in General Support
I've always used alt+tab to switch between windows. For some reason it doesn't work anymore - nothing happens. The keys work individually. How do I fix this? Also, why did it stop working? Thanks.
pc-stopped-working in General Support
Hi group, I'm not sure this is windows 10 related, but I'm having this error message or others like it popping up constantly. Cant figure out where else to find an answer. They are all threats of some sort. Niether Windows Defender or...
usb stopped working in Drivers and Hardware
Hi all, have a problem with usb drivers according to my control panel which says it is fixing the issue and then tells me to reboot but it is not fixed. Keyboard lights up on start but when the first blue window appears it goes off. I can get into...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:20.
Find Us