Windows 10: No CMOS Setup when F2 pressed nor Boot Selection with F12

Page 1 of 2 12 LastLast
  1.    05 May 2018 #1

    No CMOS Setup when F2 pressed nor Boot Selection with F12


    I have a GT70 2PE(Dominator Pro Dragon)-1885US, MSI I7 Gaming Laptop with a GTX880

    Using a dual boot with Linux I have messed up something with the UEFI bios or NVRAM

    Every was fine, until I started developing in Linux, my MSI was the last to be used, and it was great, the power.

    I noticed after a few updates, and customizing of the grub boot, there were multiple additions to the list of possible partition in the F2 setup area that gives the list for the F11 display. I read something about this being a Linux issue, but it later found to happen with windows in UEFI 2.1 or something

    I have tried many things, including remove the battery to reset the CMOS ram,

    So I went back to the original setup and ran the original factory recovery disk and still the F2 and F11 function does not work.

    Only a cursor appears on a black screen, with no response from the keyboard with either the F2 or F11 key is pressed.

    Everything is based on the BCD data point to UEFI drivers in directories, So then I would assume that the F2 and F11 would point to something thus when the factory restore was done it would be recovered, but it is not.

    When the problem first occurred, I was able to install a standard hard drive with a factory image on it, and all of a sudden F2 and F11 was working again, I was sure it was a file in one of the UEFI directories, but again something was done in resetting up my system with linux that seems to have lost it forever.

    Where does the firmware file reside for the F2 and F11, how does it relate to the UEFI bios, there would be an entry in the BCD data for it.

    Besides not having access to F2 the computer works fine.

    But how does the new UEFI interact with the F2 key? Can someone point me to some documentation on this, The UEFI spec doesn't exspliciately say anything about F2, only the Windows Boot Loader

    Help any ideas,
      My ComputerSystem Spec

  2.    05 May 2018 #2

    Those "F" function keys interact directly with BIOS. Some "super fast" Or "express" boot may be turned on in BIOS not giving you time to enter it. If you run W10 on that machine you could enter BIOS/UEFI with this line in command prompt: C:\Windows\System32\shutdown.exe /r /fw
      My ComputersSystem Spec

  3.    05 May 2018 #3

    Hello

    On the MSI the F2 or the shutdown /r /fw invoke the "aptio setup utility" from American Megatrends Inc

    The little software package is that basic GUI that we look at as being the CMOS setup pages, where you can change your boot setup, with UFEI it does it through the BCD table that controls the list of stuff, but the big picture the utility to change that CMOS NVRAM stuff.

    I just can see why it isn't a little file somewhere, the memtest was a script in the /EFI/Microsoft directory or somewhere, I could invoke it by playing with Visual BCD Edit.

    Just can figure it out, could it be stored in the BIOS, and was able to be messed up through multiple Linux installs and updates, there was a bug that was originally blamed on Linux and then it was found to be the same with Windows 10, but there wasn't too much said on the wiki or google search I did.
      My ComputerSystem Spec

  4.    05 May 2018 #4

    So F2 or F12 produces a blank screen with a cursor, no response, totally hung.

    A similar thing happened when I had plugged a Dport monitor and the setup screen was changed over to it, drove me mad till I stumbled across it., but this time the problem came and went as I change harddrives, was so sure it was a file somewhere that brought up the CMOS setup or aptio setup as it is titled on the screen. (That I can no longer get to )
      My ComputerSystem Spec

  5. slicendice's Avatar
    Posts : 3,514
    Windows 10 Pro x64 v1809 Build 17763.55 (Branch: RS5 Release Preview)
       05 May 2018 #5

    Instead of pressing F2 or F11, try FN + F2 and FN + F11. Sometimes these keys, can be screwed up at startup, so thought you could give it try.
      My ComputersSystem Spec

  6. slicendice's Avatar
    Posts : 3,514
    Windows 10 Pro x64 v1809 Build 17763.55 (Branch: RS5 Release Preview)
       05 May 2018 #6

    Oh and another thing. Re-flash your BIOS/Firmware, and then reset it...it might solve the problem.
      My ComputersSystem Spec

  7.    05 May 2018 #7

    No every video port, every key, just no.
    It has been a very interesting learning curve, The UEFI Spec talks about the boot process. you can see all the info with BCDEdit on UEFI machines, but I though it might be a record I would have to create but the whole thing is pointer of UEFI codes that point to .efi files that give you that final boot.
    If it was software it should have done it with a factory restore with the disk, with the original hardware, that after years of sitting got recycled into the mainstream around home, but verified it.

    So what exactly happens when F2 or shutdown /fw has been invoked, you can even google it because it all about people learning how to hit F2 not what it does :)
      My ComputerSystem Spec

  8.    05 May 2018 #8

    Yes the reflashing of the bios, but the MSI way is through the F2 setup lol
    Or use a usb method the gamer are using to access blocked screens in their bios.
    But still no guarantees, it will restore this functionality.

    The UEFI stuff is stored in a little software safe and may not be really accessible via the bios. It might be the bug where Samsung were bricked loading Linux and then Windows 10.
      My ComputerSystem Spec

  9. slicendice's Avatar
    Posts : 3,514
    Windows 10 Pro x64 v1809 Build 17763.55 (Branch: RS5 Release Preview)
       05 May 2018 #9

    Remove all your hard disks and then try to get into your BIOS. You should not need any drives to enter the firmware. It's all contained in a single chip. All those .efi files on your HDD are the second step in the boot process and has nothing to do with the hardware Basic Input Output System (BIOS)
      My ComputersSystem Spec

  10.    05 May 2018 #10

    Done, and if you try really really hard in a split second, got on video it says in text
    Hit <del> to enter setup,
    Took me a half hour but did it, only one shot.
    BANG
    Back to the flashing cursor the same place as if hitting F2 during a normal EFI boot sequence.

    So back to what exactly happens when the F2 it hit.
    Do it run flash code in it's bios, or efi code on the disk, pulls something out of the BCD stack.

    Just can't figure it out.

    It came and went, when I was changing hard drives, I though, but F3 causes the recovery that is point to in /EFI/ something.
    This can be verified by using Visual BCD, or BCDEdit.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
No CMOS Setup with F2 no boot select with F12 in BSOD Crashes and Debugging
Hello first thank you, this is an odd problem, with no real place to be put. I have chosen BSOD because, I think it will have the best chance for success. I have a GT70 2PE(Dominator Pro Dragon)-1885US, MSI I7 Gaming Laptop with a GTX880 ...
OS Boot Selection Screen in Installation and Upgrade
Hi there reader/expert, More a question than an actual problem. I have a dual boot system with both 8.1x64 and 10x64 on my 240GB SSD and I always used to have a nice boot selection screen in blue, like on the right side of the picture (something...
USB or DVD Boot Drive Determination/Selection in Windows Updates and Activation
I have downloaded and successfully installed Windows 10 version 1703 including the recent update. Now, I need to download and create Installation Media and note I need to determine whether this PC is setup to boot from USB drive or DVD drive. ...
Dual boot encryption at OS selection in AntiVirus, Firewalls and System Security
I have two ssd's both with Windows 10. I have it set to boot to OS selection. I want to encrypt both ssd's separately so that when I choose one OS or the other that is when I have to enter the password. So far I have use bitlocker to encrypt one...
Windows failed to start. A recent hardware of software change might be the cause. To fix the problem: 1.Insert your Windows installation disc and restart the computer. 2.Choose your language settings, and then click "Next". 3.Click "Repair your...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:16.
Find Us