PowerShell asked to make changes to the system and keyboard autotypes

  1.    25 Apr 2018 #1

    PowerShell asked to make changes to the system and keyboard autotypes


    Hello,

    I am fairly experienced with computers, although *nix servers are more my specialty, I don't really deep dive into windows much since 8+.

    Today I came onto my computer with an elevation prompt saying that PowerShell wanted to make changes to my computer. I declined this as I didn't do anything to initiate it, and then nothing related happened afterwards. I had not recently installed any software, and Windows updates are disabled, however I do update the system fairly regularly manually by re-enabling the service.

    After that while I was in a game, the computer starting typing the space key repeatedly, I tried pressing the space key to 'toggle' it but it did nothing.

    I am not sure if the keyboard issue was before or after I installed RogueKiller, however RogueKiller didn't find anything, and I then uninstalled it.

    I did after that, install Hitman Pro - Alert, and it also failed to find anything suspicious (that I didn't already know was legit)

    A couple hours later, this same keyboard issue repeated itself, this time with the dash/minus key. I don't believe I even hit that key before it started pressing itself (held down essentially). Again, pressing this key did not make it stop.

    In both cases, I had to remove the USB cable connecting the keyboard to the computer, and this did solve the problem both times, however given the strange PowerShell request this morning, I am hesitant to think the problem is the keyboard itself.

    Keyboard is a Razer BlackWidow chroma, I also have another keyboard device, a Razer Naga chroma mouse.

    My biggest concern is with the PowerShell elevation prompt, I was unable to find anything related to this happening on google, does anyone know what may have caused this?

    There are no recent event notification for Power Shell in event viewer, the only thing I could find near the time the elevation prompt appeared was from the Application section:
    Successfully scheduled Software Protection service for re-start at 2118-04-01T11:56:12Z. Reason: RulesEngine.

    However this seems to happen every day at around the same time and has never previously caused this prompt.

    I use chrome and adblock, and am extremely careful with what software I run on my computer, I vetted both the apps i installed today before installing, and scanned them before install with virustotal.

    Hitman Pro is still installed, though I'm not sure I'm a fan.
      My ComputerSystem Spec

  2.    25 Apr 2018 #2

    This is a symptom of a stuck key. Try a standard USB keyboard that doesn't require any drivers or use the onscreen keyboard, see if that solves it.
      My ComputerSystem Spec

  3.    25 Apr 2018 #3

    Not sure if you got the point of my issue. Was primarily concerned about the PowerShell elevation prompt.

    However, the issue happened again, again with a different key.. well keys.. this time, qa were repeating constantly qaqaqaqa.....

    This time, however, I unplugged my mouse, and it also fixed the problem. Seems like something could be causing a short somewhere and unplugging an HID device somehow resets it, or it could be a driver issue.

    Also, I did a 'reset' of my computer, and reinstalled Razer synapse, along with the drivers, so this is a very puzzling one.

    I've moved the mouse to a different USB slot for now.
      My ComputerSystem Spec


 

Related Threads
when my computer is completely off sometimes I accidently press a keyboard key and then my keyboard starts to light up and there is no way to turn it off unless I unplug my keyboard or turn my PC on and turn it back off. The same thing happens to my...
I have recently purchased HP Pavilion x360, 14ba075tx. I have set the touch keyboard to "show the touch keyboard when not in tablet mode and there's no keyboard attached" In Spite of this, setting does not seems to remain forever. It gets pop up...
I recently discovered what you can do with binding macros, I use a laptop which of course does not use a keyboard that hooks up, I do have Razer synapse and a Razer mouse but it doesn't support little numbers on it's side that have a variety of 1-10...
Okay so today when I was using my Desktop. All of the sudden nothing was working, Youtube wasn't playing any audio, I couldn't bring up task manager, etc. So I had to do a shutdown though it had to be a hard shutdown since it wasn't shutting down...
Hi there at one time there was a way to make Powershell the default cmd processor -- I can't find it any more. Any links. Cheers jimbo

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:39.
Find Us