1.    31 Jul 2015 #1
    Join Date : Jul 2015
    Posts : 2
    Windows 10

    Cannot install/preview any fonts at all


    Hi, there seems to be some sort of issue. I tried Google for this and found absolutely no solution.
    Basically, I cannot seem to install any new fonts at all. Any font I try to install or preview, I will get a message saying "Not a valid font". Now here's the strange part, if I click to view a font from the /windows/fonts/ folder, it lets me view it of course but if I copy that font outside that location, like to my desktop, I will again get the same error, "Not a valid font". I tried logging on the built-in Administrator account as well to see if maybe I could do it from there, but no, same error.
    Anyone knows how to fix this?
      My ComputerSystem Spec
  2.    31 Jul 2015 #2
    Join Date : Jul 2015
    Posts : 2
    Windows 10
    Thread Starter

    Okay, I seem to have fixed it myself, however I would like someone please who knows more about this to explain to me why exactly this was causing the issue.


    Basically, I went into the Event Viewer and saw two errors, one that had "font" name in it. It said something about Firewall. Screenshot below:

    i.imgur.com/YeCfqU0.png

    Now, I have Windows Firewall disabled completely because I'm using another Firewall. I went into services.msc, I enabled Windows Firewall, and boom, everything works, I can install/preview any fonts again. Now, I have disabled the windows firewall, but yet I can still install fonts and preview them.


    This is not the first time this has surprised me. Yesterday somehow randomly my search bar(next to windows button) stopped working, I went into Event Viewer, it said something about Firewall, so I enabled it in services, and search bar worked again.


    Can somehow explain to me please why exactly is Windows Firewall affecting so many things? I never had that issue in Windows 7.
      My ComputerSystem Spec
  3.    01 Aug 2015 #3
    Join Date : Aug 2015
    Posts : 1
    Windows 10 Pro

    Just ran into the same issue trying to install Source Code Pro, the Adobe font. I had windows firewall disabled as well.


    Enabled it, started it up and the fonts installed right away.
      My ComputerSystem Spec
  4.    01 Sep 2015 #4
    Join Date : Sep 2015
    Posts : 1
    Windows 10

    I am having this problem also, but only with some rare Chinese fonts. These fonts have worked on all past (otherwise English run) Windows computers of mine. I would like to try this fix, but even after disabling NIS Smart Firewall, I am unable to change anything. See screenshot attached. Almost nothing on that page is clickable. It is the same with and without the Norton Firewall enabled.Click image for larger version. 

Name:	image001.jpg 
Views:	4 
Size:	84.1 KB 
ID:	35151
    According to someone on the Norton forums, "The only way activate the Windows Firewall is to uninstall any third-party firewall." I don't really want to go that route if I don't have to.
    Any suggestions?
      My ComputerSystem Spec
  5.    19 Oct 2015 #5
    Join Date : Aug 2015
    Posts : 15
    windows 7

    I have exactly the same problem as above.Working with Photoshop,Illustrator and several other graphics programs I need to install or at least temporary open tens of different fonts.And I can't.I am stucked and one step from returning to Windows 7.Is it really no way to fix this problem?
      My ComputerSystem Spec
  6.    30 Jan 2016 #6
    Join Date : Jan 2016
    Posts : 1
    Windows 10

    Solution found


    I was able to drag the fonts to my desktop from the download folder, then either drag into fonts folder or right click and click on install. Fonts installed fine from the desktop. Did not have to disable firewall.
      My ComputerSystem Spec
  7.    15 May 2016 #7
    Join Date : May 2016
    Posts : 11
    Windows 10

    Quote Originally Posted by Mac6941 View Post
    I was able to drag the fonts to my desktop from the download folder, then either drag into fonts folder or right click and click on install. Fonts installed fine from the desktop. Did not have to disable firewall.
    You misread the above posts: strangely, the solution was not to disable the firewall but to actually ENABLE it! One would have thought disabling the firewall would result in fewer usability constraints and yet it does not. The same thing happens when you disable UAC in W10 in the Registry (EnableLUA=0 hack), all the "modern apps" don't work at all, which is absurd, frustrating and pathetic.
      My ComputerSystem Spec
  8.    09 Aug 2016 #8
    Join Date : Aug 2016
    Posts : 1
    Windows 10

    Are there any other solutions to this problem? My firewall is enabled. I tried restarting the firewall but I still cant install any fonts.
      My ComputerSystem Spec
  9.    01 Jun 2017 #9
    Join Date : Jun 2017
    Posts : 1
    Windows 10

    I think You installed Windows 10 1607 Update.

    1. Uninstall Windows Update (KB4019472).
    2. Disable Windows Update Service on services.msc
    3. Restart Windows.
      My ComputerSystem Spec
  10.    13 Jul 2017 #10
    Join Date : Jul 2017
    Posts : 3
    Windows 10 1703

    Quote Originally Posted by Hyunjin Yun View Post
    I think You installed Windows 10 1607 Update.

    1. Uninstall Windows Update (KB4019472).
    2. Disable Windows Update Service on services.msc
    3. Restart Windows.
    Do you happen to by any chance be using Print Audit? I have this exact same problem and found that this was the cause after that KB was installed.

    If not you may have another conflict, open MSCONFIG and disable all non microsoft services. Restart and test again
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Deleting fonts
Is there a way to delete a font in windows 10 build 9860? I used to delete fonts in win8 and win 10( previous build) by right clicking and delete but the new build will not allow to do that.
Customization
Icon size and fonts
Need help please. Love the Win 10 preview. My problem is some of my icons are too big or too small. Half and half on the desktop. My fonts are so small I can hardly see them Also my icons are just about touching. Need to space them better.On...
General Support
Blurry fonts on menus and properties boxes
Hi I have upgraded from win 8.1 to win 10. All the scaling settings were not correct. I have put them to the recommended setting off 125%, which is what it was when I was using win 8.1 and worked perfectly. I have had to select the "disable...
General Support
Words and Fonts are not sharp.
After I did the upgrade, the font of my system are just horrible. They are not as sharp as before, the best way to describe it, is that they look like they where printed with a misaligned print head, and I can't seem to find a way to fix it. Does...
General Support
Colour Scheme & Fonts
I see that W10 continues the "Diamond White" colour scheme of the W8 series. Is it possible to change the default: Font face (without hacking the Registry)? Colour scheme of inactive windows?
Customization
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:47.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums