EVENT ID 10016 Distributed COM - Hardlocking My System

  1.    10 Apr 2018 #1

    EVENT ID 10016 Distributed COM - Hardlocking My System


    Ok, I tried to reach out before about this and was simply told it was a driver issue, I'm running win10 PRO 64bit, just did a fresh install last night to eliminate any conflicts. and bam, sure enough, right after completing all the updates, my system is hard-locking again.. I did not install anything other than steam and bit defender security software. I called windows and they want to charge me $150 for support. I am hoping someone can help me with this, this has been going on for months now, and I'm sick and tired of having to format, and having my system hard-lock in the middle of doing emails etc. I thought it was a virus or a hacker, so I've reformatted 4x's now since the beginning of the year, and this error keeps replicating .....

    PLEASE , can someone help me solve this ?


    Click image for larger version. 

Name:	error 1.png 
Views:	10 
Size:	96.0 KB 
ID:	184199Click image for larger version. 

Name:	error 2.png 
Views:	4 
Size:	81.9 KB 
ID:	184200



    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {D63B10C5-BB46-4990-A94F-E40B9D520160} and APPID {9CA88EE3-ACB7-47C8-AFC4-AB702511C276} to the user DESKTOP-7KQ5JK6\Chris SID (S-1-5-21-1328454263-1071037402-3706687528-1001) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.


    Code:
    System
    - Provider
    [ Name] Microsoft-Windows-DistributedCOM
    [ Guid] {1B562E86-B7AA-4131-BADC-B6F3A001407E}
    [ EventSourceName] DCOM
    - EventID 10016
    [ Qualifiers] 0
    Version 0
    Level 2
    Task 0
    Opcode 0
    Keywords 0x8080000000000000
    - TimeCreated
    [ SystemTime] 2018-04-10T20:56:14.621043600Z
    EventRecordID 1103
    Correlation
    - Execution
    [ ProcessID] 1100
    [ ThreadID] 1436
    Channel System
    Computer DESKTOP-7KQ5JK6
    - Security
    [ UserID] S-1-5-21-1328454263-1071037402-3706687528-1001
    - EventData
    param1 application-specific
    param2 Local
    param3 Activation
    param4 {D63B10C5-BB46-4990-A94F-E40B9D520160}
    param5 {9CA88EE3-ACB7-47C8-AFC4-AB702511C276}
    param6 DESKTOP-7K123
    param7 Chris
    param8 S-1-5-21-1328454263-1071037402-3706687528-1001
    param9 LocalHost (Using LRPC)
    param10 Unavailable
    param11 Unavailable
    Last edited by Brink; 10 Apr 2018 at 16:09. Reason: code box
      My ComputerSystem Spec

  2.    10 Apr 2018 #2

    Hi There

    Have a read of this long thread which is marked as solved.
      My ComputersSystem Spec

  3.    10 Apr 2018 #3

    What makes you think this error is causing your problem? I've seen that error in every version of windows. It's common, and has never caused a "hard lock". It's a permission issue.

    More than likely, your problem is your video driver and unrelated to that error.
      My ComputerSystem Spec

  4.    18 Apr 2018 #4

    I uninstalled my video card software and installed a new video card even changed brands, and still getting the DCOM server issues, and the reason I think it's causing the issue, is because after every hard lock that's what shows up in the logs each time.. No other errors until lately, now my logs are flooded with errors and critical warnings

    Mystere said: View Post
    What makes you think this error is causing your problem? I've seen that error in every version of windows. It's common, and has never caused a "hard lock". It's a permission issue.

    More than likely, your problem is your video driver and unrelated to that error.
      My ComputerSystem Spec

  5.    18 Apr 2018 #5

    I followed the admin's steps all the way to step 12 and it's grey'd out for me, I can't edit the final few steps as if I am not my own administrator or something, This is frustrating, because it's still happening even 4-5 times today alone, I can't keep reformatting ,even if I do this error keeps replicating , I also feel it's worth mentioning at the end of the thread you posted the very last post relates to my very issue of not being able to edit the final steps, and it was never answered or resolved, being it's such an old thread I think they just closed it...

    swarfega said: View Post
    Hi There

    Have a read of this long thread which is marked as solved.
      My ComputerSystem Spec

  6.    18 Apr 2018 #6

    A solution for APPID 9CA88EE3...


    Hi everyone,
    I have dealt with these problem a lot, it was exactly same error in Event Viewer. And it is impossible to solve this error with modifying DCOM permissions. In the end I have discovered that starting Chrome browser is causing this error in Event Viewer. Whenever I start Chrome it is sending this error to Event Viewer. Open Event wiever, start Chrome Browser and refresh Event Viewer page. I modified DCOM permissions but no result for this error of runtimebroker APPID 9CA88EE3.... Then I started Chrome browser in Windows 7 compatible mode. Right click Google Chrome icon (or exe file)>properties> Compatibility tab> Change settings for all users>choose compatible mode Windows 7>apply>OK>OK. This happened my solution. No Event Viewer error any more for runtimebroker APPID 9CA88EE3.... İf it is not Chrome in case of you, try to find which program is causing this error. İf you will modify DCOM permission I recommend below given link. It is fully automatic solution I have ever seen. I am using Windows 10 Pro 64 bit.
    Regards
    Script Grant, Revoke, Get DCOM permissions using PowerShell
      My ComputerSystem Spec

  7.    18 Apr 2018 #7

    like i pointed out in another thread.. this error is common and not really related to issues like hard crashing/locking.. if you believe it's a video card issue.. consider running Display Driver Uninstaller(DDU) to clean out your gpu drivers and perform a clean install of your graphics drivers.. also check your temperatures on your gpu and cpu as high temps could lead to your pc crashing.

    also avoid using "Microsoft tech support" for help.. Microsoft doesn't speak with people over the phone for support and they definitely wouldn't charge you to help you fix a computer problem.. whoever you spoke with is probably a tech support scammer.
      My ComputerSystem Spec


 

Related Threads
Hi, I just noticed today that in my Event Viewer I find this item listed four consecutive times after each boot: Log Name: System Source: Microsoft-Windows-DistributedCOM Date: 4/10/2018 3:47:19 PM Event ID: 10016...
I know there are threads about event 10016 and i tried everything i could, also grant permission to local authority NT through launch and activation permissions but it didn't work i still got the same error sometimes when i something stops working...
Distributed COM 10016 - Runtime Broker in Performance & Maintenance
So all of a sudden all my apps + store stopped working. Digging into the issue deeper I discovered Runtime broker had something to do with it. As all error messages mark it as a problem. - <Event...
Solved Event Error ID 10016 in Event Viewer... in Performance & Maintenance
Windows 10 Home 64 bit ASUS X540LA Notebook What is going on here and what is the best for dealing with this? The AppID seems to be designating RuntimeBroker, but I have done everything so far to correct this error. What am I missing? Log...
Hello fellow forum users I am not sure where to begin but I'll start out by saying that I have been googling this one for a few days now. Followed the guides I've found and have not had success fixing this event. Problem: Windows 10's event...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:33.
Find Us