Windows 10: Microsoft Store or something else causing issues

Page 1 of 2 12 LastLast
  1.    25 Mar 2018 #1

    Microsoft Store or something else causing issues


    I think I am having issues with MS Store.
    I firstly noticed I can not open any images using Photos, nothing happens when I double click an image.
    I have tried to doing > Open with> Photos> Ticking it as default, but the issue remains. However, I can open photos with Photoshop.

    I also can not open videos with Default movie player, but I can with BS Player.

    Besides this media issue I can not run some things in Control Panel too, and I can not run MS Store, nor Troubleshoot after I find them via Search next to Startup button. I can not open action center in System Tray

    What may caused this: Didn't turn off my PC, left it to sleep, came back - Store and Mail icons on taskbar were blank, so I've unpinned them cuz I do not use them often anyway.

    What I've tried: Doing a DISM and SFC/scannow - no errors found
    Did a virus scan/reg repair/ junk cleanup with 360 Total Security
    Did troubleshooting > Fix problems with windows update, which told me there are available updates for this machine and that I should download them install, I pressed Yes, but nothing is downloading it seems.
      My ComputerSystem Spec


  2. Posts : 382
    Windows 10 Professional 64bit
       25 Mar 2018 #2

    Follow this guide below to reinstall the applications and see if they come back:

    Reinstall and Re-register Apps in Windows 10 Windows 10 Tutorials
      My ComputerSystem Spec

  3.    26 Mar 2018 #3

    Hi thank you , when I turned PC on today things went back to normal without me doing anything, not sure how tho cuz rebooting did not work yesterday

    Masterchiefxx17 said: View Post
    Follow this guide below to reinstall the applications and see if they come back:

    Reinstall and Re-register Apps in Windows 10 Windows 10 Tutorials
      My ComputerSystem Spec

  4.    26 Mar 2018 #4

    AFter using browser for a while, specifically Outlook and writing emails, things are back to where they were, and unresponsive again I will try the link you gave me, Thanks
      My ComputerSystem Spec


  5. Posts : 382
    Windows 10 Professional 64bit
       26 Mar 2018 #5

    That is a little odd that it recovered. Regardless, reinstalling the apps should resolve the issue.
      My ComputerSystem Spec

  6.    27 Mar 2018 #6

    Masterchiefxx17 said: View Post
    That is a little odd that it recovered. Regardless, reinstalling the apps should resolve the issue.
    Yeah, it recovers every time I turn the PC back on again. My Chrome is terribly slow lately, perhaps its related
      My ComputerSystem Spec

  7.    28 Mar 2018 #7

    Same thing today, I turn PC on, everything's fine, after 5mins I can't open images with using default Photo program.
    I have tried the solution you gave me, this is what I get Click image for larger version. 

Name:	powershell.png 
Views:	4 
Size:	20.0 KB 
ID:	182580
    Thanks again for helping me out
      My ComputerSystem Spec


  8. Posts : 382
    Windows 10 Professional 64bit
       28 Mar 2018 #8

    You need to run this as an administrator. Looks like you may have opened it without admin rights.

    Try running the command for just the Photo's app:

    Code:
    Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\Microsoft.Windows.Photos_15.1208.10480.0_x64__8wekyb3d8bbwe\AppxManifest.xml"}
      My ComputerSystem Spec

  9.    28 Mar 2018 #9

    Nope, tried running it as admin as you can see on the screenshot.
    Tried both for all and for Photo app only, I get not found msgClick image for larger version. 

Name:	powershell2.png 
Views:	3 
Size:	92.3 KB 
ID:	182674
    Masterchiefxx17 said: View Post
    You need to run this as an administrator. Looks like you may have opened it without admin rights.

    Try running the command for just the Photo's app:

    Code:
    Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\Microsoft.Windows.Photos_15.1208.10480.0_x64__8wekyb3d8bbwe\AppxManifest.xml"}
      My ComputerSystem Spec

  10.    02 Apr 2018 #10

    Anyone else have an idea?
    Btw my internet seems to intermittently slow down a lot, then go back to normal. Not sure if it's related but I'd love to resolve this issue too.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Hostname change causing serious issues in User Accounts and Family Safety
I just performed an elevated hostname change in Power Shell... After restarting the computer I noticed that my wireless network was down/not showing. Upon further investigation my issues are: -> 80% of all my services were disabled -> "The...
I'm having lots of trouble with my two disc drives on my new custom-built Windows 10 machine. I put in my older Lite-on disc drives because they were both functioning perfectly in my old PC. One is a blu-ray reader and the other is a DVD burner. ...
so the issue im having is so very far beyond bizzare to me. i will try to give as much detail as possible though. i just recently installed windows 10 on a brand new SSD without any previous OS installed. i also just bought a new shiny 4K TV but...
I just setup a few more user accounts on Win10. I'm pretty sure I had them all setup correctly but I can't seem to download anything on the 2 new accounts. There setup for my 2 youngest kids and don't want them on my desktop. Mostly because all...
Hey all, It's my first post here, so I'll try to be as helpful in my explanations as possible. Basically I'm running Windows 10 64-bit (free download version) and am trying to use my HTC ONE (m7) with Trinus VR. For the least latency I'm...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:50.
Find Us