Windows 10: Safe mode unavailable after enabling secure boot Solved


  1. Posts : 7
    Windows 10 Pro
       24 Mar 2018 #1

    Safe mode unavailable after enabling secure boot


    Hello,

    I've installed Win10 without UEFI/secure boot (a classic MBR drive with NTFS), a few days ago I used mbr2gpt to convert the system drive to GPT and then enabled UEFI and Secure Boot by enrolling the EFI keys from bootx64.efi in my BIOS. From that point I've lost the ability to boot into safe mode, anytime I try that, it wrecks booting to the point where right after startup it goes into automatic repair and then fails, BCD and Winload missing. I have to repair the EFI hidden partition with diskpart and bcdboot from command prompt inside the recovery environment to be able to boot up normally again, thankfully no install media needed, the bootloader looks unaffected.

    Anyone with an idea on what it's about and how to fix it would be welcome :)
    Thanks

    Dex
      My ComputerSystem Spec

  2.    24 Mar 2018 #2

    Just to confirm, booting in normal mode with secure boot enabled is perfectly fine and it's just safe mode that's problematic?

    Can you try booting to safe mode with logging enabled to see how far it is getting? Enable or Disable Boot Log in Windows Windows 10 Tutorials
      My ComputerSystem Spec


  3. Posts : 7
    Windows 10 Pro
    Thread Starter
       08 Apr 2018 #3

    PolarNettles said: View Post
    Just to confirm, booting in normal mode with secure boot enabled is perfectly fine and it's just safe mode that's problematic?
    Can you try booting to safe mode with logging enabled to see how far it is getting? Enable or Disable Boot Log in Windows Windows 10 Tutorials
    Hello, my boot log wasn't showing anything unusual. I was able to fix this myself however, the GPT conversion didn't preserve the BCD entries and ReagentC config needed to run safe mode properly, after following the instructions here:
    https://www.winhelp.us/restore-windows-re.html

    I was able to restore the OS as if it came cleanly installed.
      My ComputerSystem Spec


 

Related Threads
Good Evening, I could do with some pointers on resolving an issue. I can only boot into windows in safe mode in Windows 10. Normal mode and safe mode with networking doesn't work. The problem occurred after a windows update. I have removed the...
I'm having an issue with a SSD which I put into a different laptop, and now whenever I try to boot I get a INACCESSIBLE BOOT DEVICE BSOD, even in safe mode. The following is what has happened so far. I just purchased a laptop to replace my main...
Hi, I have a desktop Windows 10 x64 machine that's been working fine for months/years. It was automatically updated from Win7 last year. This morning I replaced the 2x4GB DDR3 memory with 2x8GB DDR3. This seemed to work though for some reason...
In MSconfig I set windows to boot into safe mode, now it will not boot at all. Previously it booted into normal mode. I used a Windows recovery disc from which the only option that works is the command prompt. From the cmd prompt I can see all of...
Boot mode uefi with secure boot disable in Installation and Upgrade
Ok im about to upgrade to win 10 then do a clean install afterwards of win 10, but i wanted to assure i have everything correct before i start. I updated again my profile with Belarc to assure i have a completed list of my software, i notice this...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:14.
Find Us