Windows 10: Robocopy syntax doesn't work in my batch file anymore Solved

Page 3 of 4 FirstFirst 1234 LastLast
  1.    30 Mar 2018 #21

    phrab said: View Post
    I guess it works somewhat differently in WinXP.
    Hard to say - I was born in the 80's.

    Whether robocopy worked at that time I'd have to google (assuming Google predated XP which I don't know).

    I know my own little peeve with it (the 100%100%100% in the log file) isn't fixed in the last 20 years.
      My ComputerSystem Spec

  2.    30 Mar 2018 #22

    phrab said: View Post
    For what it's worth, I used Robocopy on my 2nd machine, a WinXP SP-3 machine. When I tried to create a logfile, the /DCOPY:T switch prevented the logfile from being created...even if I made it /DCOPY:TDA. I guess it works somewhat differently in WinXP.
    Are you using the /MT switch?
    Mind you that this switch was introduced in Win7, long later WinXP
      My ComputerSystem Spec

  3.    30 Mar 2018 #23

    lx07 said: View Post
    Hard to say - I was born in the 80's.

    Whether robocopy worked at that time I'd have to google (assuming Google predated XP which I don't know).

    I know my own little peeve with it (the 100%100%100% in the log file) isn't fixed in the last 20 years.
    To avoid the 100%100%100% in the log file, use the:
    /NP switch (No Progress - don't display percentage copied.)

    I'm using /TEE /NP /FP /NDL /BYTES and the log file is OK.
      My ComputerSystem Spec

  4.    30 Mar 2018 #24

    Thank you. It was really bugging me that.
      My ComputerSystem Spec

  5.    30 Mar 2018 #25

    lx07 said: View Post
    Thank you. It was really bugging me that.
    You're very welcome. Glad I could help! :)
      My ComputerSystem Spec

  6. phrab's Avatar
    Posts : 152
    windows 10 professional 64-bit
    Thread Starter
       30 Mar 2018 #26

    ddelo said: View Post
    Are you using the /MT switch?
    Mind you that this switch was introduced in Win7, long later WinXP
    Sorry...I missed this. No, I'm not using the /MT switch. However, I put the /DCOPY:T with the other switches before the /LOG:\backups\etc.. When I put the switch after /LOG:\backups\etc., it seems to work. So I guess I goofed. I'll see if it works tomorrow.
      My ComputerSystem Spec

  7. phrab's Avatar
    Posts : 152
    windows 10 professional 64-bit
    Thread Starter
       30 Mar 2018 #27

    ddelo said: View Post
    1. The /DCOPY:T switch copies the timestamp of each copied directory (= folder). The D,A are not needed as they are copied by the /MIR switch.
    I just put the /DCOPY:T switch at the end (on my Win10 machine). The log file was created, BUT when I opened it, I got this message on 2 of the log files:
    "Copying NTFS Security to Destination Directory D:\backups\FolderName\This security ID may not be assigned as the owner of this object."
    Not sure what's going on.
      My ComputerSystem Spec

  8.    31 Mar 2018 #28

    phrab said: View Post
    I just put the /DCOPY:T switch at the end (on my Win10 machine). The log file was created, BUT when I opened it, I got this message on 2 of the log files:
    "Copying NTFS Security to Destination Directory D:\backups\FolderName\This security ID may not be assigned as the owner of this object."
    Not sure what's going on.

    It seems that the destination file permissions cannot be set by your account.

    I would suggest two options:
    1. Check this: This security ID may not be assigned as the owner of this object. or
    2. Add the /B switch (to run in Backup mode)
      My ComputerSystem Spec

  9. phrab's Avatar
    Posts : 152
    windows 10 professional 64-bit
    Thread Starter
       31 Mar 2018 #29

    ddelo said: View Post
    It seems that the destination file permissions cannot be set by your account.
    2. Add the /B switch (to run in Backup mode)
    Thank you for your reply. When I did this manually, I got this message:
    ERROR : You do not have the Backup and Restore Files user rights.***** You need these to perform Backup copies (/B or /ZB).ERROR : Robocopy ran out of memory, exiting.ERROR : Invalid Parameter #%d : "%s"ERROR : Invalid Job File, Line #%d :"%s" Started : %s %s

    However, the Task Scheduler, which is checked to run with highest permissions, worked fine. When I ran it directly, I got the error message. If I run it as an administrator, it works fine. I guess I didn't give myself enough permissions as a user/administrator.
      My ComputerSystem Spec

  10.    31 Mar 2018 #30

    The ERROR : You do not have the Backup and Restore Files user rights, is because your didn't run the command, with the /B switch, as ADMINISTRATOR.

    As a general rule, to avoid problems, RoboCopy commands should always be run as ADMIN. So either run the batch file as ADMIN or run the command from an elevated (Run As Admin) command prompt.
      My ComputerSystem Spec


 
Page 3 of 4 FirstFirst 1234 LastLast

Related Threads
Hello, Happy new year. I have a couple PC's in my house running Windows 10 64bit. All these PC's run Windows from a SSD and have a 2nd HD installed. To save space on the SSD's I put the paging file for the virtual ram on the 2nd HD. So now,...
Solved Win+X doesn't work anymore in General Support
pressing Win+X doesn't show the power user menu for me anymore. right clicking Start button doesn't work either, but when I do it, the mouse cursor jumps several pixels up and to the right. I did sfc /scannow and it didn't fix the issue. does...
Scroll wheel doesn't work anymore in Drivers and Hardware
Hi, i've been searching this issue on Google with literal no topic about it so i'll just make the first one here: From a time i have an A4Tech V7 Gaming mouse that works perfect in Windows 7. Since a few weeks ago, after Microsoft deployed a...
I'm used to run files by drag'n'dropping them on top of one of the icons in quicklaunch. When I need to launch file with some app, while file is associated with another, or just use the other version of app. E.g. drag and drop png file on Paint icon...
I want to run Robocopy to copy my Money 2005 file every shutdown, I know Money has a backup facility but when my wife runs Money on her laptop (Using Homegroup) there is always a backup conflict with my PC and if I open Money and try to backup I get...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 07:00.
Find Us