Windows 10: Disallowrun and locked exe, cmd, regedit Solved

Page 1 of 2 12 LastLast
  1.    09 Mar 2018 #1

    Disallowrun and locked exe, cmd, regedit


    I did a very stupid thing. I tried to make windows block one application by creating registry in Policies/Explorer named RestrictRun.

    I did it and then I also created DisallowRun. In KEy Restrict run I added one application, but i couldnt create key for DisallowRun and forgot to remove registry DWORD with DisallowRun.

    After Restart I cannot access anything.. task manager, regedit, cmd, any programs.. they throw the same error about restrictions placed on PC and executing app was cancelled..
    I have no USB Stick and I cannot edit anything.. help, how can I fix this?!

    I can run only windows universal apps..

    I was stupid but I have importatnt thing to do..
      My ComputerSystem Spec

  2.    09 Mar 2018 #2

    Can you use a system restore point (if it will execute, that is)? (You could try from advanced startup options via e.g. SHIFT + left click restart..... )

    Do you use disk imaging- if you do, you could restore a recent image if you have one. (We constantly urge people to use disk imaging routinely to give themselves a means of recovery - even from disk failures).
      My ComputerSystem Spec

  3.    09 Mar 2018 #3

    No I have no restore point... whatsoever :c

    I am panicking here, even with the safe mode I cant do anything :c
      My ComputerSystem Spec

  4.    09 Mar 2018 #4

    If you made the changes once and still have a usable backup copy of your registry that has not been affected by this, you could restore that.
    Last edited by dalchina; 09 Mar 2018 at 16:20.
      My ComputerSystem Spec

  5.    09 Mar 2018 #5

    I don't think I have registry backup... I never did such things because I never had issues.. this is first time it happened and I am on my friend's laptop now... I can't open regedit, cmd or even task manager. Only universal windows apps run... how can I edit that one registry key and remove it? I would never touch this thing again with a 10 feet pole..
      My ComputerSystem Spec

  6.    09 Mar 2018 #6

    Please help! I am trying anything here..
      My ComputerSystem Spec

  7.    09 Mar 2018 #7

    Oh wait, I entered the thing where you click shift and restart and couple of options.. and noticed 3 days old restore point from 6.03. So it was keeping restore points. I will see what happens if I restore it.
      My ComputerSystem Spec

  •    09 Mar 2018 #8

    It couldnt restore it because of issues with some Universal app... couldnt unpack it or something.... so the problem is still there.
      My ComputerSystem Spec

  •    09 Mar 2018 #9
      My ComputerSystem Spec

  •    09 Mar 2018 #10

    Okay I am in the registry but I have no idea what to load. I loaded as it said and have HKEY USers, but the registry entry isnt there, nor it is in HKEY CURRENT USER. Its just not there.

    Can someone point me where I will find hive I need to load in order to edit it?

    Key I added was in HKEY_Current_USER

    Was something like that except it had also RestrictRun in it.

    @ediT: I solved it.

    For anyone who will have same issue by locking themselves out of exes, regedit, cmd or anything here is what I did:

    1. Shift + Left Mouse click on restart PC
    2. Go to Advanced tools and start command prompt.
    3. IF your windows drive is C, type c:
    4. type regedit
    5. Highlight HKEY LOCAL MACHINE
    6. Click File -> Load Hive
    7. Navigate to c:\users\YOURUSERNAME
    8. Tricky part. If you dont see ntuser.dat, just type it in the open box, and click open.
    9. Navigate to the registry that was added or changed (Software/Microsoft/Windows/...etc)
    10. Delete or modify the keys and values.
    11. Select Hive you've loaded and click File-Unload Hive.

    Done. All works.
    Last edited by SnekkestSnek; 09 Mar 2018 at 16:35.
      My ComputerSystem Spec


  •  
    Page 1 of 2 12 LastLast

    Related Threads
    Regedit issue in Performance & Maintenance
    Hello, Previously when I tried to open "Regedit", a warning notice was asking if I want to make changes...., then clicked on 'yes' and the editor opened. Recently when I try to open the Regedit, it just opens without that warning. Is something...
    RegEdit - Can I delete this ? in General Support
    When I open "Regedit" - "HKEY_LOCAL_MACHINE" and "HKEY_USERS" a number of points that has the same name. Can these are marked on the image be deleted or they still have a function. ? What software is the best reg cleaner (currently using...
    Solved cannot delete key in regedit in General Support
    tried to delete HKEY_CURRENT_USER\Software\360TotalSecurity Thought I had removed 360 Total Security from pc running Win 10. But it still appears in Task Manager as a Background process. Keep receiving message error while deleting key. My account...
    Regedit in Performance & Maintenance
    Looking for help with how to clean up My regedit.
    Solved regedit changes in General Support
    Made a change in HKLM, so that my numloc keys worked on start-up, previous version. Upgraded via update to 10166, Be advised for this change to become effective had to restart comp again. I know its SOP for reg changes but, on an upgrade. SO...
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    © Designer Media Ltd
    All times are GMT -5. The time now is 08:43.
    Find Us