Windows 10: Lotus Approach .dbf read-only warning after splitting RAID 1 array


  1. Posts : 6
    Windows 10 Pro Version 1607
       25 Feb 2018 #1

    Lotus Approach .dbf read-only warning after splitting RAID 1 array


    Got a bug here that is driving me crazy. I had Windows 10 Pro V1709 32bit running on RAID1 (mirrored). This PC was running very slow after KB4074588 (but that is another story), so I decided to replace the two mirrored 500GB HDDs with a 500GB SSD.

    Step one was to disable raid at boot up. No problems there. Next, change the SATA RAID option in BIOS to AHCI, and do a Safe Boot into the OS, then a normal restart. No problems there. Successfully changed Windows from RAID to AHCI using this guide:
    https://triplescomputers.com/blog/uncategorized/solution-switch-windows-10-from-raidide-to-ahci-operation/

    I then installed the Samsung EVO 860 500GB SSD, using the Samsung migration software to clone the two partitions on the HDD (OS and DATA partitions).

    We use the ancient Lotus Approach database software (Lotus Smartsuite V. 9.8). The program is installed on C: drive (where Windows resides) and the folder with the database resides on a partition called DATA (E:) on the same HDD. After cloning the HDD to the SSD, the .dbf files on DATA partition (now on the SSD) are all read-only. If I open the database on the source HDD, it opens without the read-only warning. I thought this might be a Windows permissions problem, so I deleted the database folder on DATA SSD partition and used XCOPY /O /X /E /H /K to copy all permissions. Still got the read-only warning.

    Tried to change the read-only permissions in Lotus Approach. File menu, choose User Setup --> Approach Preferences --> Database panel, but the "Make all fields in database read only" checkbox has a greyed out tick which I cannot remove. So I thought this might be something to do with the database being on the SSD.

    I next booted up using one of the originally mirrored HDDs, but this time I got the same problem with the HDD; Approach produced the read-only error on the DATA HDD partition (which had formerly produced no error when I booted from the SSD), but strangely, if I opened the database files on the DATA SSD partition, they now open without the read-only warning. It seems that since I split the RAID mirror, Lotus approach gives me a Read-Only message if the database files are stored on the same disk as the OS. This happens both on the SSD and the HDD. If I boot from a particular disk (SSD or HDD), I can only avoid the read-only warning by opening the database files on a partition on another disk.

    What I want to do is remove the HDDs and just use the SSD, but since access to the Approach database is critical, I can't do this without solving this issue.

    Hope somebody out there might release what is causing this.

    Many thanks,
    Tim
      My ComputerSystem Spec

  2.    25 Feb 2018 #2

    Have you tried using Easus's free partition managing tools? It can show a lot of reasons why the Data partition may be foreign to the bootable drive and may even offer solutions..

    Easus.
      My ComputerSystem Spec


  3. Posts : 6
    Windows 10 Pro Version 1607
    Thread Starter
       25 Feb 2018 #3

    I tried cloning the DATA partition with Acronis True Image, but got the same issue. Perhaps this is a Lotus Approach issue.
      My ComputerSystem Spec


  4. Posts : 6
    Windows 10 Pro Version 1607
    Thread Starter
       25 Feb 2018 #4

    Fixed this. Cloned again with True Image and this time i worked
      My ComputerSystem Spec


 

Related Threads
Having gone from windows 7, to 8 to 8.1 to 10 without a reinstall I've started to have a few issues so I've just reinstalled windows to a new drive. Trouble is, I didn't think too much and left the old RAID array connected so the recovery and EFI...
RAID 0 SSD Windows 10 Disk Read Error in Installation and Upgrade
I bought two new SSDs to be used in a RAID 0 configuration with a Dell 9020 under Windows 10. Before the drives I arrived I configured two old HDDs in RAID 0 and installed Windows 10 as a clean install. This worked perfectly. Once the new...
Solved Recreating RAID 5 Array AMD in Drivers and Hardware
I updated to Windows 10 Pro with a clean install and had issues with my RAID array showing up as raw format. I was able to take a backup of it from my W7 drive then rebooted into W10 deleted the array in Disk Management, deleted the array in the...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:48.
Find Us