Windows 10: Cannot get chmod to work

  1.    21 Feb 2018 #1

    Cannot get chmod to work


    I'm embarrassed to be asking this, but I need to set /var/www/html and the scripts to have permissions of 775. The install of /var directory as

    ...
    d---------. 4 root root 33 Feb 16 10:57 www
    ...

    Why is this and what does it mean? If I try to change it or any of the directories/files with

    chmod -775

    nothing happens.

    \rtc

    P.S. How can I capture the screen and keystrokes so I can post them?
      My ComputerSystem Spec

  2.    21 Feb 2018 #2

    What are you doing this on your using linux cmds but your specs show windows 10?
      My ComputerSystem Spec

  3.    21 Feb 2018 #3

    What OS are you using?

    When you run "chmod -755" (with the minus sign) you are removing permissions. If you want to change the permissions just do "chmod 755 <filename>".

    Since www is owned by root you have to run this as root.

    I recommend you get familiar with how file permissions work before running any sort of server connected to the Internet.
      My ComputerSystem Spec


  4. Posts : 32,306
    Triple boot - Win 10 Pro, Win 10 Pro Insider (2) - (and a sprinkling of VMs)
       21 Feb 2018 #4

    He's running an Intell NUC, if that matters. Not familiar with that mini hardware. IntelĀ® NUC
      My ComputersSystem Spec

  5.    21 Feb 2018 #5

    OMG! Embarrassed is an under statement. If you come to Bend, OR I buy you a beer -- how about a pitcher.

    \rtc
      My ComputerSystem Spec


 

Related Threads
I have been using computers for over 25 years now, and I have never run across a problem like this. Backstory: I built my current PC about a year ago. Everything worked perfectly until about 5 days ago. At that point, it needed to restart. I...
I have a network drive, which I set up to save a copy of a folder for offline use using the instructions here: Working with network files when you are offline - Windows Help I am not able to find any option for setting the drive to work online...
What on EARTH process is always running in the background to make my hard drive chatter away for literally nearly 3-5 minutes after a bootup...and we're talking with a FRESH install!....Some something is running a LOT in the background but task...
I decided to update my audio drive so i went to the Lenovo website and installed the windows 10 (64 bit) driver, after restarting I noticed that there was no volume at all, i tried the Windows 8.1 driver and now only my headphones work. I also...
Here is info from both computers that might assist in troubleshooting my problem. Trying to Import from IE shows "couldn't import favorites." In both of the following instances identical lists of my favorites and contents of Favorites Bar appear...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 01:58.
Find Us