Windows 10: Unable to connect to Virtual Disk Service

Page 1 of 2 12 LastLast

  1. Posts : 7
    Windows 10 Pro 1607
       07 Feb 2018 #1

    Unable to connect to Virtual Disk Service


    Hello

    For some months I have had a problem on my Windows 10 Pro (1607) desktop where I cannot use "Create and format hard disk partitions" Start Menu item, diskpart on elevated and non-elevated command prompt nor Disk Management(Local) snap-in in mmc.

    Diskpart gives me "DiskPart encountered an error starting the COM services" and the other two give me the usual popup "Virtual Disk Management could not start the Virtual Disk Service (VDS) on ..." - the service is actually running.


    I have tried all the suggested service startup and disable options concerning the "Remote Access Connection Manager", "Remote Access Auto Connection Manager" and "Virtual Disk Service" .

    I have played around with windows firewall. I detached all non-essential hard drives and SATA cables. I even disabled USB controllers (took me 3 days to find a PS/2 adaptor for keyboard). Disabled or removed anything witch could cause an external short on possible storage devices (i.e all case USB headers).

    Uninstalled all software which could somehow interact with storage on lower levels (Etcher, SDFormatter, DaemonTools, Image burning software).

    I tried to follow the solution at Unable to Connect to Virtual Disk Service. but the VDS.log was never created in system32, nor anything appeared into event viewer.

    I took three procmon captures: One with the Start Menu item, one with mmc snap-in and the final with elevated command prompt and diskpart. My untrained eye can't find anything irregular in them, tho I can say that at least the start menu item processes are a bit different compared to my 1709 laptop (virtual disk loader vs virtual disk service).

    One observation I made is that no matter what of the three options I use, virtual disk management service is never triggered.

    I have tried both "sfc /scannow" and "chkdsk c:" to check for corruption but no dice. Also I have updated all drivers I can find for this old motherboard (mainly intel chipset)


    At this point my only solution is to try a clean install, which will be a true headache. I did a test install on a fresh SSD with 1709 and on the clean system the disk management interface works as intended.

    I did manage without the feature and used alternative products (for example EeasUS Partition Master works), but looks like I can't upgrade windows 10 to 1709 without getting the VDS working properly. Windows 10 upgrade gives me error code 80070032 and in the C:\$WINDOWS.~BT\Sources\Panther\setuperr.log I can see:

    Code:
    2018-01-27 01:27:30, Error    WMI Helper Library: Getting WMI Uint16 property DriveLetter: unexpected VARIANT type 1
    2018-01-27 01:27:30, Error    Failed to read MSFT_Volume.DriveLetter, although the property exists; unexpected type? (0x8007070c)
    2018-01-27 01:27:30, Error    SP     CSetupPlatform::Initialize: Disk provisioning is not available; hr = 0x80070032
    2018-01-27 01:27:30, Error    MOUPG  CAutomationManager::Initialize(120): Result = 0x80070032
    2018-01-27 01:27:30, Error    MOUPG  SetupHost: Automation initialization failed: [0x80070032]

    I might have made a wrong conclusion that VDS problem and windows 10 upgrade problem are connected but that is all I have to go on.

    procmon capture links: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

    I have posted this also to reddit and technet, but those post haven't given me anything useful or promising to try.

    Thank you all in advance! All solutions and ideas are welcome.
      My ComputerSystem Spec


  2. Posts : 5,855
    Windows 10 Pro X64 16299.192
       07 Feb 2018 #2

    Try doing a Reset (Refresh actually), keeping everything. That will replace only the system components and files. It's the least intrusive method and should still resolve your problem. See Brink's tutorial for doing this:

    How to Reset Windows 10
      My ComputersSystem Spec


  3. Posts : 7
    Windows 10 Pro 1607
    Thread Starter
       08 Feb 2018 #3

    This line
    • Removes apps and drivers you installed.

    So basically ill have to reinstall programs and "stuff" again?
      My ComputerSystem Spec


  4. Posts : 7,655
    10 Home x64 (1803) (10 Pro on 2nd pc)
       08 Feb 2018 #4

    duckasylum said: View Post
    This line
    • Removes apps and drivers you installed.

    So basically ill have to reinstall programs and "stuff" again?
    Correct. You could as an alternative try...
    Repair Install Windows 10 with an In-place Upgrade
    ...which allows you to keep installed apps as well.

    Your problem in doing a repair install would be that you'd need to use the install media for 1607 if you don't want to upgrade to 1709. The current ISO available from Micosoft (as described in that tutorial) is only available for the latest Fall Creators Update 1709.

    If you already have the 1607 install media as an ISO or USB you could use that. If not, this 3rd-party tool can generate links to get earlier ISOs direct from Microsoft.

    https://www.heidoc.net/joomla/techno...-download-tool
      My ComputersSystem Spec


  5. Posts : 7
    Windows 10 Pro 1607
    Thread Starter
       08 Feb 2018 #5

    In my book this does not constitute as a fix (as a reinstall has always been an option) but this has taken all my free time past two weeks so Ill try the in place upgrade as soon as I find a suitable disk for cloning my system for backup.
      My ComputerSystem Spec


  6. Posts : 3,374
    3-Win-7Prox64 2-Win10Prox64
       08 Feb 2018 #6

    Hi,
    I've personally always used free mini tool might see what it comes up with :/
    Best Free Partition Manager for Windows | MiniTool Partition Free
      My ComputersSystem Spec


  7. Posts : 7
    Windows 10 Pro 1607
    Thread Starter
       08 Feb 2018 #7

    Ok so I made a system clone. Trying to do a repair install with 1709 by booting from USB says that a install media upgrade is not available and I should run it from windows. If I run the installer from windows nothing happens and in setupact.log in C:\$WINDOWS.~BT\Sources\Panther I see (last rows of the whole log):

    Code:
    2018-02-09 00:01:26, Info                         Initializing diagnostics helper; data file = (NULL)
    2018-02-09 00:01:26, Info                         No existing diagnostics data
    2018-02-09 00:01:26, Info                         Key CollectTrace is not available.
    2018-02-09 00:01:26, Warning               SP     CSetupPlatform::Initialize: Failed to initialize tracing
    2018-02-09 00:01:26, Info                         There is already a running setup user mode etw session!
    2018-02-09 00:01:26, Warning                      VdsPlatform::IsAvailable: Couldn't create VDS loader instance (0x80004002)
    2018-02-09 00:01:26, Warning                      WMI Helper Library: Wmi::OpenNamespace: Too late to initialize COM security (0x80010119)
    2018-02-09 00:01:27, Error                        WMI Helper Library: Getting WMI Uint16 property DriveLetter: unexpected VARIANT type 1
    2018-02-09 00:01:27, Error                        Failed to read MSFT_Volume.DriveLetter, although the property exists; unexpected type? (0x8007070c)
    2018-02-09 00:01:27, Warning                      SmPlatform::IsAvailable: Couldn't initialize SM API (0x8007070c)
    2018-02-09 00:01:27, Error                 SP     CSetupPlatform::Initialize: Disk provisioning is not available; hr = 0x80070032
    2018-02-09 00:01:27, Error                 MOUPG  CAutomationManager::Initialize(120): Result = 0x80070032
    2018-02-09 00:01:27, Error                 MOUPG  SetupHost: Automation initialization failed: [0x80070032]
    2018-02-09 00:01:27, Error                 MOUPG  CSetupHost::InitializeComponents(1227): Result = 0x80070032
    2018-02-09 00:01:27, Error                 MOUPG  CSetupHost::Initialize(306): Result = 0x80070032
    2018-02-09 00:01:27, Info                  MOUPG  CInstallUI::Quit: Posted MSG_INSTALLUI_FORCE_QUIT
    2018-02-09 00:01:27, Info                  MOUPG  CInstallUI::CInstallUIMessageWindow::ForceQuit
    2018-02-09 00:01:27, Info                  MOUPG  Force ending Message pump
    2018-02-09 00:01:27, Info                  MOUPG  CInstallUI::ExitInstance
    2018-02-09 00:01:27, Info                  MOUPG  **************** SetupHost Logging End ****************
    So can we assume that the Virtual Disk Loader and Virtual Disk Service and upgrade failure are connected? What is a user mode etw session? Can that be the source off all evil?
      My ComputerSystem Spec


  8. Posts : 4,987
    Win10 Home and Pro, Win10 Insider Preview, WinXP Home Premium, Linux Mint
       08 Feb 2018 #8

    Whenever I have seen the "Unable to connect to Virtual Disk Service" I have always gotten it to work by rebooting the computer. I've had no trouble with the Upgrades and ensuing updates since getting the computer in Oct. 2016.
      My ComputerSystem Spec


  9. Posts : 7
    Windows 10 Pro 1607
    Thread Starter
       08 Feb 2018 #9

    I have done countless reboots during this ordeal, so its safe to say that restarting won't help here.
      My ComputerSystem Spec


  10. Posts : 5,855
    Windows 10 Pro X64 16299.192
       08 Feb 2018 #10

    You can't do a Repair Install by booting the USB flash drive. You need to run Setup from the flash drive after inserting in from the booted Windows 10 system.
      My ComputersSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Windows 10 is installed on machine and I need to clone the entire disk with Clonezilla. However, it gives an error as This disk contains mismatched GPT and MBR partition. It also says that I have to destroy the GPT partition table to be able...
I am running Windows 10 Pro. I have an old 1Tb drive that used to be the boot (C) drive and also had partitions for two additional drives. I since replaced that 1Tb drive with an SSD and another 2Tb second internal drive. I've inserted the...
hello friend.. I cannot update windows 10 to anniversary update. Every time I check for update, this came out "We couldn't connect to the update service. We'll try again later, or you can check now. If it still doesn't work, make sure you're...
Hi - Having lots of trouble here and very frustrated. On login, I get the message "Failed to Connect to a Windows Service. Windows couldn't connect to the Group Policy Client service. This problem prevents standard users from signing in. As an...
I had a few problems with my PC, so I refreshed it. After doing that, I was not able to connect to my virtual router plus, nor find a wireless adapter. I have literally tried everything but I can't fix it. I've attached a picture of my available...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:45.
Find Us