Windows 10: Inaccessible-boot-device after January 2018 Updates - Partially Solved Solved

  1.    22 Jan 2018 #1

    Inaccessible-boot-device after January 2018 Updates - Partially Solved


    Inaccessible Boot Drive after Update? Solved - Page 4 - Windows 10 Forums

    Mine Started there in that forum - and I was not Original OP so I agree - should have created a new thread as I was working through it..

    Systems I encountered error on
    Dell T5500 precision workstation
    dual Xeon CPU ~2010 original purchase
    these have been upgraded only with better video AMD W5000 (not much better though)
    as well as SSD 250g SATA (Samsung EVO 840 (i think red one might be 830) in primary boot and 140g 10k SATA WD Raptor on Secondary... really not needed but figured just to show what is in them.

    AV - vipre endpoint security - verified compatible with MS updates and correct reg flag was in place before any of these issue.
    only thing I did notice was the agent version was on 10.0.6290 and now all other working systems are on 10.0.7233
    Coincidence?? hummmm


    system only reboots on Wednesdays/Thursdays unless acting up then manually reboot - but generally rarely needs a reboot. (this is my workstation for the office so its always on and locked and ready for me to do anything remotely.

    last week noticed it wasn't coming back online in am hours like it should have been...
    all after release of intel patches from MS... and being windows 10... wonderful - can't exactly stop the updates.

    so it had to be an update from 10th > 18th I figured - as those would have been the ranges it would have rebooted on...
    (so it might be a Thursday - don't really care - wed / thurs reboots - don't care to check the schedule /script as it is barely related.)

    initially read through this older article from October and didn't see any pending updates... so they were all installed...
    How to fix October 10 update causing 'Inaccessible Boot Device' error in Windows 10 | Windows Central

    first attempts no change - as well as rebuilding bcd - no real change
    then just did a restore to ~Jan 10th and restore worked and was back up and running - thought i was good as I also stopped future updates.... - nope... no good after reboot for some other updates apparently or power loss - but system is on ups so not sure why it rebooted over the weekend... something else!

    However after trying some of the bootrec /fixboot commands and failing to get the system operational again - this morning..

    booting to window 10 install disk and using repair got back into advanced troubleshooting and CMD prompt.

    then started using the dism to remove updates manually as I am 80% sure the drives are not failing
    this is also evident from a second ~identical system also having the same issue - restore to previous update also worked but will have to see if i need to remove the same updates on that one as well soon - that on is my plex server so can't be having that one offline!

    trick for me was knowing which drive had windows installed on it during windows pe ... c: was not the correct drive
    but didn't try c: - instead command was

    dism /image:f:\ /get-packages
    dism / image:f:\ /remove-package /packagename:IDENTITY NAME /scratchdir:f:\temp\packages

    slightly modified from original which was using C: - but working now at least temporarily...

    anyway the fix for me was removing 3 updates..

    first one -

    KB4056887~.........10.0.1.0
    1/15/18 1pm

    Click image for larger version. 

Name:	fixboot-01.JPG 
Views:	1 
Size:	23.0 KB 
ID:	173795

    rebooted - no change... not fixed.

    next removed two more

    KB4058702......16299.188.1.0
    1/11/2018 1:03pm

    and

    package_for_rollupfix....16.299.192.1.9
    1/11/2018 4:51pm

    then rebooted...
    initially showed error (like repair needed / not sure hit ok) but then booted correctly into windows after that and now working again...

    Still not 100% sure - as updates are/were paused, and now i am unable to pause them again.

    Click image for larger version. 

Name:	fixboot-02.JPG 
Views:	3 
Size:	107.3 KB 
ID:	173796

    so it might become unbootable shortly again anyway if the updates get re-installed... oh well...
      My ComputerSystem Spec


  2. Posts : 7,474
    Windows 10 Pro x64 Build 1709
       22 Jan 2018 #2

    Might I suggest you have a read of this and then hide the offending updates.

    Hide or Show Windows Updates in Windows 10

    I did not look up what these updates do. You may wish to research yourself to determine exposures.

    These updates are likely tied to Meltdown exposures and Intel has noted some issues. One thread. You can google others.

    Intel Security Issue Update: Addressing Reboot Issues
      My ComputerSystem Spec

  3.    27 Jan 2018 #3

    I have had the Inaccessible boot device error twice now on the same machine. The first time I re-installed W10 on a different HDD, the second time I used the same HDD to get it up and running again.

    This problem certainly seems tied to a recent update - I hope Microsoft is working on fixing this....so annoying to have a random problem like this.
      My ComputerSystem Spec

  4.    29 Jan 2018 #4

    Here's what I have found.
    You can get at least one single normal boot by following the viperiii's procedure. My system only booted once. during that boot,
    the last half of the update that caused the problem, continued to install, but the system booted. But only once.
    I suggest that you use the DISM with the revert pending updates before you remove the installed packages.
    Here's the steps:

    Boot from a USB or DVD recovery disk from the same version of windows 10
    select repair my PC
    in troubleshooting select command prompt.
    once in command prompt: (where X is the drive letter where windows is installed. (check because it might be d: or e: even though after windows boots, it will become c:)
    dism.exe /image:X:\ /cleanup-image /revertpendingactions
    (this step is necessary because if you do not and are getting the error Inaccessible boot device, once you get it to boot, the remainder of the patch that caused the problem will replace 40 or so drivers in the \windows\system32\drivers folder. And you will not be able to boot again.)
    now execute the following command (replacing X with the drive where windows is installed)
    dism /image:X:\ /get-packages
    make note of the most recent updated package.
    using DISM remove the most update.
    type the following: (replacing X with the drive where windows is installed)
    md X:\temp
    md X:\temp\packages
    Don't worry if the directory exists.
    dism /image:X:\ /remove-package /packagename:PACKAGE TO REMOVE scratchdir:X:\temp\packages

    [example: dism /image:e:\ /remove-package /packagenameackage_for_kb4056887~31bf3856ad364e35~amd64~~10.0.1.0 /scratchdir:e:\temp\packages
    ]

    reboot

    (you may have to do another startup repair, but the system should boot)
    If not you may have to remove more packages.

    Once booted, remember you may not be able to boot again.
    (at least I wasn't. Trying the procedure again did not produce a bootable machine).

    Note: System reset works, but you lose all your programs and configurations)
    My next step is to try doing a repair install from within windows.
    More to come...
      My ComputerSystem Spec


 

Related Threads
Solved Not receiving January 2018 updates. in Windows Updates and Activation
I didn't get any January updates. I have intel and don't use a 3rd party av. I see that registry entry has been added. But how come I have received no updates at all for january? I feel something is wrong. I did receive an update for my...
I'm having an issue with a SSD which I put into a different laptop, and now whenever I try to boot I get a INACCESSIBLE BOOT DEVICE BSOD, even in safe mode. The following is what has happened so far. I just purchased a laptop to replace my main...
Inaccessible boot device in BSOD Crashes and Debugging
Just finished this build Wednesday night. Finished all software installs Thursday night and did some gaming Friday night. I played Doom 2016 on Ultra settings @2k 144hz for about an hour. System ran beautifully. All hardware is at factory spec. ...
Inaccessible Boot Device in Installation and Upgrade
Sir, I had upgraded my Acer Aspire Laptop (CORE i5 - 4GB RAM) from Windows 8.1 to Windows 10 recently. As it was running very slow, I decided to do a 'clean reset'. By mistake, the recovery partition also cleaned. It then went to a blue screen...
Inaccessible Boot Device in General Support
I ran into a problem this evening with my laptop, Lenovo B575. The laptop kept restarting because of inaccessible boot_device. I am not sure how to fix this problem. I know it's too new for everyone with Windows 10. Mine is Windows 10 64X Home...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:13.
Find Us