Windows 10: The media is write protected on internal HDD Solved


  1. Posts : 4
    Windows 10 Enterprise
       22 Jan 2018 #1

    The media is write protected on internal HDD


    After installing an mSata SSD as my main boot drive for Windows 10 Enterprise I can no longer write to the internal HDD.
    I have checked the read only status in disk part and everything is correct.
    If I pull the drive from the laptop and insert it into a usb dock I can write files to just fine.
    I am running out of space in the SSD and it really bugs me not being able to use my HDD.
    Thanks for any input.
      My ComputerSystem Spec

  2.    22 Jan 2018 #2

    Have you tried switching the internal HDD to a different SATA port when using it inside the PC enclosure/case? I'm curious if this is a property of just one SATA port or all of the available ones in your machine. If you can try plugging it into (or switching cables to use) a different SATA port, it may solve your problem (in which case you'll know it was the port) or not (in which case the drive becomes a more interesting suspect -- "interesting" because you can write to it when plugged into an external dock). For the nonce, you might want to just use it in your dock so you can write to it while we're getting this figured out.
    HTH,
    --Ed--
      My ComputersSystem Spec

  3.    22 Jan 2018 #3

    This should or maybe I should say could help with your problem...

    Step 1.

    From All Programs….select “Windows System”………Right Click and select “Run as Administrator” on “Command Prompt”…….when the cmd prompt window opens go to the next step…

    Step 2.
    Type "diskpart" at the prompt and press the "Enter" key. The Diskpart tool launches.

    Step 3.
    Type the "list volume" command, without quotes, then press the "Enter" key. The volumes attached to the computer are listed.

    Step 4.
    Type "select volume X" (omitting quotes and replacing "X" with the letter of the volume to modify) and then press "Enter."

    Step 5.
    Type "attributes disk clear readonly" (again omitting quotes) and then press "Enter" to make the specified disk writable.

    Step 6.
    Type "exit" to close the Diskpart utility.

    Hope you get it figured out....
      My ComputersSystem Spec


  4. Posts : 4
    Windows 10 Enterprise
    Thread Starter
       22 Jan 2018 #4

    Thanks for the input guys.
    I will hunt down an HDD caddy to try the other sata port for the DVD drive as there is only one HDD bay on this laptop.
    And I tried the attribute clear command but this did not resolve the issue.
    Thanks, again.
      My ComputerSystem Spec

  5.    23 Jan 2018 #5

    Something funky with the internal SATA connections, if the diskpart suggestion makes no difference. This one keeps getting more interesting but (and alas) not in a good way. Do keep us posted. I'm going to learn something from this, and I hope it's something valuable.
    Thanks,
    --Ed--
      My ComputersSystem Spec


  6. Posts : 4
    Windows 10 Enterprise
    Thread Starter
       23 Jan 2018 #6

    I may have made some progress?
    Ok, so when I go into my computer and right click and "format" the drive, as soon as it pops up in the "this pc" window I am able to partly transfer a folder to the drive before it kicks back with the "write protected" error.
    This is weird and I discovered this by accident.
      My ComputerSystem Spec


  7. Posts : 4
    Windows 10 Enterprise
    Thread Starter
       05 Feb 2018 #7

    Did some more googling and found this Second hard drive says write-protected


    This regedit resolved my issue!
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Policies\Microsoft\FVE]
    "FDVDenyWriteAccess"=dword:00000000

    Ran diskpart clean after editing the registry and all is well.
    Time to offload my full solid state!
    And thanks for all input!
      My ComputerSystem Spec

  8.    05 Feb 2018 #8

    Thanks for following up. How on earth did you figure out what to search for? Great job!
    --Ed--
      My ComputersSystem Spec


 

Related Threads
Hi I had to reset Windows 10 due to a ransom ware attack. I mounted my backup using Aomei Backupper. I can view everything but my User files. When I select my User files I get the message: You don't currently have permission to access this folder....
Hi there. I was looking for a solution to an issue I've been having and came across this forum. Maybe someone could help? I recently had a few problems with my PC, leading to me replacing and swapping different components. I originally had the...
I tried CMD, StorageDevicePolicies in Regedit but nothing. Still Write Protected, help.
Write Protected DVD-RW, can't format in Drivers and Hardware
DVD-RW are re-writable correct? I tired to format it and it said i couldn't because of write protection is there any way i can remove the write protection on it?
Not a windows 10 specific question: I'm unable to perform "clean" command with diskpart on my USB memory stick. Getting a nice little error "DiskPart has encountered an error: The media is write protected." Checked disk attributes and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:50.
Find Us