Windows 10: Access Denied on External Drive Solved

  1.    11 Dec 2017 #1

    Access Denied on External Drive


    I was hoping that this take ownership feature would give me access to files I have on an external drive formatted with NTFS.

    I am still receiving the following error when I try to copy a file from the external drive to anywhere on my local drive or if I try to play an mp3 song or open any office documents. I receive a message from these apps that the program cannot access this file.

    Click image for larger version. 

Name:	image.png 
Views:	45 
Size:	16.4 KB 
ID:	167771

    I am prompted to provide permission but still get file access denied. I am currently logged in with an administrator account JCLATOP\Joe
      My ComputerSystem Spec

  2. Layback Bear's Avatar
    Posts : 994
    Windows 7/64 Professional
       11 Dec 2017 #2

    I'm no expert on such matters but I think it would help if we had more information.

    1. What brand is the external drive and specs?
    2. Was the troubled drive data installed from this computer?
    3. Was the external drive encrypted?
    4. Have you tied to enter this drive using Admin permission?

    Note:
    I'm new to Windows 10 so I might not be able to help but others will need the information.

    Jack
      My ComputersSystem Spec

  3.    11 Dec 2017 #3

    Is this setup from the current PC or other have you done clean install as that would make the sid different even if it's the same name. Who has full rights on the drive?
      My ComputerSystem Spec

  4.    11 Dec 2017 #4

    You could display your profiles effective access if you wanted.

    Either you have access or you don't. If you don't, take ownership and then give yourself authority.
      My ComputerSystem Spec

  5.    11 Dec 2017 #5

    I have full access to this drive and files as far as the security tab shows. All files receive these same permissions and ownership.

    Click image for larger version. 

Name:	image.png 
Views:	29 
Size:	26.3 KB 
ID:	167800

    I read that it has to do with the drive being formatted as NTFS and it is using the credentials from that computer and seems to be an issue with Windows 10. There are many people with this same issue. I thought take overship with resolve this but it has not. I am able to access these files if I plug the external drive into a Window Ready2009 computer I have at work.

    I actually have two different USB external drives that I can plug into my laptop and I am not even able to copy files from one drive to the other. I get the same access denied message.

    Here is the disk part detail on the drive:

    Maxtor OneTouch III USB Device
    Disk ID: DA9C2DC9
    Type : USB
    Status : Online
    Path : 0
    Target : 0
    LUN ID : 0
    Location Path : UNAVAILABLE
    Current Read-only State : No
    Read-only : No
    Boot Disk : No
    Pagefile Disk : No
    Hibernation File Disk : No
    Crashdump Disk : No
    Clustered Disk : No


    Volume ### Ltr Label Fs Type Size Status Info
    ---------- --- ----------- ----- ---------- ------- --------- --------
    Volume 3 D NTFS Partition 149 GB Healthy
    Last edited by joeyCoyle; 11 Dec 2017 at 14:46.
      My ComputerSystem Spec

  6.    11 Dec 2017 #6

    There may be corrupted files due to Bad Sectors on the HDD.
    With one of the drives plugged in, Press the Win Key+X and choose Command Prompt (Admin)
    Here type the drive letter of the drive (ie) D: and press enter (ie) D:\> at this prompt type chkdsk /R and press enter. Now type a Y for Yes to Unmount the drive. Check Disk will go thru 5 stages and may take a while. After that is done, try it again.
      My ComputerSystem Spec

  7.    11 Dec 2017 #7

    The quick fix is to use the free app to convert NTFS to fat32 which removes all security you don't loose any data and it's simple to convert back to NTFS
      My ComputerSystem Spec

  8.    11 Dec 2017 #8

    There seemed to be an issue with the account I was signing in with. I was setup to use Windows Account to log in with. I changed to use local account and was able to access files. I then changed back to logging in with Windows Account and I am still able to access the files. There must of been an issue with the account.
      My ComputerSystem Spec

  9.    11 Dec 2017 #9

    You know, Samuria, they say that "great minds think alike, but so do mediocre ones." I had the same thought you voiced in your suggestion to convert the drive to FAT32, though I was thinking more along the lines of exFAT because of the larger file sizes it supports.
    Click image for larger version. 

Name:	f32-v-xfat.jpg 
Views:	1 
Size:	36.6 KB 
ID:	167814
    Good on you, mate!
    --Ed--
      My ComputersSystem Spec


 

Related Threads
We have two windows 10 laptops (both locked with a different password). I have been experiencing several difficulties trying to setup a sharing network, I'll get into that a later date. Since I have been having several difficulties with the...
My issue is basically the same as some old posts and I have tried all suggestions with no luck. I am running Win 10 recently updated with a Western Digital external T2 hdd. My explorer view sees the drive on my network, however access is denied...
Hi ok to give a bit of background , roughly 6 to 7 months ago I had a hacker get into my pc and though that person did not really do anything but steal things from my pc and drives .... I did all I could to protect what I have in my pc ,,,,so I...
Following a successful upgrade from my PC running Windows 7 pro 64bit I had a short while running OK. I then had a Notepad window appear on startup together with a sub window saying 'access denied'. Clearing these was no problem but I asked on...
Finally in version 10565 you are able to move/install Apps to other location than C:\Program Files\WindowsApps To change permissions for C:\Program Files\WindowsApps to be able to see what was inside the folder was easy however to do the same on...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:36.
Find Us