DirectX Issues (Steam)


  1. Posts : 5
    Windows 10 (Mac Boot Camp)
       22 Jan 2017 #1

    DirectX Issues (Steam)


    I'm running an Early 2015 MacBook Air with Intel HD Graphics 6000 and an Intel i5 processor with 8GB of RAM with Windows 10 64-bit through a Boot Camped external drive. Overwatch, RollerCoaster Tycoon 2, and Portal 2 all run perfectly fine - heck, Portal runs better than it did in Mac mode.

    However, games with the pop up that says "Installing DirectX" as they boot in Steam don't work - they start to boot and then stop immediately. Sonic Generations in particular says three .dll files (XINPUT1_3.dll, d3dx10_43.dll, and d3dx9_43.dll) are missing and then doesn't boot.

    I've found that I need DirectX 9, I believe (Windows 10 has DX12 installed automatically). The DirectX installer within each game's files (and the same file grabbed from numerous sources online) fails the installation, saying to check the .log for the issue (which I can't make heads or tails of). The Direct End-User Runtime Installer on Microsoft's website, which I've been directed to as a be-all fix repeatedly, does not work and fails to install as well with an error with advpack.dll. I've updated my graphics card drivers, updated Windows 10 twice, reinstalled multiple games repeatedly, and even turned off antivirus and nothing works. This is getting increasingly frustrating as I can't play the majority of my games, which is what I did this Boot Camp process for in the first place. Boot Camp shouldn't be the problem; as I said, some games work just fine and I haven't found anyone else through hours of Google searching that had the same problem as me.

    Can anyone please help? I'm desperate at this point.
      My ComputerSystem Spec

  2.    22 Jan 2017 #2

    Just to check you are using this download which does work with Win10?
    "http://www.microsoft.com/en-us/download/details.aspx?id=8109"
    Should be obvious, however some I have come across dont realise that you need to run DXSETUP.exe from the folder it downloads to, should run with Admin privileges however try Running as admin if it's failing.

    Link keeps coming up on here as access denied so copy between the quotes.
      My ComputersSystem Spec


  3. Posts : 5
    Windows 10 (Mac Boot Camp)
    Thread Starter
       22 Jan 2017 #3

    I've downloaded that and ran the same file out of Steam game directories multiple times, both as admin and not. Each time it fails and says I need to check the .log files for what went wrong.
      My ComputerSystem Spec

  4. TairikuOkami's Avatar
    Posts : 3,475
    Home 1809 x64 10.0.17763.134
       23 Jan 2017 #4

    Rycaster said: View Post
    The Direct End-User Runtime Installer on Microsoft's website, which I've been directed to as a be-all fix repeatedly, does not work and fails to install
    Have you downloaded Redistributable version?

    You can always download needed DLLs and put them to System32 folder manually.
      My ComputerSystem Spec


  5. Posts : 5
    Windows 10 (Mac Boot Camp)
    Thread Starter
       23 Jan 2017 #5

    Yeah, the DXSETUPexe doesn't work. It's the same installer within Steam games. I put the .dlls Sonic Generations was asking for in the folder and it doesn't ask for them anymore, but it does give a new error code. After inserting the .dlls, most of my Steam games are still not booting. No error code, they just don't run.
      My ComputerSystem Spec

  6.    23 Jan 2017 #6

    Humour me, run sfc /scannow, it has happened in the past that a missing or corrupt system file could cause problems installing directX.
      My ComputersSystem Spec


  7. Posts : 5
    Windows 10 (Mac Boot Camp)
    Thread Starter
       23 Jan 2017 #7

    One of the first things I tried actually, haha. No errors were found.
      My ComputerSystem Spec


  8. Posts : 5
    Windows 10 (Mac Boot Camp)
    Thread Starter
       23 Jan 2017 #8

    So, uh...hypothetically speaking...would running this whole ordeal in Windows To Go be an issue...?
      My ComputerSystem Spec


 

Related Threads
I am trying to buy some Telltale games from the MS Store, but it doesn't let me buy them as there is no green tick against the DirectX 11 requirement, even though I have DirectX 12 installed? Thanks.
Not sure if many of you noticed, but post Windows Insider build 14936, the Steam overlay would refuse to work with 64 bit games. Starting with the public beta build of Steam that is available today, that issue is resolved. You can opt in to Steam...
Solved directx 11.2? in Drivers and Hardware
I upgraded from 8.1 to 10 and everything's ok but my dxdiag says directx 11.2? I have the latest Nvidia W10 driver for my Geforce 610 (353.62), all fermi will have DX12 support and Windows update even updated it shortly again, causing some issues...
DirectX 11.2 overwrote DirectX 12 in Software and Apps
Hello everybody ! I recently upgraded to windows 10 from 8.1 and got DirectX12 , but when i tried to install a game it automatically overwrote it with 11.2 . Because dx12 is exclusively for windows 10 I can't find anywhere an installer or...
Directx 12 in Software and Apps
Hi i am new to this forum i just upgraded to windows 10, but when i run dxdiag it says directx 11.1 is this normal? Shouldn't be directx 12, can i do something to get the new directx 12 or i have to wait for an official uptade? thanks
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:44.
Find Us