Microsoft Solitaire Collection closes on launch, reason unknown.

  1. Posts : 50
    Windows 10 Pro x64

    Microsoft Solitaire Collection closes on launch, reason unknown.

    Hello forum members, it's been awhile since I last posted anything. I've been busy testing and working with Windows 10. While the OS has improved I find that there are still numerous bugs to work out, even on the stable Anniversary Update build.

    My problem today deals with one of the store apps, namely the Microsoft Solitaire Collection. The game was working fine for a long time, granted I only played it every so often, and then a few days ago I tried running it and it just closes and exits from the memory. Task manager shows that it does indeed crap out and close. If anyone knows why please inform me.

    Now I figure it would be helpful to post some more detailed information about this issue. Yes I have googled the crap out of this problem before coming here. I chose to ask here because the Microsoft Answers site is a complete joke.

    I think the problem started when I was trying to fix Cortana. Cortana I noticed no longer does web searches and the notebook settings tab is no longer there, so I tried to fix it. At one point I had her working again(not sure how I did it though) but then that's exactly when Solitaire stopped working correctly. I kept messing with the Windows Apps directory and the permissions on that folder because I am almost certain that the problem lies in access rights to the apps. Sadly my attempts to correct both of the issues resulted in the start menu and notifications center no longer flying out. So in that case I used system restore to take me back about 3 days and that fix the system back to a state where Solitaire worked but I lost Cortana's advanced search functions again.

    So I tried again to work on Cortana and repeated what I thought was the correct steps to fix it but it didn't work this time around, and now this has messed up Solitaire again, I just can't seem to win with Win 10. Cortana aside I just don't care to get the web search and other functions of Cortana back, and I just recently did the 3rd fresh install of Windows 10 from scratch, I'm not doing that again to fix Cortana or Solitaire.

    All the other apps work fine and that is what's got me lost. Why is it that only Solitaire is failing to launch? I've done the sfc /scannow a bunch of times and it reports no integrity violations. The DISM tools is unable to find a source even when I explicitly told it where the install.esd file is and used both a flash drive and mounted ISO image for the source data. Both failed to find the source files. I've ran the Get-App whatever registration command to re-register all the apps more times than I can remember. That screen is full of info some apps install fine others throw red error messages that are to cryptic to really understand and points to missing manifests. I've even taken the System apps and Windows apps folders from another working system and copied the various data's over to their respective folders to try and correct for corrupt or missing data. Even with directory ownership and removing specific folders and restoring them from the uncorrected backup fails to correct it.

    This leads me to think the problem is either in the registry somewhere or in the folder permissions. Which are currently owned by my user account name Britton and applied to all subfolders in the Windows Apps folder only. I left the System apps folder alone because last time I messed with that one it locked up the start menu and notification center prompting a system restore. I'm going to make TrustedInstaller the owner of the Windows apps folder again becuase that is the default owner of that folder, at least I'm pretty sure it is. All i know is either owner works and none of the apps except for Cortana and Solitaire seem to have a problem no matter who has ownership of that folder.

    Anyway I know that is a lot to read through and to finish this up I'm posting an event log that might help figure this out. Below is the log for the Solitaire error. I'd like to fix Solitaire if possible, don't really care if Cortana works or not.

    Faulting application name: Solitaire.exe, version:, time stamp: 0x58178454
    Faulting module name: Windows.UI.Xaml.dll, version: 10.0.14393.351, time stamp: 0x5801a795
    Exception code: 0xc000027b
    Fault offset: 0x00000000006d714b
    Faulting process id: 0x1f54
    Faulting application start time: 0x01d244026dece6a0
    Faulting application path: C:\Program Files\WindowsApps\Microsoft.MicrosoftSolitaireCollection_3.12.10310.0_x64__8wekyb3d8bbwe\Solitaire.e xe
    Faulting module path: C:\Windows\System32\Windows.UI.Xaml.dll
    Report Id: 1ad54ac0-f4f7-4536-9075-15cfd4d100e9
    Faulting package full name: Microsoft.MicrosoftSolitaireCollection_3.12.10310.0_x64__8wekyb3d8bbwe
    Faulting package-relative application ID: App
    Last edited by Brink; 13 Apr 2017 at 22:55. Reason: restored
      My Computer

  2. Posts : 69,970
    64-bit Windows 11 Pro for Workstations

    Hello Britton, :)

    If you haven't already, you might see if resetting the Microsoft Solitaire Collection app may be able to help.

    In the worse case situation, you should be able to do a repair install to fix both apps without losing anything, and avoid a fresh install.

    Repair Install Windows 10 with an In-place Upgrade
      My Computers

  3. Posts : 50
    Windows 10 Pro x64
    Thread Starter

    Thanks for the ideas Brink, I'll give them a try later on today and report how it went.
      My Computer

  4. Posts : 50
    Windows 10 Pro x64
    Thread Starter

    I did the reset option in the apps and settings menu but that didn't have any effect. I had tried that the other day with the same results.

    Just watched the video on the tutorial page, I'll give that a try. Though I didn't think the installer worked that way unless the system was being upgraded from a different version. Such as Windows 7 or 8.1. Anyway I'll try that now and see what happens.
    Last edited by Britton; 22 Nov 2016 at 10:46.
      My Computer

  5. Posts : 50
    Windows 10 Pro x64
    Thread Starter

    Alright I did the upgrade install options and the outcome was not good. Instead of just solitaire not launching all MS store apps and system apps, including the start menu and the settings app failed to work. The start menu itself will pop up but struggles and becomes unresponsive. Once opened the second attempt to open it results in nothing. As in no start menu pops up, but I can manually restart explorer and have the start menu work again but each time is different. There is a massive delay sometimes for the action center and start menu to fly out. That's just the tip of the iceberg since none of the apps will run anyway.

    Oddly my regular programs (when did programs become apps, ridiculous) still work firefox pops up normally, allowed me to get back here and post this. Since other apps like Firefox and Winamp, Irfanview all seem to work normally this has lead me to what I feared was the cause. Folder permission settings. Check out the mess below in the screen shot.

    Microsoft Solitaire Collection closes on launch, reason unknown.-shambles.jpg

    On the left is the messed up permissions, they where not even touched apparently by the upgrade install and on the right is the System Apps folder with it's permissions left as is. This leads me to think that this is the source of the problems since the framework and VC runtimes are stored there and without proper permissions for the other Apps data folder nothing can run.

    I'm going to take the time to manually correct all the permissions and make the entries inherit their permission from the parent directory and make SYSTEM the owner of those folders. I think it was TrustedInstaller by default but I'm not sure anymore. If all this still fails I know what has to be done next

    I'm still open to other suggestions if anyone who has been down this road has some.
      My Computer

  6. Posts : 50
    Windows 10 Pro x64
    Thread Starter

    Yeah figured no one would have any ideas for this issue. All the fixes and ideas to recover the operating system failed. I even went as far as manually setting all 156 subfolders of the WindowsApps directory permissions. I set TrustedInstaller as the owner in the end and even that wasn't able to fix it. Whatever MS does to that folder is beyond my technical skill level, but I know one thing it's a pain in the a** when Windows 10 corrupts on itself.

    I am probably to blame for the issues since I know I did at one point go in the WindowsApp folder and bypass the lock out action. I want to cuss someone out at MS so bad right now but I can't. Just for making such a wretched pile of crap and pushing it out to everyone in the world. Lesson learned, just leave the installed apps alone and in the future use only the powershell to uninstall them.

    Final solution - Reinstall Windows from scratch.

      My Computer

  7. Posts : 69,970
    64-bit Windows 11 Pro for Workstations

    Unfortunately, when permissions get messed up, sometimes only a clean install will help.
      My Computers


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:02.
Find Us

Windows 10 Forums