Windows 10: Metro games crash immediately with DCOM timeout error - with AzureAD Solved

  1.    18 May 2016 #1

    Metro games crash immediately with DCOM timeout error - with AzureAD


    hi,
    i've read dozens of threads here and elsewhere where windows 10 users have lost their start menu, lost their store app, lost the ability to open all store apps, or lost cortana. these all seem to stem from the 1511 update. i am familiar with all the troubleshooting steps listed on these threads, and they have all been unsuccessful for me. changing registry permissions, NTFS permissions on WindowsApps etc for the All Application Packages user, system restore etc.

    i have 5 machines all with clean windows 10 installs. these are Windows 10 Pro "N" installs on various hardware. 4 of the machines are joined to AzureAD and my win 10 tablet is not joined to any domain or AzureAD. the tablet is the only one that can play xbox games. since the 1511 update, the other 4 have lost the ability to open games, they crash immediately with DCOM error 10010 The server App did not register with DCOM within the required timeout. and a corresponding "Apps" application log entry: "Activation of application Microsoft.HaloSpartanAssault2_8wekyb3d8bbwe!App failed with error: The app didn't start. See the Microsoft-Windows-TWinUI/Operational log for additional information." i am certain that a re-install will result in the same problems because i have replicated identical behaviour on 4 independent machines. the definition of stupidity now would be to reinstall the OS and expect it to be any different!

    i can confirm that the start menu store works fine, i receive app updates and can use one-note, calculator, solitaire and every other metro app i can think of. however any xbox games will not open, example Age of Empires Castle Siege, and Halo Spartan assault. Cortana is not available in Ireland so it is disabled by windows.

    does anyone have any ideas how to fix this? i've tried logging in as a local administrator user and the problems are the same. AzureAD jumps out as the most likely culprit, perhaps with some security policy that has been applied to the 4 problematic machines, but i have been unable to identify the cause. i searched around in the AzureAD control panel and could find no relevant settings. thanks for any help!
      My ComputerSystem Spec

  2.    14 Jun 2016 #2

    to answer my own question, the reason apps were failing to launch is because the media pack was not installed, i used a Windows 10 "N" install, and this requires a special media pack, note you must install the version of the media pack for update 1511, the previous version will fail to install. here is the link:
    Download Media Feature Pack for N and KN versions of Windows 10 from Official Microsoft Download Center
      My ComputerSystem Spec


 

Related Threads
Apps Immediately Crash in Software and Apps
Hi Everyone, I've run into this problem where I'm offline and I open a modern app, I might see the app for a moments, but then immediately closes or crashes. It doesn't seem to happen to the mall/calendar app that comes with Windows 10. ...
My games now crash straight to the desktop now. GTA V, MGS V, Just Cause 3, very strange I don't know if it was a Windows update or something with Nvidia? I rolled back drivers and still the same, it was doing it before this update but out of the...
I can't open 2 games. Of course i can play just 1, but i need to put one in taskbar (SAMP) and when i want to open other game (it doesn't matter what game ), the second game i open crashes. Any solution? 57640
Continuing DCOM event viewer error in Performance & Maintenance
I recently started getting this error in event viewer. There are a number of threads across the web about it, but none of them has presented the solution. The error is related to Runtimebroker.exe. Any new ideas? The application-specific...
All metro apps crash. in Software and Apps
This is a problem I have been having for a few days now. Upon launching any metro app, it crashes. Attached is a picture with the diagnosis of the problem. Any way to fix that?? 15304 Thank for any help!!!
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:28.
Find Us