Windows 10: Loss of performance on 10041 compared to 9926? Solved


  1. Posts : 1,495
    Windows 10 Pro Insider Preview x64
       20 Mar 2015 #1

    Loss of performance on 10041 compared to 9926?


    Is anyone else seeing a major loss of performance after moving from 9926 to 10041? Games that I was getting 40-60 FPS in before (ACU, FarCry 4 etc) I'm now not even able to crack 30 FPS on a regular basis.

    Massively annoying.
      My ComputerSystem Spec


  2. Posts : 51
    Windows 10 Pro 64bit Anniversary
       23 Mar 2015 #2

    blackroseMD1 said: View Post
    Is anyone else seeing a major loss of performance after moving from 9926 to 10041? Games that I was getting 40-60 FPS in before (ACU, FarCry 4 etc) I'm now not even able to crack 30 FPS on a regular basis.

    Massively annoying.
    I am playing only World of Warcraft on my laptop, but I haven't experienced any performance loss at all. It is the same, maybe a bit faster for me (and you can see, my laptop is not some high-end gamer piece of hardware ).
      My ComputerSystem Spec

  3.    23 Mar 2015 #3

    To be honest I've not noticed a drop.. not an increase but it's just about the same on my PC,
      My ComputerSystem Spec


  4. Posts : 1,495
    Windows 10 Pro Insider Preview x64
    Thread Starter
       23 Mar 2015 #4

    Yeah, for some reason, it seems like it's only Ubisoft games giving me issues. I'm still getting 50+ FPS on Dying Light.

    Freaking Ubisoft...
      My ComputerSystem Spec


 

Related Threads
hi all, after fresh install windows 10 9926 or 10041, my usb port can't work properly. to be exact, when i try to install my wifi adapter (tp-link), even the installation take too long, and end up fail. then using other tp-link model adapter, the...
Hi there Reverted back to 9926. TWO mega showstoppers for me. 1) START MENU totally hosed up again -- Brinks mod to get back the old menu from previous builds doesn't work. My installed applications don't appear on it and the search is TOTALLY...
Hello Every one, New windows 10 user via Vmware, i just did the windows update to 10041, but its still showing as a 9926 build, is this normal ?? 1500015001 thanks in advance.
Iíve installed 9929 version by ISO image... In my pc it runs wonderfully and Iím really happy with it. Yesterday I tried to update it by windows update service to the newer 100041 but I received back this message after the installations stopped at...
Updating to 10041 from 9926 fails twice. in Installation and Upgrade
Today, I tried to update 9926 to 10014 through windows update and both times it failed. After several reboots during the installation I got a window with a message saying something like, "Couldnt' update to Windows Technical Preview -- Have...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 13:30.
Find Us