1.    11 Jan 2016 #1
    Join Date : Jan 2016
    Posts : 2
    Windows 10

    JIT debugging - Total War - Mod Manager


    Hello all, my first post here! I'll keep it simple, I got Rome Total War 2 and want to install a mod but whenever I start the manager is gives me an error message:

    Vallue cannot be null.
    Parameter name: path1.
    And if you expand the details in says:

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.


    ************** Exception Text **************
    System.ArgumentNullException: Value cannot be null.
    Parameter name: path1
    at System.IO.Path.Combine(String path1, String path2)
    at TWModManager.Game.GetGameDirectory()
    at TWModManager.FormMain.FormMain_Load(Object sender, EventArgs e)
    at System.Windows.Forms.Form.OnLoad(EventArgs e)
    at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
    at System.Windows.Forms.Control.CreateControl()
    at System.Windows.Forms.Control.WmShowWindow(Message& m)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)




    ************** Loaded Assemblies **************
    mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.8670 (QFE.050727-8600)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
    ----------------------------------------
    TWModManager
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.0.0
    CodeBase: file:///C:/Program%20Files%20(x86)/Total%20War%20Rome%20II/ModManager.exe
    ----------------------------------------
    System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.8670 (QFE.050727-8600)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.8670 (QFE.050727-8600)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.8670 (QFE.050727-8600)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    Accessibility
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.8670 (QFE.050727-8600)
    CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
    ----------------------------------------


    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.


    For example:


    <configuration>
    <system.windows.forms jitDebugging="true" />
    </configuration>


    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.

    I dont know what the problem is because before I did a total reset on my laptop it worked fine!
      My ComputerSystem Spec
  2.    11 Jan 2016 #2
    Join Date : Jan 2016
    Posts : 2
    Windows 10
    Thread Starter

    No one knows something about this error code?
      My ComputerSystem Spec
  3.    02 Mar 2017 #3
    Join Date : Mar 2017
    Posts : 1
    win 10

    I have the same problem an year later. Have you found any solution? Any help would be highly appreciated.
    Thank you.
      My ComputerSystem Spec
  4.    04 Mar 2017 #4
    Join Date : Apr 2015
    Posts : 172
    Windows 10 Enterprise x64

    This error basically means that you need a standalone debugger software installed on your PC. Instead of your error message showing, your debugger will open instead (if you have one, and have assigned it according to the instructions). As for what else the issue might be, no idea, since I've only ever played the TW games without mods.
      My ComputerSystem Spec
  5.    04 Mar 2017 #5
    Join Date : Jul 2015
    Canada
    Posts : 123
    Win7 Pro x64/Win10 Pro x64

    Quote Originally Posted by did91 View Post
    I have the same problem an year later. Have you found any solution? Any help would be highly appreciated.
    Thank you.
    Are you getting the exact same error message as the OP? If you are, the mod loader is missing a path to something. It either can't find the game, or the mod, or the mod manager. I'm not sure which.

    You could try adding the game and the mod manager to your PATH environment variable and see if that works...
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved bitdefender total security
I have tried installing Bitdefender total security 2014 from both disk and from there website. It does not seem to want to work yet. does anyone have the same problem? i shall continue using malwarebytes which i shall buy full next year after...
AntiVirus, Firewalls and System Security
Solved Total Computer Freeze
So my computer started running a bit slower then it should be, at the point where my computer to open would take half a min, so i did fresh install. So i left installation overnight, i wake up in the morning and it say "Hi there" installation menu...
Installation and Upgrade
Total Defense
I thought I'd be brave and try to install Total Defense's (paid) anti-virus program that works under Windows 8.1 It installed okay although did give me a warning about "some incompatability issues". On re-boot however the PC just "hung", my guess...
AntiVirus, Firewalls and System Security
VIRUS TOTAL Bookmarked
While Miles was helping some one in Eight Forums he made a recommendation for the user to scan a URL with an online scanner. An then it came to me, I should have Virus Total bookmarked. https://virustotalcloud.appspot.com/static/img/logo.png ...
AntiVirus, Firewalls and System Security
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:32.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums