1.    17 Nov 2015 #1
    Join Date : Nov 2015
    Posts : 3
    Windows 10 64 Bit

    Archeage - Disconnects every time i select a server


    Hey there,

    I recently built a new PC and installed windows 10 as my operating system (some what regretting it at this moment) and i have installed a game called Archeage that worked just fine on windows 7 with no connection issues what so ever. Now with windows 10 as i try to select a server i get disconnected right away with maybe a 1/100 chance of actually connecting to the server.

    Is there something i have to configure with windows 10 to allow me to connect to game servers because i find i have a similar issue with Black Ops 3 in terms of connecting to the server.

    This is quite frustrating for me and any help in this would be appreciated..

    Thanks,
    Rhodric
      My ComputerSystem Spec
  2.    17 Nov 2015 #2
    Join Date : Sep 2014
    Cheshire, UK
    Posts : 445
    Windows 10 Home 64bit

    Trionworlds posted this a while ago regarding Windows 10 compatibility Windows 10 - Our Current Status!!

    and also posted this link if you have any Windows 10 Woes.
    Trion Worlds Support Center
      My ComputerSystem Spec
  3.    17 Nov 2015 #3
    Join Date : Nov 2015
    Posts : 3
    Windows 10 64 Bit
    Thread Starter

    Ah shit i saw this "ALL Trion games are ready for Windows 10 release." and assumed it meant all games but further down it says Archeage is under review.... What a pain in the ass...
      My ComputerSystem Spec
  4.    17 Nov 2015 #4
    Join Date : Sep 2014
    Cheshire, UK
    Posts : 445
    Windows 10 Home 64bit

    guess you'll just have to wait for a response, sorry.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
General Tips Synchronize Clock with an Internet Time Server in Windows 10
How to Synchronize Clock with an Internet Time Server in Windows 10 Your PC's clock is used to record the time whenever you create or modify files on your PC. You can change the clock's time and time zone. You can synchronize your PC's clock...
Tutorials
Are you still running SQL Server 2005? Time to Upgrade.
Source: Are you still running SQL Server 2005? Now is the time to upgrade to a modern data platform - The Official Microsoft Blog
Windows 10 News
Windows Upgrade Won't start - Windows Server Update Server installed
Hi All, I've tried to run the upgrade from Windows 7 to 10. It fails with the pre-requisite as I had the WSUS 3.0 SP2 admin console installed. I uninstalled this and tried to resume but it still thinks it's installed and won't progress. I've...
Installation and Upgrade
Windows Server 2016 leaks reveal Nano Server, protected VM role plans
Read more: Windows Server 2016 leaks reveal Nano Server, protected VM role plans | ZDNet
Windows 10 News
My Win10 Ent' time server was mis-set after install.
Is your internet time off? Are you running Win10 E? Try changing to the second server on the list. It works!
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:01.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums