Windows 10: star trek online below par perormance

Page 2 of 2 FirstFirst 12
  1.    26 Oct 2015 #11

    roger that. going to try that tomorrow or wednesday. expecting to have the desk set up and the tower set up by then.
      My ComputerSystem Spec

  2.    27 Oct 2015 #12

    Good luck! Here's a picture. I wasn't home when I posted my previous reply. Don't forget to click the "Apply" button.
    Click image for larger version. 

Name:	screen.png 
Views:	1 
Size:	50.0 KB 
ID:	44910
      My ComputerSystem Spec

  3.    27 Oct 2015 #13

    if it doesnt work and hp support cant help, well I'm within the 30 day returns window still, I'll just go with a different hardware vender.

    as it is I'll be rearranging my room to accommodate a new desk and will soon after be setting up the new hardware.
      My ComputerSystem Spec

  4.    27 Oct 2015 #14

    ok..its using the dedicated card. as in there's no option to change it. so...what do I do next?
      My ComputerSystem Spec

  5.    28 Oct 2015 #15

    Can you show me a screenshot?
      My ComputerSystem Spec

  6.    28 Oct 2015 #16

    yeah, might take me a few days, now I'm waiting on the chance to run an ethernet line as trying to do anything on wifi past basic browsing and skype chatting is a fiasco and a half.
      My ComputerSystem Spec

  7.    29 Oct 2015 #17

    what area in specific do you need a screenshot of?
      My ComputerSystem Spec

  •    30 Oct 2015 #18

    To be honest, you're not the only one with performance problems in STO. It may/may not be your hardware, but the game itself runs on a really bad game engine that isn't all that optimized.

    I used to play the game maxxed out graphics wise back in the Legacy of Romulus expansion, but after that and starting with Delta Rising performance has just taken a nose dive and I can't even play the game maxxed out anymore...I literally have to make the game look horrible looks wise just to get any sort of decent FPS nowadays.
      My ComputerSystem Spec

  •    30 Oct 2015 #19

    xraiderv1 said: View Post
    what area in specific do you need a screenshot of?
    The same as my screenshot. Also LovingWindows might be right as well.
      My ComputerSystem Spec

  •    30 Oct 2015 #20

    ok, on a similar line of discussion if I may..

    well I took a friend's advice with starwars the old republic, turned off anything shadow related. I can run the graphics pretty well towards the maxxed out end though I zeroed out the trees and grass for obvious reasons, as they too contribute to lag in that game.
      My ComputerSystem Spec


  •  
    Page 2 of 2 FirstFirst 12

    Related Threads
    I am expieriencing a wierd start menu lag (for now im on the old start menu, i dunno if it appears on the fullscreen one because I haven't tested yet) and I want to ask if it's normal and/or how to fix it Let's say I have for example two tiles...
    i've used win 8, and 8.1 since day 1, and have fallen inlove with the zippiness and productivity enhancing start screen. the start menu to me is taking 35 steps back to the 90s. now that i have 10, i want that back, is there an extension or 3rd...
    I don't know if this is only for Windows 10, but I'll post it here, maybe someone knows a workaround. I installed Star Wars The Old Republic (the new MMORPG) and when I start it with my NVIDIA GeFore 610M card, it refuses to launch, no error...
    Chewy.. we're home. :) http://www.youtube.com/watch?v=wCc2v7izk8w
    http://www.youtube.com/watch?v=xWBGrkc360M :shock::D
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    © Designer Media Ltd
    All times are GMT -5. The time now is 09:09.
    Find Us