I even have posted this in the The Division 2 reddit forums but no replies so far

I have this problem CTD that is driving me insane, right until August 2nd I was playing The Division 2 on Windows 1809 perfectly well no crashes, no lags nothing and then I updated to Windows 1903 and also installed all patches and started playing The division 2 again no crashes, no lags nothing but a peculiar mouse problem was affecting my game play especially when using Aces & Eights or any marksman build I had the mouse pointer was very jumpy, I restarted the game cleared all games files but still the problem persisted even in Photoshop and Premier PRO which was not the case in Windows 1809.

So I did a backup of my entire drive using Acronis and did a fresh install of Windows 1809 now every time I start the game it loads up easy anticheat a black screen and crashes to the Desktop which was never the case previously when I was running the same Windows version... I did a verify on game files still CTD, uninstalled/re installed Uplay CTD, fresh re download of the game CTD, I then did a backup of Windows 1809 using Acronis and went back to 1903 and lo and behold the game is running fine, restored my backed up 1809 and CTD no extra software no nothing similar to what it was before I upgraded to 1903. On 1903 whether I use DX 11 or 12 it runs fine for hours but on 1809 CTD on DX 11 and 12, previously before upgrading to 1903 I was playing on DX 11 right from march uptil June and then switched to DX 12 and no problems.

I forgot to mention that Assassin's creed odyssey and other games run fine on both Windows (1809/1903)

I just don't understand why this is happening?? can anyone pls explain to me what could possibly be wrong.

My PC specs:

MB: ROG RAMPAGE VI EXTREME OMEGA | CPU: Intel Core i9-9920X | GPU: Nvidia GeForce RTX 2080 Ti | RAM: 2 X 16GB DDR4-3200 | Storage: 3 X 1TB SSD