hi, Im trying to install xbox (beta) game apps to the d:\ (game installs) yet it wont let me unless its the default app directory.

i also cant change the default app directory from c:\ to d:\ idk why. attached in the error message 0x80070003.

I read here that 0x80070005 is denied access so i tried the icacl solution in command prompt, but it didnt help. any ideas?Click image for larger version. 

Name:	1.JPG 
Views:	2 
Size:	62.6 KB 
ID:	241770Click image for larger version. 

Name:	2.JPG 
Views:	2 
Size:	83.4 KB 
ID:	241771Click image for larger version. 

Name:	3.JPG 
Views:	2 
Size:	86.7 KB 
ID:	241772Click image for larger version. 

Name:	4.JPG 
Views:	3 
Size:	75.8 KB 
ID:	241773

- - - Updated - - -

I fixed it, by removing all my "d:\game_installs" and Steam_directory off the drive, formatting the drive, and then changing location of windows 10 default apps. it took about 2 hrs to move everything :S theres gotta be an easier way to manipulate microsoft apps and folders than formatting a drive?