Logitech K740 - Can't SHIFT + SPACE in a Game!

  1. DjDave238's Avatar
    Posts : 13
    Windows 10 Home (1803 Build 17134.590)
       #1

    Logitech K740 - Can't SHIFT + SPACE in a Game!


    I have a brand-new Logitech K740 Illuminated Keyboard (that's about to get sent back). For some reason, I can't run and jump at the same time in any game; pressing Space while holding Left Shift does absolutely nothing.

    I see only that Shift+Space+W doesn't work, but can't find anything about Shift+Space...

    I tried downloading Logitech's driver for the keyboard, but that didn't do any good.

    Any thoughts???

    - - - Updated - - -

    Oops, it is W+Shift+Space..... they did it on purpose.
      My ComputerSystem Spec

  2.    #2

    I've done some research on this keyboard.. it's a common problem and some people have claimed it's been fixed with newer batches of the keyboard.. some not.

    I would send it back and perhaps pick up a different keyboard.. do you mainly game or work on your PC?
      My ComputerSystem Spec

  3. DjDave238's Avatar
    Posts : 13
    Windows 10 Home (1803 Build 17134.590)
    Thread Starter
       #3

    I do both. I am a programmer, and I play a lot of Creativerse and Space Engineers. I already repackaged and initiated a return through Amazon... ordered an AmazonBasics keyboard instead, we'll see how it does.
      My ComputerSystem Spec


 

Related Threads
New changes to Captures (GameDVR) means x2 storage space for all! Existing clips older than 90 days w/o views will be deleted, as will new clips unviewed after 30 days. Learn how to backup your favorite Captures here. 1056939106767261696
I just bought an Asus b350-f and a ryzen 5 2400g (no OC). I'm using the Vega 11 on board graphics. I'm using a fresh install of Windows 10 home 64bit. My graphic driver is the most current (17.7). When I launch civ 5 everything starts normal, the...
I have two Logitech mice (M570 and M720.) Been using 570 as my all around mouse, and just got 720 for photography editing. I have been using setpoint 6.67.83 with 570. I have tried and tried to use Logitech's support forum for the following...
I just picked up a few cheap games since like Call of Duty: Modern Warfare 3. To play this and NOT have to rely on my keyboard, I bought a Logitech F310 game controller. It's suppose to work right away once I plug it in....but like most things that...
Whenever I press Shift + Spacebar my computer acts like I pressed other keys, like f6 and others. This messes up a lot of things from typing to playing games. Is there a way to check if I accidentally made a shortcut or something?
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:12.
Find Us