1.    02 Aug 2015 #1
    Join Date : Jul 2015
    Posts : 6
    Windows 10

    Experiencing huge ping spikes 1k+


    I installed win 10 and ever since then have experienced like spikes like crazy, making games unplayable due to massive rubberbanding. Is anyone experiencing this and how can i fix this?
      My ComputerSystem Spec
  2.    03 Aug 2015 #2
    Join Date : Aug 2015
    Posts : 1
    Windows 10

    been having the same issue
    seems like there are some network driver issues
    when i use my ethernet cable steam/battle.net/origin/etc download slower then 100KB/s, when i was using win7 my DL speed was close to 1MB
    switched to my wifi dongle, and my DL speed jumped to around 500KB/s, yet as like with the ethernetcable, in win7 i was close to 1MB/s

    my ping skyrockets in games, up over 5000+ at times
      My ComputerSystem Spec
  3.    03 Aug 2015 #3
    Join Date : Jul 2015
    Posts : 6
    Windows 10
    Thread Starter

    no one else seems to have this issue, i think im gonna have to record it and show what im talking about. This is just ridiculous
      My ComputerSystem Spec
  4.    06 Aug 2015 #4
    Join Date : Aug 2015
    Posts : 1
    windows 10

    Quote Originally Posted by RobMathew View Post
    no one else seems to have this issue, i think im gonna have to record it and show what im talking about. This is just ridiculous
    I had the same problem when i installed windows 10. i fixed it by uninstalling my drivers for my wireless adapter, then restarting my pc, then reinstall and no more like spikes.
    Last edited by Smitty warben; 06 Aug 2015 at 23:26.
      My ComputerSystem Spec
  5.    11 Aug 2015 #5
    Join Date : Jul 2015
    Trinidad
    Posts : 18
    Windows 10 Pro

    Did you try clean uninstalling your drivers, downloading the latest versions and re-installing?
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Experiencing mouse lag/stutter when I open Microsoft Edge
I figured out that it's a graphic driver problem: when I start PC on safe mode or if I uninstall all graphic drivers the lag/stutter problem doesn't happen but if I install AMD Drivers again the lag problem starts. Can someone help please?
General Support
Solved Anybody experiencing sudden loss of apps Win10 Build 10162
Over the weekend everything was fine until I turned on my Microsoft Surface first thing this morning and the menu list on the left has vanished...? The apps are not working and it's asking me to reinstall them all but when I do it doesn't work...? I...
Software and Apps
Realtek Ethernet huge problem after installation
I just installed Windows 10 and everything went fine. Now I cannot connect to the internet and when I try to install the ethernet card drivers after 30 mins of "installation" an error is displayed "The realtek network controller was not found. If...
Network and Sharing
Huge news: Windows 10 can run reworked Android and iOS apps
Source A Guy
Windows 10 News
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:26.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums