So here is the whole Story folks, which i am having more than 2 weeks problems with :'(

1.) I downloaded a game (PayDay2) on Steam via friends account (he is using discord and some sdk, one of them is also discordrpc)

2) i tried to start the game but it was saying: @ Missing api-ms-win-.... .dll there was 10 or so of them. i downloaded all from this page ( Search )seperately and put them in the RIGHT folder!!!

3) Now when running the game its saying @payday2_win32_release.exe - Entry Point not found " The procedure entry Point could not be located in the dynamic link library C:\Program Files (x86)\Steam\steamapps\common\PAYDAY2\discord-rpc.dll. "

10.0) I deleted the whole game several times and tried to install them

11.0) I tried removing the discord-rpc.dll from the folder but it than says that the discord-rpc.dll file is missing

12.0) I INSTALLED A NEW CLEAN VERSION OF WINDOWS 8.1 and did a clean driver install, all! This time i downloaded the game over my steam profile (yes i have bought the game too but i had forgot my password ....) -----> AND AGAIN SAME STEPS 2---->3 :'((((((((((((((((((

ANYONE has ANYTHING on this ?? I would be so gratefull, all my friends playing it like and me just listening to them :$
i searched other forums and contacted steam and the game founder but no one seems to know anything. this is my last hope guys

I am using an Windows 8.1 64 Bit, 8GB Ram, 3.3 GHz quad core, hdd 500gb 2 partitions