Windows 10: Gaming labtop lagging without monitor connected to it

Page 2 of 2 FirstFirst 12

  1. Posts : 238
    Windows 10 Home Fall Creators Update 64-bit
       2 Weeks Ago #11

    Try the same mode just per application instead and see if it helps.

    1. Open Nvidia controlpanel (right click on desktop).
    2. Click Manage 3D Settings.
    3. Click the Program Settings tab.
    4. Choose Rust or PUBG from the list. If they're not in the list, uncheck the box "Show only programs found on this computer".
    5. Choose Nvidia processor from the dropdown menu and select High-performance NVIDIA processor from the list.
    6. Click Apply.
      My ComputerSystem Spec

  2.    2 Weeks Ago #12

    I already did that
      My ComputerSystem Spec


  3. Posts : 238
    Windows 10 Home Fall Creators Update 64-bit
       2 Weeks Ago #13

    And is the Nvidia processor being used while playing? Download MSI Afterburner and check the performance graph during gameplay, you can post some results here if you want. I don't understand why disconnecting a secondary monitor would give you performance issues when it's most common the other way around. If you can actively connect/disconnect the monitor and immediately see performance gains/loss then either the Nvidia processors is not being used correctly or there's some kind of power-saving feature enabled somewhere. Or maybe the refresh rate is running lower than usual? I honestly don't know unfortunately Maybe someone else here knows what's up, because I'm stumped.
      My ComputerSystem Spec

  4.    2 Weeks Ago #14

    Ok will do
      My ComputerSystem Spec

  5.    2 Weeks Ago #15

    14% cpu
    54%gpu
    39% memory
    1-10% disk
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
This one is really strange to me... Windows 10 cannot find a GPU diver for my integrated card. I had to switch to it when my installed GPU failed. I do notice on occasion that (probably due to the fact that I don't have the GPU driver) my text...
hello,, i am playing modern combat 5 game from windows store.. i feel lag in insider preview version 15014.1000 build 1607 even when i have high speed optical fibre net with 85ms ping.. cant revert back to rts build.. can someone help me fix the...
Hi, I have this weird problem whenever I connect my macbook pro to an external monitor. I'm running Windows 10 Pro. The problem occurs only when I close the laptop's lid. The mouse starts acting up, it applies clicks randomly. Perhaps...
I have temporarily connected a 22 inch LCD tv monitor( until i get a new one) to pc via HDMI lead but i cannot get resolution set right.The recoommended native makes the taskbar disappear of screen and the desktop icons are barely visible on left...
Hello everyone I upgraded to windows 10 yesterday and now i don't have any sound left. My internal labtop speakers don't get recognized and so are my headphones. i have a microphone(blue yeti) wich chan be used as a output, and it is the only one...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 04:04.
Find Us