So i installed borderlands 1 cause i was going to see if some of the older games worked. I installed it while on windows 7 and it worked no issue. (i installed it for windows 10 but i installed it before i updated windows)
I wanted to see if borderlands 1 worked on windows 10 so i tried to boot it after i updated to windows 10. It just does the loading circle for a moment and then does nothing. I checked task manager (and went to processes) and nothing. So i was like "Maybe it needs the net framework and Directx installed?" so i got the the DX installer from Microsoft's website and installed dx9, 10, and 11 (least re-installed it) and tried it again, nothing. Re-installed the game, nothing. I'm not sure as to why it is working. If anyone could help me fix this as i truly do want to re-play through the first borderlands again. Thank you for reading and suggestions. I can play borderlands 2 and The pre Sequel perfectly fine..

Also my keyboard is not working (was doing that before windows 10 but its not a driver issue, its the actual keyboard) So im using my bluetooth tablet keyboard to type this. (this thing is tiny, its for a 10 inch tablet and the keys are small)

CPU: Intel Core 2 Quad Q8200
GPU: MSI Twin Frozr II GTX 460
Mobo: Intel DP35DP
RAM: Generic 4GB 4x1GB DDR2 667
PSU: Logisys 480w