Windows 10: Canon scan from printer no longer works due to a Windows 10/64 update

  1.    08 Dec 2017 #1

    Canon scan from printer no longer works due to a Windows 10/64 update


    I understand from Canon that a windows 10 update is causing issues in that the scan to PC button on the printer control panel no longer works. I would go so far as to say that Microsoft have introduced a bug - not for the first time either.

    I mention it here as I spent not an inconsiderable amount of time trying to resolve, re-installing drivers, etc etc, before calling Canon - within seconds of explaining our problem they knew the cause. - since it was working till earlier this week, it is down to Microsoft to resolve as they have introduced the problem.

    Canon Pixma 5450 on Windows 10/64 latest version - PC not recognising connection (via USB) of a scan being passed to it from the printer/scanner. Scan occurs but no error is reported on Windows 10 nor the scanner - further checked that the scan is not "silently" paced within our Documents/Pictures folders. No other issues, printer works fine - put simply PC to printer works - printer to PC fails.
      My ComputerSystem Spec


  2. Posts : 296
    Windows 10 Pro 1709 16299.192
       08 Dec 2017 #2

    Maybe its your USB connection. I have Win 1709, 16299.98 installed an I'm using a Canon MB5120 via Lan connection and scanning works like a charm. The reason I'm suggesting the USB connection, because I tried that type of connection win I first installed Win 10 (The first version), and I could never get it to work.
      My ComputersSystem Spec

  3.    08 Dec 2017 #3

    Yr response raises 3 things in my mind:

    1. How do you scan? do you scan from the printer panel, or use the IJ utility from yr pc?
    2. I tried both LAN and USB with the same result.
    3. Canon knew of the problem within 0 seconds of explaining the issue - they are obviously aware, - they put it down to Windows Updates - it was fine till this week.

    However I'm prepared to try anything!
      My ComputerSystem Spec


  4. Posts : 296
    Windows 10 Pro 1709 16299.192
       09 Dec 2017 #4

    Yes I'm using the Canon utility on the pc. That feature has been working on my W10 system since I bought the printer 2 years ago. But I noticed in your thread that it stop working after KB4051963 came out on Nov 30th. I hadn't updated this system until yesterday morning, so I did a test, to see if it broke my scanning capability. I ran a couple of scans, both from the platen and ADF, all worked. So I came back here an noticed that you were using USB and I'm using WIFI, and suggested that maybe the problem. Maybe its a printer driver issue, since you have a different model printer than I do.

    So if you tried it wirelessly and it still failed, then it could be the printer driver for your printer type that is causing the problem.
      My ComputersSystem Spec

  5.    09 Dec 2017 #5

    The response from Canon doesn't surprise me. Its typical to blame it on someone else "not my problem" whether it is or isn't and the customer is left to try and find the problem their selves. Usually they either do not know or too lazy to research the problem. I used to manage a large LAN/WAN Network and Hardware Help Desk, that was the one thing we would never do. We may not have the answer immediately but we wouldn't tell someone "its not my problem".

    I have a Canon MB5420 all in one (Wi-Fi connected) and it is working properly with all Win 10 updates. If a Windows update caused the problem, it would have caused it for all, not just you.

    I would do two things
    (1) Refresh the Driver. Make sure the printer is connected, then go to the Device Manager. Uninstall the Printer but DO NOT uninstall the Drivers. Then restart the PC and when Windows starts it will detect and reinstall the device. This fixes any Windows corruptions with the device.

    (2) If the refresh didn't fix it, uninstall the Canon AND drivers. Disconnect the Printer then restart Windows. Do a fresh install and do not connect the unit until the install program tells you to. (If you connect the device first the install can fail or Windows may install an incorrect driver).
      My ComputersSystem Spec


 

Related Threads
We printed a document yesterday morning, the update came through in the afternoon, and today Windows no longer recognizes the printer. (Win 10 Home Edition, 64-bit) I recognize that this is an old printer, but it's what we have, and I don't see...
Hi there My HDMI capture device no longer works with CU update -- just get a blue screen and the signal input (Video IN) LED shows flashing yellow (DRM / unable to pass thru signal instead of constant and steady Blue - signal OK). I loaded...
Canon MP250 Printer No Longer Works in Drivers and Hardware
When the print spooler is turned on I get a message that says the printer queue is full. (The printer queue is empty.) If I try the printer without the printer spool on i.e. print directly to the printer, I get a message that says "Unable to...
Canon printer drivers in Drivers and Hardware
I am currently on Win10 build 10158 and none of the Canon drivers for my Pixma ip8750 two year old printer work correctly. There seems to be a break in communication between the app being used for printing and the OS handling the printer driver...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:43.
Find Us