Windows 10: USB-attached mouse no longer wakes Windows Solved


  1. Posts : 480
    Win10 x64 Pro -2 desktops, 1 laptop
       06 Dec 2017 #1

    USB-attached mouse no longer wakes Windows


    Two days ago my USB-attached mouse lost the ability to wake a sleeping Windows. Once Windows is awake the mouse works normally. I tried plugging a different mouse into a different USB port and it, too, fails to wake Windows. The Device Manager show that both mice have "Allow this device to wake the computer" selected. My keyboard can wake Windows but it's a very old PS/2-attched keyboard so that doesn't prove much. The mouse is a Logitech M500 but I'm using a "HID-compliant mouse" driver rather than the driver that comes with the Logitech Setpoint software because I didn't want or need anything Setpoint provided. The mouse has worked fine with driver for years with Win7 and Win10. I installed KB4055254 around the time the behavior changed. I don't see any obvious connection ... if the description given by Microsoft is accurate. I guess I could try uninstalling it. Any other things I can try to diagnose and/or fix this problem? This is obviously not a disastrous situation but I don't like it when even small things happen without obvious cause.
      My ComputerSystem Spec


  2. Posts : 480
    Win10 x64 Pro -2 desktops, 1 laptop
    Thread Starter
       09 Dec 2017 #2

    After a couple of reboots (unrelated to the mouse problem) my mouse has regained its ability to awaken Windows. I'm glad things are back to normal, but I hate unexplained problems like this.
      My ComputerSystem Spec

  3. Berton's Avatar
    Posts : 5,393
    Win10 Home and Pro, Win10 Insider Preview, WinXP Home Premium, Linux Mint
       09 Dec 2017 #3

    There's 2 types of USB mice, Wired and Wireless.

    If it happens again or frequently check your power settings that the USB port is not on power saving and also check the mouse or power settings for WOM/Wake on Mouse [similar to WOL/Wake on LAN].
      My ComputerSystem Spec

  4. Layback Bear's Avatar
    Posts : 994
    Windows 7/64 Professional
       10 Dec 2017 #4

    Many time a couple of re-starts will somehow fix things.
    I don't know why, it just happens.

    What I think but can not prove is some how a driver stopped working properly and a reboot started the driver up again.

    Jack
      My ComputersSystem Spec

  5. jumanji's Avatar
    Posts : 758
    Windows 7 Ultimate 32bit
       10 Dec 2017 #5

    "What I think but can not prove is some how a driver stopped working properly and a reboot started the driver up again."

    You are aboslutely correct. Often times my USB mouse fails when I boot my PC. I just reboot my PC and everything works fine. The only reason could be that the driver was somehow skipped by Windows during the boot..
      My ComputerSystem Spec


  6. Posts : 480
    Win10 x64 Pro -2 desktops, 1 laptop
    Thread Starter
       10 Dec 2017 #6

    In this case, though, only the "wake" function was broken/missing. Once the PC was wake the mouse worked fine. (I assume the drivers don't get reloaded when Windows wakes.) "... a driver stopped working correctly ... " could describe the situation; a driver not being loaded does not..
      My ComputerSystem Spec

  7. Layback Bear's Avatar
    Posts : 994
    Windows 7/64 Professional
       11 Dec 2017 #7

    Whether the drives is loaded incorrectly or is not loaded at all is unknown.
    I do believe it is a driver problem either way.

    Jack
      My ComputersSystem Spec


 

Related Threads
I recently enabled the sleep feature in the bios but now it wakes in the evening but not in the morning.
So this mouse uses its own USB dongle. When it is plugged, both Mouse compatible with HID technology and Combined USB device appear in the Device manager. I've set Allow waking computer to False for Mouse to prevent it from waking my laptop, but it...
Hi all. I've been struggling for weeks in finding a solution to this very annoying behavior of my new desktop pc running W10 Pro x64. I have successfully activated hibernate mode (S4), yet whenever the PC is hibernated a shake of the mouse or...
I can no longer see my Network Attached Storage in this build(10049) Enterprise. I have Network Discovery enabled and can get to the device by IP Address in a browser but am unable to map a drive to any share. Anyone else having these issues. I have...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:52.
Find Us