Windows 10: WU installed the wrong soundblaster driver - card no longer works Solved


  1. Posts : 30
    Windows 10 Pro x64
       23 Nov 2017 #1

    WU installed the wrong soundblaster driver - card no longer works


    I have a Soundblaster Z series card for use with Cubase. Today there was no sound. I looked in device manager and it was listed as a different card - Recon3D. Updates confirmed the wrong driver had been installed today.

    I've uninstalled + reinstalled the card about 10 times today using the SB installer, manually in device manager, using Revo etc (all with restarts) and nothing will make the card operate. I've tried different PCI-e. The card either reverts to thinking its the Recon3D or shows as SB-Z but doesn't work - I get the message 'the current selected audio device is disabled, not present, not supported by the application or has unplugged jack connections'. I also tried a system restore but still zilch.

    While I was doing the above, I disabled auto driver updates in gpedit - to no avail.

    The Creative forum says this is a common problem. Creative say it's a WU issue. Either way I can't play my keyboard.

    A Windows 10 reinstall would be a major hassle. Any ideas ?
      My ComputerSystem Spec

  2.    23 Nov 2017 #2

    badcrc said: View Post
    I have a Soundblaster Z series card for use with Cubase. Today there was no sound. I looked in device manager and it was listed as a different card - Recon3D. Updates confirmed the wrong driver had been installed today.

    I've uninstalled + reinstalled the card about 10 times today using the SB installer, manually in device manager, using Revo etc (all with restarts) and nothing will make the card operate. I've tried different PCI-e. The card either reverts to thinking its the Recon3D or shows as SB-Z but doesn't work - I get the message 'the current selected audio device is disabled, not present, not supported by the application or has unplugged jack connections'. I also tried a system restore but still zilch.

    While I was doing the above, I disabled auto driver updates in gpedit - to no avail.

    The Creative forum says this is a common problem. Creative say it's a WU issue. Either way I can't play my keyboard.

    A Windows 10 reinstall would be a major hassle. Any ideas ?
    I would go to settings an choose go back to previous version of Windows and see if that fixes it, but you only have 10 days to do that I think. I had a few problems with the latest WU 1709 I believe and reverted back to 1703.
      My ComputerSystem Spec


  3. Posts : 30
    Windows 10 Pro x64
    Thread Starter
       24 Nov 2017 #3

    I decided to install the Soundblaster card (and Cubase etc) in a different pc, and everything works fine - showing that the card wasn't faulty, it was a Windows driver update problem. It seems that once the wrong driver has given the SB card a different ID, it sticks and even uninstalling the wrong driver doesn't fix it. According to the Creative forum, this SB + WU problem has been around for a few years, but Microsoft haven't addressed the issue.

    Weekly Macrium backups from now on.
      My ComputerSystem Spec

  4.    24 Nov 2017 #4

    badcrc said: View Post
    I decided to install the Soundblaster card (and Cubase etc) in a different pc, and everything works fine - showing that the card wasn't faulty, it was a Windows driver update problem. It seems that once the wrong driver has given the SB card a different ID, it sticks and even uninstalling the wrong driver doesn't fix it. According to the Creative forum, this SB + WU problem has been around for a few years, but Microsoft haven't addressed the issue.
    \



    Weekly Macrium backups from now on.
    Yep....this started back in windows 8/8.1. I experienced this with AMD driver for my XFX AMD 6970D. It would install the windows generic 1.0 driver and would kill my sound.
      My ComputerSystem Spec


 

Related Threads
As the title suggests, I allowed the creators update to install itself yesterday and now the computer will get stuck whilst booting. I took the graphics card out and used the onboard graphics and it then booted fine. Uninstalled the graphics drivers...
'Wrong' Nic Card driver in Network and Sharing
Hi Guys I'm not sure what to do about this, whether to leave it as is and use the driver Windows thinks I should use or some how use the driver for the nic card I actually bought. The manufacturer appears not to have a Windows 10 driver and...
Since changing to Windows 10 I can no longer access Sky sports despite having legal access. It sometimes suggests I need to load java but the offering is through java setup which seems to be a virus? Any ideas - PS sorry about underlining not...
Open network no longer works in Network and Sharing
Prior to W10 I had a network NOT using Homegroup. Network worked who needs it? Now, I see some of my devices on the network, but when I try to share files I get a window requesting user name and password. Never used passwords before. I think...
Windows 10 no longer works... in Performance & Maintenance
I'm really upset about the new windows 10 upgrade. I had windows 7 and worked fine till I updated. Now my sound keeps going out, my wifi doesn't turn on, everything lags, nothing works, it's slower than ever before. This happened one month after...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 07:39.
Find Us