Windows 10: How to remove harddisk password in Lenovo G50-70 laptop?

  1.    21 Nov 2017 #1

    How to remove harddisk password in Lenovo G50-70 laptop?


    I had set the password on my internal harddisk few months back. Now I want to remove it but could not do so. When I enter the bios, the following parameters are seen under Security, Password:-
    1 Administrator Password - Set
    2 User Passord - Set
    3 HDD Password - Set

    Set User Passord
    Set Hard Disk Password
    Change Master Password
    Change User Password

    I know my password and it accepts it. I can only select two parameters: 1 Set User Password and 2 Change User Password.
    All other parameters are not selectable.
    When I boot my laptop it asks for HDD password. I have the password and it takes the password . I can use my laptop but when I want to remove it from Bios- Security - Password - it does not get removed.
    Please help me remove the hard disk password.
    Ashok Kumar Bagaria
      My ComputerSystem Spec

  2.    21 Nov 2017 #2

    Try this - it worked for me on Lenovo X201.

    1. Remove the drive from the laptop
    2. Power up the laptop and go into the bios
    3. If there are any other bios related passwords set, remove them.
    4. Now, you should be able to toggle the "Use Passphrase" setting. If it is enabled then disable it, and if it is disabled, then enable it.
    5. Save changes and exit.
    6. Power down, re-insert the drive, and go back into the bios. You should now be able to make whatever changes you want to the HD password setting.
    Solved: Can't remove HDD password - Lenovo Community
      My ComputerSystem Spec

  3.    21 Nov 2017 #3

    lx07 said: View Post
    Try this - it worked for me on Lenovo X201.

    Solved: Can't remove HDD password - Lenovo Community
    Thanks for prompt response Mr lx07. I will try this tomorrow. By the way, could you please explain what is passphrase setting? Is it in Bios - Security - Password? I will wait for your answer and then proceed to solve this problem as per your suggestion.
    Thanks in advance
    Ashok
      My ComputerSystem Spec

  4.    21 Nov 2017 #4

    The passphrase setting is in the BIOS and defines whether the password is encrypted before being passed to the disk controller (to stop dictionary attacks).

    I'm not 100% sure the G50 has it but X201 and most other Thinkpads do. It is certainly worth a look anyway.
      My ComputerSystem Spec

  5.    22 Nov 2017 #5

    Dear Mr lx07,
    I had tried as per your suggestion today- taken out hard disk and logged into into bios. Since hdd was removed - the system did not ask for hdd password this time, instead it asked for system password. In my case system pw and hdd pw both are same. I remember all the passwords and after typing down the pw - I logged into the bios and there I could only navigate to " Set User Password" which I did.
    My user password, master password, hdd password & administrative pw all are same.
    The problem is I can only navigate to the following two options after hdd refit:
    1 Set User Password
    2 Change User Password

    All other options in Bios cannot be navigated. The print screen shows that the administrative password and user password is not set. And Master password has Change option but I cannot navigate to the same. When I remove hdd - I get only 3 options - viz 1 administrative 2 User Password and 3 set user password. Out of these 3 I can only access " set user Password"
    I do hope you could help me further on this matter. 2 print screens are attached herewith.
    Please help.
    Ashok Kumar Bagaria
    Attached Thumbnails Attached Thumbnails hdd refitted.jpg   hdd removed.jpg  
      My ComputerSystem Spec

  6.    22 Nov 2017 #6

    My assumption is if I could enter into bios with either Master Password or Administrative Password - I could navigate to other options as well and change password to " None" but I do not know how to enter Bios with Administrative Password. With Novo key pressed once, I get the next screen and on that screen I choose- my option as "Bios" and enter. On the second screen I am asked to type hdd password and after entering hdd password , I am on the 3rd screen asking me to enter system password- which I do and the next screen is BIOS. Therefore it nowhere ask me to enter administrative password.
    If you could help me here.
      My ComputerSystem Spec

  7.    22 Nov 2017 #7

    You could flash your BIOS - that should remove the BIOS passwords. It definitely will not remove the disk password as that is stored in the firmware on the HDD.

    Note I didn't try that. I simply removed the disk and then I could change Passphrase setting. If you have other passwords set then (when the disk is removed) you should remove them too.

    Sorry I can't help more - I do have a Thinkpad but a different model. According to the link above all are affected (except T60) but perhaps someone with a G50 will help.
      My ComputerSystem Spec


 

Related Threads
In June a friend bought a Lenovo Z50-70 laptop running Win 8.1. He particularly dislikes touchpads so uses a mouse. In 8.1 I was able to disable the touchpad for him, via Device Manager. He's now updated to Win 10 and the touchpad has come back...
I am not sure what happened to my settings, but if anyone can help, would be greatly appreciated! I am running a Lenovo Win 10 notebook on a home system, at least theoretically networked into two Win 10 PC's and one Win 7 PC. Now, all of a...
I was working on a Lenovo laptop this weekend. Could not get into the UEFI Bios using a function key. I could get to the Boot Menu using the Fn + F12 keys however. I had a lot to do, so I had no time to spend screwing with it. I just used the...
Not getting updates on my Lenovo Laptop G50-70 in Windows Updates and Activation
I have not got any updates since 6th Nov on my Laptop having Windows 10 home 10240 single language upgraded from Windows 8.1 over the air. Most of the updates on 06.11.2015 failed to install. Also no notification for new version 1511 10586 as yet....
Every time I try it I get a failure: C1900101-20017 There are no official Windows 8.1 or 10 drivers for this laptop and no BIOS update. Just wondering if anyone else has had success with this laptop. Currently running Windows 7 Home X64...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:34.
Find Us