Page 1 of 2 12 LastLast

  1. Joined : Jul 2015
    Posts : 5
    windows 10
       30 Jul 2015 #1

    Windows 10 mouse pointer lag/general lag


    I have a pretty powerful computer, running an i7, nvidia 980 gtx, 16GB ddr3 ram, all on a 1TB SSD.

    Just upgraded from 8.1 which was extremely smooth and 10 feels LAGGY.
    The mouse pointer seems to lag and even explorer windows seem to stutter as I drag them around the desktop.

    I tried out the technical preview and it was doing this so I went back to 8.1 and I thought it was just a beta issue.
    After installing today its better than it was during the preview but still not nearly as smooth as 8.1
    There was a new nvidia driver that released along side windows 10 so IDK if that is what helped.

    Either way, IDK what to do guys....help please!

    EDIT: It almost feels like my monitor isn't refreshing as fast and thats the lag I'm feeling? But it didn't exist on windows 8 so I know its a software problem. Using a 28" samsung 4k monitor but running at 2560 x 1440 just like i was on 8.1
      My System SpecsSystem Spec


  2. Joined : Apr 2015
    California
    Posts : 362
    Windows 10 Pro x64
       30 Jul 2015 #2

    Run the Task Manager (right click on the Task Bar or start from the Start Menu) and see what's running, taking cpu, ram, or using the hard disk. Maybe this will give a hint what might be going on. Click on "More details" for a detailed view.
      My System SpecsSystem Spec


  3. Joined : Jul 2015
    Posts : 5
    windows 10
       30 Jul 2015 #3

    Click image for larger version. 

Name:	Untitled.png 
Views:	60 
Size:	67.1 KB 
ID:	26719cpu usage just maxed out at like 5%....im stuck here :/
      My System SpecsSystem Spec


  4. Joined : Apr 2015
    California
    Posts : 362
    Windows 10 Pro x64
       30 Jul 2015 #4

    I would be looking at the Nvidia site to see if they offer Windows 10 drivers. Might be the video driver. Check the Device Manager and make sure Windows 10 hasn't automatically loaded the wrong driver for your video card.
      My System SpecsSystem Spec


  5. Joined : Jul 2015
    Posts : 5
    windows 10
       30 Jul 2015 #5

    uninstalling the nvidia driver and just running without any graphics driver at 1024 x 600 gets rid of the lag so its a problem with the nvidia drivers. idk how to fix tho -_-

    edit: posted at the same time as you. the driver i have installed is apparently for windows 10 but still having the problem. downloaded straight from nvidias site.

    Click image for larger version. 

Name:	Screen Shot 2015-07-30 at 1.37.47 AM.png 
Views:	63 
Size:	246.6 KB 
ID:	26720
      My System SpecsSystem Spec


  6. Joined : Apr 2015
    California
    Posts : 362
    Windows 10 Pro x64
       30 Jul 2015 #6

    prgmitchell said: View Post
    uninstalling the nvidia driver and just running without any graphics driver at 1024 x 600 gets rid of the lag so its a problem with the nvidia drivers. idk how to fix tho -_-

    edit: posted at the same time as you. the driver i have installed is apparently for windows 10 but still having the problem.
    Probably have to wait until new drivers are released, or get a Windows 10 compatable video card in the long run if they don't release any new drivers.
      My System SpecsSystem Spec


  7. Joined : Jul 2015
    Posts : 5
    windows 10
       30 Jul 2015 #7

    Thats dumb -_- and lol my card better be "compatible" it's one of their most expensive cards.
      My System SpecsSystem Spec


  8. Joined : Apr 2015
    California
    Posts : 362
    Windows 10 Pro x64
       30 Jul 2015 #8

    Over in the Drivers and Hardware section of this site is a discussion thread about Nvidia Windows 10 drivers. Other people are also having problems.
      My System SpecsSystem Spec


  9. Joined : Oct 2014
    Posts : 177
    Windows 10 Pro 64-bit
       30 Jul 2015 #9

    delete duplicated message
      My System SpecsSystem Spec


  10. Joined : Oct 2014
    Posts : 177
    Windows 10 Pro 64-bit
       30 Jul 2015 #10

    and games and such run fine? did you check with GPU-Z
    I have a low end Nvidia GT610 using that same driver from Nvidia and Windows desktop is smooth as butter...
      My System SpecsSystem Spec


 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Blue circle by pointer all the time - W10 Pro X64 in Oracle VM
This just started yesterday. Did not have it previously. Now when I boot the blue circle is always by the mouse pointer. Nothing I do gets rid of it. Have not tried a Clean Boot yet, will do so soon. Just wondering if anyone else has had this and...
General Support
Microsoft will pre-load Windows 10 ahead of general release on your..
Source
Windows 10 News
Mobile Using a mouse with Windows 10 mobile
Read more: http://www.neowin.net/news/using-a-mouse-with-windows-10-mobile
Windows 10 News
Black screen with mouse pointer
I wanted to give some feedback for the 10061 build and when I did, Windows kindly offered to create a Microsoft Account for me as I didn't have one on my Dell 15R laptop. That worked fine and i was able to submit the feedback, but when I Signed out...
General Support
Solved USB Mouse bonkers in 9879 in VM. PS/2 Mouse OK !!!!
Hi there "Back to the future". Bog standard Ms USB mouse doesn't work properly in W10 build 9879 VM after latest Windows updates applied (Ok on earlier releases). VMware tools etc all installed -- no difference. The Toolbar only works when the...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:41.
Find Us
Twitter Facebook Google+



Windows 10 Forums