Windows 10: Epson CX7400 scanner will not start

Page 1 of 2 12 LastLast
  1.    14 Nov 2017 #1

    Epson CX7400 scanner will not start


    I have an HP 15 Notebook PC with a Epson CX7400 All in One Printer, Scanner. When I click the icon, I get an error message saying that the scanner can not open and directs me to run a trouble shooter. I open it and it asks questions like make sure the usb is connected and it is.
    I deleted the old driver and reinstalled the driver. When I clicked the icon I get the same error message but I do not have another shortcut on my desktop. I do not know where to go next.
    Please advise.
      My ComputerSystem Spec

  2.    14 Nov 2017 #2

    Note: The drivers appear to be claiming compatibility with Win 10, despite the quoted date being 2013.

    Epson Stylus CX7400 | Epson Stylus Series | All-In-Ones | Printers | Support | Epson US
    Click image for larger version. 

Name:	1.jpg 
Views:	10 
Size:	29.0 KB 
ID:	163839

    Is that the driver version you are using?

    What happens if you uninstall the driver, then connect your printer?

    See
    [Solved] Epson Scanner Not Working on Windows 10 - Driver Easy
    for more ideas..

    History: with which version of Windows was it last working? When did it stop working? Was there an update or upgrade around the time it stopped working?
      My ComputerSystem Spec

  3.    14 Nov 2017 #3

    That is the correct printer driver, although I do not know if that is the particular driver that I downloaded. I uninstalled the printer then connected it and it downloaded automatically. It may work, but I have no idea how to start the scanner because I do not have a shortcut.
      My ComputerSystem Spec

  4.    14 Nov 2017 #4

    Om File Explorer, Browse to C:\Program Files or C:\Program Files (x86) there should be an Epson folder there. There should be a Epson Scan icon in that folder. Right click it and Send To... Desktop. Now double click it to start a scan.
    If there is no Epson Folder, or Epson Scan icon, then you did not install all of the Epson Drivers and Utilities form the Disc or the Download. Epson Stylus CX7400 Driver Download - Windows, Mac, Linux - Support - Epson
      My ComputerSystem Spec

  5.    14 Nov 2017 #5

    Well I think there is a problem with the installation. I do not know what the problem is. I have uninstalled the driver on multiple occasions but the scanner just will not work.
      My ComputerSystem Spec

  6.    14 Nov 2017 #6

    What happens? Did you find the Epson folder? Did you find the Epson Scan Icon? What happens when you click it?
    Unplug the USB cable from the computer, Go to Start/Search and type appwiz.cpl and press enter. In Program and Features, Uninstall all Epson software, restart the computer. When you are back up, download the latest version of the Epson software from the link in post #4, be sure to download the Utilities as well as just the driver. During the install, it will tell you when to plug in the USB cable.
      My ComputerSystem Spec

  7.    14 Nov 2017 #7

    I did as you instructed. When I went to uninstall, there was a red arrow on the Epson Scan in the list of programs. I uninstalled everything then installed from the link that you provided. I plugged it in and nothing. I went to programs and features and the Epson file had a red arrow and there was nothing listed as Epson scan. And by the way, thanks for your help.
      My ComputerSystem Spec

  8.    14 Nov 2017 #8

    I installed again and once again it does not work and in programs, the Epson Scan was visible but it had a red arrow on it. For some reason it will not download.
      My ComputerSystem Spec

  9.    14 Nov 2017 #9

    I uninstalled and installed the latest version then an older version, but on every occasion, when I look in programs, it shows a red arrow on the program and the program will not open. It looks as if the program will not totally install. Any ideas on what could be holding it up?
      My ComputerSystem Spec


  10. Posts : 8,967
    Windows 10 Pro x64 Build 1803
       14 Nov 2017 #10

    Could you use the snipping tool and post a screen shot please.

    In the Epson Software folder do you have something called Event Manager? If so double click.

    By the way how is the scanner connected?

    Next when you uninstalled everything did you disconnect All in One.

    Then with unit disconnected start the install and let it run. It will either tell you to connect device or it can't find device. At that point connect device (powered on).
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
I've been experimenting with Windows 10 using a VM (VirtualBox) before upgrading. One challenge has been to see if I could get my old 1999 Epson Perfection 1200 scanner working in Windows 10 since Epson do not provide any 64 bit drivers. I...
I have an Epson Perfection 1250 scanner which is about 15 years old, but still useful - or it would be if I could get it running in Win 10. I still have the original CD with the driver software. When I moved from XP to Win 7, all I needed to get...
Epson Perfection Scanner 2480 driver in Drivers and Hardware
Hope this may be of help to someone.:) The following file/driver enabled me to run a 2480 scanner in windows 10 64bit Epson Perfection 24803.0u It is Version 3.0u Make sure you remove all previous drivers for the scanner, then...
Solved Epson Perfection 1640SU scanner in Drivers and Hardware
Hi, has anyone been able to get the Epson Perfection 1640SU scanner to work with Windows 10 64bit
Does anyone know of any software/drivers that will work with an Epson Perfection 1670 scanner using Windows 10 ? There is none on the Epson website listed for Windows 10. Jack
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 11:44.
Find Us