Page 1 of 2 12 LastLast
  1.    5 Days Ago #1
    Join Date : Apr 2016
    So Cal
    Posts : 25
    Windows 10 Professional X64

    External hdd recognized in comp mgmt but wants to format


    My external hdd can be opened in pc, but in laptop it wants to Format.
    It asks to give it another drive letter, which I do, but still says " do you want to format?"
    How can I get this drive to open?
    I also tried Disc Clean. Same message.
    Thanks,
    Paul
    Attached Thumbnails Attached Thumbnails DISC MGMT D 11,13,17.png  
      My ComputerSystem Spec
  2.    5 Days Ago #2
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,451
    windows 10

    Its showing as raw which means its lost the parition table you need to download free parition recovery software to get it back
      My ComputerSystem Spec
  3.    5 Days Ago #3
    Join Date : Apr 2016
    So Cal
    Posts : 25
    Windows 10 Professional X64
    Thread Starter

    It was able to read it yesterday when I downloaded a backup to it.
    Also opens on my PC, so how can it be Raw?
      My ComputerSystem Spec
  4.    5 Days Ago #4
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,451
    windows 10

    Its reporting it as raw in your screen shot try it back on another pc
      My ComputerSystem Spec
  5.    5 Days Ago #5
    Join Date : Mar 2016
    India
    Posts : 196
    Windows 7 Ultimate 32bit

    Hi PSCO2007W10

    Your external disk has a drive letter. So it is not a partition loss problem.

    Run check disk from command prompt.

    Open Command prompt. Start > All programs > Accessories > Command Prompt

    Type
    CHKDSK D: /f /v /r /x Press enter. Note: Replace D: with the actual drive letter of the external drive. Please note there is a space between every switch/option.

    Allow check disk to complete. ( Do not abort checkdisk for any reason midway. That would leave your disk in a much worse condition. If it aborts by itself its OK. In that case we shall do a thorough check with TestDisk)
    Last edited by jumanji; 5 Days Ago at 22:32.
      My ComputerSystem Spec
  6.    5 Days Ago #6
    Join Date : Apr 2016
    So Cal
    Posts : 25
    Windows 10 Professional X64
    Thread Starter

    Thanks,
    I'll do it tomorrow and let you know if it is successful.
      My ComputerSystem Spec
  7.    5 Days Ago #7
    Join Date : Apr 2016
    So Cal
    Posts : 25
    Windows 10 Professional X64
    Thread Starter

    Tried your suggestion.
    Got this message in screenshot.
    Attached Thumbnails Attached Thumbnails cmd error 11,14,17.png  
      My ComputerSystem Spec
  8.    4 Days Ago #8
    Join Date : Apr 2016
    So Cal
    Posts : 25
    Windows 10 Professional X64
    Thread Starter

    Hi Jumanji,
    I'm running Testdisk now.
    Should take about an hour.
    I'll let you know results.
    I got an original message that said it was Fat32 which is really strange, since this hdd came with this laptop (I pulled it out and used as an external after inserting an SSD)
    It was NTFS at that time.
    Paul
      My ComputerSystem Spec
  9.    4 Days Ago #9
    Join Date : Apr 2016
    So Cal
    Posts : 25
    Windows 10 Professional X64
    Thread Starter

    It just finished and said "structure ok) but also said "partition can't be recovered" but then started a new test.
    I don't know why, but you said not to abort so I'm letting it run.
    It looks like I may have to Format, unless you have any other ideas.
    Thanks, so far.
    Paul
      My ComputerSystem Spec
  10.    4 Days Ago #10
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,451
    windows 10
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
External HHD not recognized by Windows
Hi, I've got WD MyPassport Ultra 1TB, and after reinstalling Windows, I have problem with it working on USB 3.0, it works fine on USB 2.0. Here I have to mention, that I installed drivers through DriverPack Solution Online. I've read a lot of...
Drivers and Hardware
External USB drive not recognized for Disk Image
Greeting with a smile. I'm trying to save a first time disk image on an external USB drive. And I had it working at the start. The first time, it started fine, and was running fine. But it took longer than I thought it would, and I had to shut...
Drivers and Hardware
Hitachi HDS72101 external drive not recognized
I've got two Hitachi HDS72101 1TB external drives that my new Dell XPS 8900 running Windows 10 won't recognize. The device manager shows the drives to be working properly and having current drivers. My computer recognizes my new Seagate 5TB drive...
Drivers and Hardware
Cannot Format my External Hard drive
When I plug my external into my pc it tells me it's unable to use and to format the drive. So I try to do so, and Windows tells me that there's a program using the external drive. I attempt to format anyway since I know there's no programs...
Drivers and Hardware
Solved Can't format external USB drive.
I am trying to format 2 partitions on an external 1TB USB3 drive. I had 2 ExFat partitions (partitions 6 and 7) which I have deleted and created 2 new ones using diskpart which I want to format NTFS. When I try to format them using disk...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:37.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums