1.    1 Week Ago #1
    Join Date : Jul 2015
    Posts : 9
    Windows 10 Pro X64

    Sound Blaster Z - No Sound


    Hi guys! Some days ago I made a fresh install of Windows 1709 and things appears to be working.

    Today I`m having some sound problem with my SBZ and I tried to reinstall driver but since then, I have no sound.

    Thanks for any help
      My ComputerSystem Spec
  2.    1 Week Ago #2
    Join Date : Jan 2014
    Inverness
    Posts : 1,190
    Win 10

    Check the sound playback panel. If the SoundBlaster is not set as default, that could be the problem. If its not set as default make it the default audio playback device.

    As you have the add on SoundBlaster card, if you have motherboard in built sound disable that in the BIOS so it does not conflict and cause problems.
      My ComputersSystem Spec
  3.    1 Week Ago #3
    Join Date : Jul 2015
    Posts : 9
    Windows 10 Pro X64
    Thread Starter

    Thanks for the answer fireberd!

    I tried this without sucess:
    -check playback device
    -check volume
    -check onboard soundcard disable
    -reinstall Sound Blaster Z driver

    The stranger thing is working, so I started having some problems and after reinstall stopped working...
      My ComputerSystem Spec
  4.    1 Week Ago #4
    Join Date : Oct 2014
    Trnava
    Posts : 2,871
    Windows 10.4 Home 1709 x64

    Quote Originally Posted by fulvioval View Post
    -reinstall Sound Blaster Z driver
    Windows Update installs the wrong driver sometimes, which breaks the sound. At first uninstall and remove the driver for both devices via device manager, otherwise you can not install older one over it. Then restart and install again.
    Attached Thumbnails Attached Thumbnails capture_11132017_095646.jpg  
      My ComputerSystem Spec
  5.    1 Week Ago #5
    Join Date : Jul 2015
    Posts : 9
    Windows 10 Pro X64
    Thread Starter

    Quote Originally Posted by TairikuOkami View Post
    Windows Update installs the wrong driver sometimes, which breaks the sound. At first uninstall and remove the driver for both devices via device manager, otherwise you can not install older one over it. Then restart and install again.
    Thanks! I'll try this. I'm using Windows 10 Pro, maybe if I use police editor to block driver updates I can avoid this to happen again but I really don't know if that Police Rule really works to block driver updates from Windows Update.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved Lost sound after latest Windows 10 update (Sound Blaster Z)
Hello there, As in the title: I have lost sound after latest Windows 10 update, which happened yesterday (23rd June 2017) - I am using Creative Sound Blaster Z sound card. I have tried reinstalling the drivers, then reinstalling the device, then...
Drivers and Hardware
Solved No sound from sound blaster
I just installed the most recent windows 10 tech preview last night; but my sound blaster pci express sound card did not get installed correctly or something because i am getting no sound at all. Please help me fix this before I roll everything back...
Drivers and Hardware
Sound Blaster X-Fi Surround 5.1 Pro - default Win sound indicator?
Hi, I just bought this sound card and installed drivers for Windows 10. (and a crapton of bloatware with UI of Win XP media player...) Everything works well except one thing: when I change the sound (or mute) I don't see Windows 10 volume bar. I...
Drivers and Hardware
Sound Issue in Windows 10 with Sound Blaster X-Fi Titanium
Hello -- After I upgraded to Windows 10 from 7 Pro, there was no sound. Obviously, Creative Labs has yet to release compatible drivers for many of their sound cards. Nevertheless, I found out that I'd make it work by changing its modes back and...
Drivers and Hardware
Solved sound blaster in build 10166
I can not get my sound blaster x-fi titanium pci express sound card to give me sound through the right channels even though Ive uninstalled the support pack for 5.1 surround audio that was compiled from another sb user that did work in the last...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:44.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums