I have an Asus Strix 7.1 headset, its a little less then a year old. Recently I've been having an issue with it where I can't get it to power it up. Device manager shows me the following:

Click image for larger version. 

Name:	dm.png 
Views:	7 
Size:	12.1 KB 
ID:	163517

It uses 2 USB connectors, both are connecting to USB 3.0 ports. It will work at times but it seems if my computer is off for a length of time, like overnight, it won't work.

I've tried the following:

I've made sure that all software and drivers have been installed and are up to date
Uninstalled/reinstalled the driver with the error on it
Updating the drivers for the USB root hubs and the generic root hubs
I tried different USB ports, both 3.0 and 2.0
I changed the power options to disable the automatic powering down of USB ports on the hub drivers and the power options in control panel
I tried disabling driver signature enforcement
I've done and clean install of Windows 10, and reinstalled everything fresh, including drivers and updates

Any idea what I might try next? I'm at a loss here.