Windows 10: Only 4GB RAM usable out of 16? -- using Windows 10 64 bit

Page 1 of 2 12 LastLast

  1. Posts : 3
    Windows 10 Pro 64 bit
       06 Nov 2017 #1

    Only 4GB RAM usable out of 16? -- using Windows 10 64 bit

    So I bought this computer used and just noticed that there is only 4GB of RAM available while the other 12GB is "hardware reserved". I've searched around and tried a few things but nothing is working so far. Here's what I've come up with so far:

    • I've updated the BIOS for motherboard, which is an MSI 970 gaming motherboard.
    • Despite what others have suggested, it is not possible to remap the memory for this BIOS.
    • I've tried changing BIOS settings, as well as changing the "maximum memory" setting through msconfig -> boot -> advanced options.

    Click image for larger version. 

Name:	task manager.png 
Views:	3 
Size:	27.9 KB 
ID:	162478

    Here are my specs via Speccy:

    My .txt file from running CPU-Z (MSI Version) should be attached.

    Any help will be greatly appreciated! Thanks.
    Only 4GB RAM usable out of 16? -- using Windows 10 64 bit Attached Files
      My ComputerSystem Spec

  2.    06 Nov 2017 #2

    If your BIOS includes setting "Framebuffer Location" or similar (memory for in-processor video), try to change it first.

    Run msconfig, Boot options - Advanced, Max Memory must be unchecked.

    Try to change memory config (remove all DIMMs but one), enter Setup, save, boot Windows. Then make the same steps with two DIMMs. If all is OK, repeat all steps with four DIMMs inserted.
      My ComputerSystem Spec

  3. Posts : 3
    Windows 10 Pro 64 bit
    Thread Starter
       06 Nov 2017 #3

    I was not able to find any setting for "Framebuffer Location" within the BIOS settings, or after searching Google and the motherboard manual.

    I unchecked the Max Memory setting in msconfig, Boot options - Advanced.

    As per your third recommendation; I just turned off my PC, removed all DIMMS but one and turned it back on, but neither my monitors, keyboard, nor mouse would work. I powered off, added another DIMM, and the same problem occurred. I had to repeat this until all 4 were back in for my monitors, keyboard, and mouse to start working.

    Any feedback at this point would be appreciated. In particular, if you could clarify what do you meant by the "enter Setup, save" parts of your third recommendation, that may be useful since I did not understand what you meant, and thus didn't follow those steps. Thanks.
      My ComputerSystem Spec

  4.    06 Nov 2017 #4

    Are these sticks identical?
      My ComputersSystem Spec

  5. Posts : 3
    Windows 10 Pro 64 bit
    Thread Starter
       06 Nov 2017 #5

    Yeah, all four sticks are identical.

    Here they are: GeIL Enhance CORSA 16GB Desktop Memory Model GEC316GB1600C9QC -
      My ComputerSystem Spec

  6.    06 Nov 2017 #6

    Framebuffer Location:
    BIOS is not fully described in manual; however, this setting can be located under menus
    Press <Enter> to enter the sub-menu. This sub-menu displays all the settings and
    timings of installed memory.
    CPU Features
    Press <Enter> to enter the sub-menu.
    Or it may be missing completely.

    Did you left modules in banks 1 or 1+3 only? Then system should boot.

    Setup, save:
    After memory adding/removing, it may be necessary to go into Setup and save new configuration.

    Entering BIOS Setup
    Power on the computer and the system will start the Power On Self Test (POST)
    process. When the message below appears on the screen, press <DEL> key to enter BIOS:
    Press <Del> to run BIOS setup, or <F11> to run boot menu

    You can also try the Restore Defaults option in BIOS.
      My ComputerSystem Spec

  7. Posts : 262
    Windows 10 x64 Home 1703
       06 Nov 2017 #7

    Hey guys... I just noticed he's saying he has more than one stick of memory... yet, his Speeccy sheet says he's on single channel mode... isn't he supposed to be running on dual channel mode given his RAM configuration? Can that be somewhat the cause of that monstrous hardware reserved amount?

    Just wondering...
      My ComputerSystem Spec

  8.    06 Nov 2017 #8

    Yeah, it should be running in dual channel mode and I think there's something wrong with the motherboard itself.
      My ComputersSystem Spec

  9. Posts : 2,400
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)
       07 Nov 2017 #9

    This is weird. What does CPUID or HWInfo report?

    It might be worth removing the memory cards, carefully cleaning the contacts with alcohol then reinserting the memory cards ensuring the clips click into place.
      My ComputersSystem Spec

  10. Posts : 3,105
    10.4 Home 1709 x64
       07 Nov 2017 #10

    Have you tried to run this as admin via CMD:

    bcdedit /deletevalue {current} truncatememory
    bcdedit /deletevalue {default} truncatememory
      My ComputerSystem Spec

Page 1 of 2 12 LastLast

Related Threads
Hello everyone, I am at a loss here with my new desktop as to why Windows 10 Pro (64 bit) is currently only allowing me to use half of my RAM. Due to a fried CPU I rebuilt this computer with some good parts: CPU: Ryzen 7 1700 Motherboard: ASUS...
8GB (3.9GB Usable), Windows 10 x64 Bit in Performance & Maintenance
Hello, i tried to fix that problem with - Switch RAM from the port - Msconfig Checked Maximum Memory - No Paging file - Clear CMOS - Update Bios - Clean the yellow ram with rubber and still not work until now, here's some screenshots about...
so when i built my win 10 box it was registering roughly 18-19 gb of ram for usable and now its only at 9.95... any ideas? Oh, and ive already done the unchecking of the ram boxes in startup 117633
Hi, Did a clean install of Windows 10 in 64 Bit and now on my properties it only says 4GB of Ram are usable instead of the full 8GB. (Pic Attached) I had never seen this before and I did have Win10 installed after upgrading from 8. Decided to...
I just noticed this. I never had this problem under Windows 8.x. Checked my BIOS and everything looked good. IGPU is turned off. Setting the memory in msconfig Boot|Advanced doesn't work. I've run out of ideas. Looking for a fix. 30002
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:10.
Find Us