Windows 10: USB Pendrive problem

  1.    19 Oct 2017 #1

    USB Pendrive problem

    Good morning to all.
    Since the latest windows 10 update, When I insert a usb pen drive into usb port on my laptop it don't show up I have to go into the File explorer to open the drive,And this is the same with a usb hdd.
    Been looking in the auto runs section but failed to solve the problem.
    Any Help on this Please, I know its not a major issue but annoying.
    Many thanks David.
      My ComputerSystem Spec

  2. Posts : 3,181
    64bit Win 10 Pro ver 1709 Build 16299.251 and W10 Insider Build 17115 and 17604
       19 Oct 2017 #2

    Hi Dafydd,

    Go into settings and make sure your AutoPlay is configured to open the folders for removable drives:

    Click image for larger version. 

Name:	2017-10-19.png 
Views:	0 
Size:	23.5 KB 
ID:	158936
      My ComputersSystem Spec

  3.    19 Oct 2017 #3

    Thanks for the reply
    But it don't work
      My ComputerSystem Spec


Related Threads
When I insert my pendrive in Laptop or Desktop PC, it shows on in My Computer but when I try to open it, it says " Please insert disk into USB Drive". When I right click on the drive and want to format, it says there is no disk in the drive. When I...
Macrium Reflect bootable pendrive in Backup and Restore
Is it makes any difference if we restore a 64 bit macrium image with a 32 bit MR bootable Pendrive or restore a 32 bit macrium image with 64 bit MR bootable pendrive?
Password problem or Windows Live Account problem in User Accounts and Family Safety
Cannot remember password, OR typed it in wrong on both entries. When I use the tool for recovering/resetting the password. The system takes me to a reset function, where I am able to put in a new password twice, but the screen that follows does not...
I have one Sandisk USB 2 OTG pendrive which can work on mobile and PC/Laptop. When I plug into the port the message pops up as sd/mmc card. I have recently burned on it one iso with Rufus 2.4 with multi bootable OS of 7, 8.1 and 10 bootable. I...
I have a 8GB Kingston pen-drive that refuses to be formatted. I noticed that it's write protected and tried to make it usable again, but nothing works. First I tried DiskPart as follows... ... but after all it remains protected ! I also...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:26.
Find Us