Page 1 of 2 12 LastLast
  1.    4 Weeks Ago #1
    Join Date : Jul 2015
    Nine Mile Falls WA
    Posts : 496
    win 10 pro x64

    Fall creator updated did something to my keyboard


    Help i have now light for caps lock or num lock, once in windows, they do work but the lights are not functioning they did before fall creator updated, i uninstalled keyboard and even reinstalled it no go , i even got the latest steelseries drivers nothing works. It's a steelseries apex gaming keyboard, i can't tell know when caps lock is on or off, or when num lock is on or off. i can when i first boot outside windows in bios and on boot, all functions fine, its something with fall creator. Also i had a unknown device inside device manager i uninstalled it rebooted and it never reappeared so it must have fixed that, can anyone help with my keyboard issue ?????
      My ComputerSystem Spec
  2.    4 Weeks Ago #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,976
    Win 10 Pro (1703)

    It's possible you may need to use an older driver for your keyboard.

    Research what's available: if you can find one, try it. If that works, you would need to protect it from being updated.
    There's a tutorial on how to do that on how to hide Windows Updates in the Tutorial section which you're free to browse and search.
      My ComputerSystem Spec
  3.    4 Weeks Ago #3
    Join Date : Jul 2015
    Nine Mile Falls WA
    Posts : 496
    win 10 pro x64
    Thread Starter

    i will give that a t ry is so wired it did this after the update i guess not everything can be perfect.
      My ComputerSystem Spec
  4.    4 Weeks Ago #4
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,976
    Win 10 Pro (1703)

    It's a bit like the old days of XP where some derisorily termed it 'Windows eXPerimental' - yet now we still have key industries, police etc still using XP.

    When you upgrade to a new build you get a new set of drivers. Some people in some circumstances find a driver doesn't quite work, whereas all was well with the old build.

    My approach- after a new build is released, wait at least until the first big update is released before upgrading, having seen the pattern.

    Or: create a disk image (so you can always revert regardless by restoring it - we continually and strenuously advise the routine use of disk imaging e.g. Macrium Reflect (free)- try the upgrade- if unsatisfactory- you can roll back, and worst case (e.g. unbootable) restore the image.

    Always act defensively.
      My ComputerSystem Spec
  5.    4 Weeks Ago #5
    Join Date : Jul 2015
    Nine Mile Falls WA
    Posts : 496
    win 10 pro x64
    Thread Starter

    have to hunt down a old driver looks like steelseries don't have them on the website, and it seems to be using the new one i put on. may if i can't find one be something i have to deal with .
      My ComputerSystem Spec
  6.    4 Weeks Ago #6
    Join Date : Aug 2015
    Posts : 11
    Windows 10 Pro

    I'm using a SteelSeries Apex with the Fall Update and none of my lock lights light up.
      My ComputerSystem Spec
  7.    4 Weeks Ago #7
    Join Date : Jul 2015
    Nine Mile Falls WA
    Posts : 496
    win 10 pro x64
    Thread Starter

    Quote Originally Posted by WastedJoker View Post
    I'm using a SteelSeries Apex with the Fall Update and none of my lock lights light up.
    hi here is what steelseries had me do, this is quoted from them verbatim copied from my support thread and it worked for me but make sure you leave it in the usb ports you move too or it will be right back to same old issue.


    Aaron NToday at 04:19

    Tony,

    Try doing a clean reinstall of both SSE and your device drivers using the following steps.

    Please note that this will delete any saved configures within SSE, so please save them to the cloud.

    1) Download and install CCleaner (it's free): http://www.piriform.com/ccleaner/download/standard

    2) Go to ‘Tools’ tab -> Uninstall
    Find the SteelSeries Engine and uninstall it.

    3) Go to the ‘Registry’ tab on the left side -> scan for issues -> fix selected issues

    Next, we will need to uninstall the existing driver( if there is one) completely.

    1) Make sure your SteelSeries Engine is up to date. Install the latest version if you have not already. It's very important that the latest version of SteelSeries Engine is installed PRIOR to taking the next steps. Please find the latest version at: http://steelseries.com/downloads

    2) Using the search functionality in Windows, search for "Device Manager" - click and open it
    Note: If this does not work, search for "Control Panel" and navigate to Device Manager

    3) Find the device in the device tree under 'human interface devices'

    4) Right click and select "Properties"
    4a) If there is a second or multiple entries related to the device, you will need to repeat this process.

    5) Click "Driver" on the top toolbar and select "Uninstall (Advanced)" at the bottom.

    6) Ensure the checkbox is checked and uninstall the driver.

    7) Once this is done, unplug the device and plug it into a different USB port to allow the driver to reinstall.

    Let me know if the issue persists.

    Regards,
    Aaron N



    SteelSeries Support

      My ComputerSystem Spec
  8.    4 Weeks Ago #8
    Join Date : Oct 2017
    Posts : 2
    windows 10

    Quote Originally Posted by WastedJoker View Post
    I'm using a SteelSeries Apex with the Fall Update and none of my lock lights light up.
    Same here. creators update is a complete mess
      My ComputerSystem Spec
  9.    4 Weeks Ago #9
    Join Date : Jul 2015
    Nine Mile Falls WA
    Posts : 496
    win 10 pro x64
    Thread Starter

    yup a mess for sure
      My ComputerSystem Spec
  10.    4 Weeks Ago #10
    Join Date : Oct 2017
    Posts : 2
    windows 10 64bit

    same problem here with the steelseries apex and the fall creators update with the lights issue with the caps lock etc,yet another reason to consider switching to linux,come on microsoft does every update you bring break components,this is getting beyond a joke now lets hope they fix it very soon.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Windows media creator for fall creators update...? Which version?
Which version do I suppose to get? Right now it's like this: 158335 Is it already the good version? Or do I have to wait a day longer (impatient me haha!) And how do I know it's updating to the last version. Oops, so many questions at once,...
Windows Updates and Activation
Errors using MS Keyboard Layout Creator w/ Win 10
Hi, I (no profi) used MKLC v1.4 to create a Keyboard w/ Latin characters such as 'macron'. Unicode definitions. The definition cycle had been done; only warnings caused to double usage of characters w/i different maps (shift/ ctrl/ ...). I stored...
General Support
Updated to windows 10 and now my mouse and keyboard are not working
I get to the splash screen and I have no mouse or keyboard functions. When I go I to bios the keyboard works but not the mouse. I have bought a new set of wired mouse and keyboard being the original ones were wireless. I need help
Drivers and Hardware
Dell Studio 540 updated to Win 10 - Keyboard driver not working
Good Day. I have upgraded my old Dell Studio 540 from Win 7 to Win 10. Everything seems to be working fine except the keyboard no longer works. In Device Manager the keyboard is now "Unknown Device" and automated device driver update attempted to...
Installation and Upgrade
Windows 10 - Logitech K800 keyboard (& USB keyboard) stops responding
I upgraded from Windows 8.1 (and I never had this problem), to Windows 10 and I noticing that my keyboard would stop responding in windows explorer, calculator, search, etc. The keyboard had no issues working in a browser like Chrome, but it...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 04:30.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums