1.    4 Weeks Ago #1
    Join Date : Jul 2017
    Posts : 35
    windows 10

    task supposed to wake up the computer isn't recognised by powercfg


    Since the task doesn't wake up the computer, I ran:
    Code:
     powercfg -devicequery wake_armed
    which doesn't find the task. Any idea why?

    This print screen summarized it:


    Click image for larger version. 

Name:	cmd_2017-10-15_20-51-53.png 
Views:	2 
Size:	31.3 KB 
ID:	158284
      My ComputerSystem Spec
  2.    4 Weeks Ago #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,928
    Win 10 Pro (1703)

    That indicates no hardware is presently configured to wake your system from sleep.

    It doesn't list tasks. What were you expecting?

    In your task schedule, what is the action you are interested in?

    Click image for larger version. 

Name:	1.jpg 
Views:	11 
Size:	26.7 KB 
ID:	158285

    The second command will tell you which devices can be configured to wake your system.

    I get the impression you are perhaps confusing two concepts...
      My ComputerSystem Spec
  3.    4 Weeks Ago #3
    Join Date : Jul 2017
    Posts : 35
    windows 10
    Thread Starter

    Thank you very much for your clarification dalchina! You are right I'm confused (I thought it would also list the task allowed to wake up the computer!)

    EDIT: I confuse 2 commands, here is the one I should have use
    in powershell:
    Code:
    Get-ScheduledTask | where {$_.settings.waketorun}
    The task (X morning_noise) should wake the computer up, but it doesn't. Any idea why?
    (I checked all settings in advance power, allow wake time is enabled.)
    Click image for larger version. 

Name:	mmc_2017-10-15_22-29-04.png 
Views:	9 
Size:	9.7 KB 
ID:	158297

    Click image for larger version. 

Name:	image.png 
Views:	10 
Size:	16.8 KB 
ID:	158292


    I ran a command few weeks ago which did show the task supposed to wake up the computer, I don't remember what it was. Any idea how to check if a task has been set to wake up the computer? (or why my task doesn't wake it up)


      My ComputerSystem Spec
  4.    4 Weeks Ago #4
    Join Date : Jul 2017
    Posts : 35
    windows 10
    Thread Starter

    Actually, the task does wake up the computer but doesn't manage to pass the login screen. (The computer wake up, the fan get excited for few second at the login screen, but that's all. As if it could not manage to enter the password)
      My ComputerSystem Spec
  5.    4 Weeks Ago #5
    Join Date : Jul 2017
    Posts : 35
    windows 10
    Thread Starter

    I solved it (by chance) : I just needed to add my user in the group policy:
    Code:
    “Computer Configuration-->Policies-->Windows Settings-->Security Settings-->Local Policies-->User Rights Assignment--> allow logon locally
      My ComputerSystem Spec
  6.    4 Weeks Ago #6
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,928
    Win 10 Pro (1703)

    Sounds good.. but could be an expensive alarm clock...
      My ComputerSystem Spec
  7.    4 Weeks Ago #7
    Join Date : Jul 2017
    Posts : 35
    windows 10
    Thread Starter

    I'm actually open to any other solution if this one is too risky
      My ComputerSystem Spec
  8.    4 Weeks Ago #8
    Join Date : Jul 2017
    Posts : 35
    windows 10
    Thread Starter

    I finally found a better trick: the task does need to log on to work. So I undo the policy editor edit, and I uncheck in the task the option "run whether the user is logged or not"
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved task only wake up the computer when it fall into sleep automatically
When I put the computer to sleep the task don't wake up. The task only manages to wake up the computer when the computer goes to sleep alone. Any idea how to solve that? ps: I have enabled in Power option: Power Options / Change Plan Settings...
General Support
Solved Sleep/Wake via Task Manager
I have a bat file(s) set up for Sleep and Wake via the Task Manager in W7 and W8 and now W10. I have Task Manger execute the Sleep bat file ever night at 10PM. I have tried "runddl32.exe powrprof.dll,suspendstate", "runddl32.exe...
General Support
powercfg and ps keeping my computer awake??
How do I stop the process nw.exe from keeping my computer from going to sleep. I know it's a powercfg command but I'm not sure of the options so any help would really be appreciated :) C:\WINDOWS\system32>powercfg -requests DISPLAY: None. ...
Performance & Maintenance
Task Scheduler does not always wake the computer
I'v tried just about everything, including selecting the "wake the computer" option. Hibernate or Sleep, it makes little difference. I would expect it to always work or never work, but to have it just work sometimes makes troubleshooting a real...
General Support
My computer is 32 bit when it's supposed to be 64 bit
In the About page under Settings, the system type says: 32-bit operating system, 64x-based processor. I tried looking this up but not many solutions worked, how can I fix this?
Installation and Upgrade
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 20:11.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums