Windows 10: "USB Device Not Recognized Device Descriptor Request Failed" but ... Solved

  1.    09 Oct 2017 #1

    "USB Device Not Recognized Device Descriptor Request Failed" but ...


    Hi,
    I sporadically gets the "USB Device Not Recognized Device Descriptor Request Failed"; however, while I have 6 USB devices connected, none of them seem to be the cause of the error. When I use devmgmt.msc to get the Hardware Ids, the value is simply "USB\DEVICE_DESCRIPTOR_FAILURE". I use TARGET software to control two joysticks and a rudder. (Besides these three USB devices I have a keyboard, a mouse and a TrackIR 5). In some instances everything works even though I got the error but in others instances none of the joysticks are working as expected. Sometimes restarting the computer helps or uninstalling the "mystic" USB device, however the problem always reappear and I would really like to get rid of it permanently.
    Anyone got some idea what could be causing this?
    I have updated all drivers but it did not help.
    Thanks,
    Klaus
      My ComputerSystem Spec


  2. Posts : 198
    Windows 10 Pro
       11 Oct 2017 #2

    Are these direct into the PC or are they running through a USB hub? Its possible there isnt being enough power being supplied via the port
      My ComputerSystem Spec

  3.    11 Oct 2017 #3

    They are connected directly to the computer (to potentially solve the problem I did add a small hub with two USB2 ports that runs the keyboard and mouse; however, the problem was present before and was not solved by adding the two new USB2 ports).
      My ComputerSystem Spec


  4. Posts : 198
    Windows 10 Pro
       12 Oct 2017 #4

    try the device's in a different pc and see if they do the same.

    Only other thing would be to remove ALL usb port drivers ans hosts and plug the device in question in by itself and see if it does it then. If it does i'd be inclined to suggest a fault with the device.
      My ComputerSystem Spec

  5.    12 Oct 2017 #5

    Thanks Kingtez for your suggestions. I think I figured it out, so in case someone else have the same problem here is what I believe fixed the problem. The software that runs the joysticks creates one virtual joystick. Under device manager and power management I had disabled "Allow the computer to turn of this device to save power" for all the USB devices directly connected to the computer except of course for the virtual joystick. I have not had the error since I disabled the power management for the virtual device, so crossing my fingers...
      My ComputerSystem Spec


 

Related Threads
When my girlfriend connects external USB device to any of the USB ports on Windows 10 Home she gets message: USB Device Not Recognized. She can not charge USB device via USB port. I went to device manager and under USB Controllers I see...
After installing Windows 10 anniversary update, I get the following error in the device manger: Unknown USB Device (Device Descriptor Request Failed) Tried uninstalling and restarting PC. Reinstalled Windows made from media tool. Nothing fixed...
Fresh install of Windows 10 and the last driver I need to sort out is the above. I believe it is my powered USB 3 hub to which I plug in my keyboard and mouse. Technically it is working but I don't like seeing yellow triangles on devices. So...
Hello, ok so after recently doing a clean install of windows 10(please don't get me started on that mess). my system has been plagued by random usb drops. it's where everything connected via USB suddenly disconnects then reconnects out of the blue....
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:47.
Find Us